Bug 243271 - Running wlassistant with sudo changes .ICEauthority permissions
Running wlassistant with sudo changes .ICEauthority permissions
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: wlassistant (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-08 07:03 EDT by The Source
Modified: 2008-01-02 16:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 16:10:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description The Source 2007-06-08 07:03:18 EDT
Description of problem:
They are changed to owner=root u=rw,g=none,o=none. And many programs experience
errors because of this.

Version-Release number of selected component (if applicable):
wlassistant-0.5.7-1.fc7

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Hector Centeno 2007-08-03 17:02:26 EDT
Same problem for me. It causes several applications to start malfunctioning.
Comment 2 Mariusz Wodzicki 2007-11-16 21:51:39 EST
Look also at my comment to Bug 306041

https://bugzilla.redhat.com/process_bug.cgi
Comment 3 Tom "spot" Callaway 2007-11-17 11:49:12 EST
Just for clarification, does this happen when you run "sudo
/usr/bin/wlassistant" or when you run /usr/sbin/wlassistant, and let pam take
care of the permissions?

There are new packages for F-7 here (they'll be in updates-testing on the next
push):
https://admin.fedoraproject.org/updates/F7/pending/wlassistant-0.5.7-5.fc7

Upgrade to wlassistant-0.5.7-5.fc7, and try just running /usr/sbin/wlassistant
(this is also how it is called from the desktop menu) without sudo.
Comment 4 Tom "spot" Callaway 2008-01-02 16:10:25 EST
Closing this one. Reopen if the updated wlassistant doesn't work (don't run it
with sudo, just run it.)

Note You need to log in before you can comment on or make changes to this bug.