Bug 306041 - wlassistant gives unknown error when opening in GNOME.
wlassistant gives unknown error when opening in GNOME.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wlassistant (Show other bugs)
7
i686 Linux
low Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-25 16:07 EDT by Jeff Makus
Modified: 2008-01-06 20:17 EST (History)
0 users

See Also:
Fixed In Version: 0.5.7-5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 20:12:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My pam.d file for wlassist (300 bytes, application/octet-stream)
2007-09-25 16:07 EDT, Jeff Makus
no flags Details

  None (edit)
Description Jeff Makus 2007-09-25 16:07:34 EDT
Description of problem:

wlassistant gives unknown error when opening in GNOME (wlassistant icon).  I
think that the PAM file for wlassistant is wrong or something.  It should ask
for the root password.

When I open in a terminal window it runs.  Here is a snippet of text from the
console. I am a normal user.

wlassistant
kbuildsycoca running...
Loaded application options.
All interfaces: eth0, wlan0
Wireless interface(s): wlan0
warning: /etc/resolv.conf not writable
Permissions checked.
DHCP Client: dhclient
All executables found.
scan: /sbin/iwlist wlan0 scan
Networks found: 1
Application options saved.
Kernel socket closed.

In a gnome window it says "You may have insufficient permissions for Wireless
Assistant to function properly.  Did you run it using 'sudo'?  OK button

I run the as root from the console and it works fine.  

When I an a normal user I should be able to run the wlassistant icon and it
should prompt me for a root password....

Version-Release number of selected component (if applicable):
wlassistant.i386  0.5.7-3.fc7
wlassistant.i386  0.5.7-1.fc7 

How reproducible:
Happens every time.

Steps to Reproduce:
1.  Run icon
2.  error comes up
Comment 1 Jeff Makus 2007-09-25 16:07:34 EDT
Created attachment 206001 [details]
My pam.d file for wlassist
Comment 2 Mariusz Wodzicki 2007-11-16 21:50:02 EST
This bug remains unresolved in the newest version, wlassistant-0.5.7-4.fc8,
but I think some clarifications to the original bug report are due.

Executing, without root privilages, /usr/sbin/wlassistant on the shell command
line  results in a pop-up window with the error message: "Unknown error".

Exactly the same happens when clicking, without root privilages, on

  System -> Preferences -> Wireless Assistant

since the latter also executes /usr/sbin/wlassistant

On the other hand, executing `wlassistant' on the command line opens up first
the Wireless Assistant window, and a moment later a window saying:

"You might have insufficient permissions for Wireless Assistant to function
properly.

Did you run it using 'sudo'?"

Just hit `OK', or press `Enter', at this point.


Note that the full path to `wlassistant' is /usr/bin/wlassistant, while
/usr/sbin/wlassistant is a symbolic link to /usr/bin/consolehelper

Executing /usr/sbin/wlassistant as a root seems to have the same effect as
executing /usr/bin/wlassistant


Thus, a probable cause of the bug is a typo in the file

  /usr/share/applications/fedora-wlassistant.desktop

Proposed solution:

change '/usr/sbin/wlassistant' to '/usr/bin/wlassistant' in that file.


A temporary workaround that does not require root privilages:

1) go to System -> Preferences -> Look and Feel -> Main Menu
2) in the `Menus' pane click on System -> Preferences
3) in the `Items' pane right click on `Wireless Assistant'
4) select `Properties'
5) change '/usr/sbin/wlassistant' to '/usr/bin/wlassistant'


Caveat:

There was an earlier bug report

https://bugzilla.redhat.com/show_bug.cgi?id=243271

about "wlassistant with sudo changing .ICE authority". I don't know how serious
that can be. Neither do I know whether this still affects the newest version of
Wireless Assistant.

If in doubt, execute `wlassistant' or `/usr/sbin/wlassistant' as root from the
command line.
Comment 3 Tom "spot" Callaway 2007-11-17 11:06:17 EST
No, this is not correct. The /usr/sbin/wlassistant symlink is designed so that
it can hook into pam, and have the user prompted for the root password, and then
run with root permissions.

It used to leverage pam_console for this, but that no longer works, and I
apparently broke things when I made that change. I'm working on fixing this
properly now, should knock all of the (filed) wlassistant bugs out.
Comment 4 Fedora Update System 2007-11-20 12:52:55 EST
wlassistant-0.5.7-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wlassistant'
Comment 5 Fedora Update System 2007-11-20 12:53:19 EST
wlassistant-0.5.7-5.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wlassistant'
Comment 6 Fedora Update System 2008-01-06 20:12:54 EST
wlassistant-0.5.7-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2008-01-06 20:17:13 EST
wlassistant-0.5.7-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.