Bug 243374 - installation from live-image still doesnt work
Summary: installation from live-image still doesnt work
Status: CLOSED DUPLICATE of bug 244913
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-08 16:22 UTC by Holger Levsen
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-21 18:19:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
build log (42.02 KB, text/plain)
2007-07-09 16:54 UTC, Holger Levsen
no flags Details
config file used (6.94 KB, text/plain)
2007-07-09 16:56 UTC, Holger Levsen
no flags Details

Description Holger Levsen 2007-06-08 16:22:37 UTC
Description of problem:

The problem is described in 
https://www.redhat.com/archives/fedora-livecd-list/2007-June/msg00023.html
where also the anaconda traceback is attached.


Version-Release number of selected component (if applicable):

This time I used anaconda from F7 plus installclass.py from CVS trunk (to fix 
#242083) and livecd.py (to fix #241754), also from trunk.



How reproducible:


Steps to Reproduce:

config and iso image availabe at 

http://xs-dev.laptop.org/xs-live-installer/200706081955*
  
Actual results:


Expected results:


Additional info:

Comment 1 Chris Lumens 2007-06-15 17:41:26 UTC
What sort of partitioning selections did you make?  Can you attach /tmp/syslog
to this bug report when the exception occurs?

Comment 2 Holger Levsen 2007-06-28 15:32:01 UTC
Quoting from the used config file which is available 
athttp://xs-dev.laptop.org/xs-live-installer/200706081955-livecd-xs-installer.ks 
(as described in this bug :) the build log is at 
http://xs-dev.laptop.org/xs-live-installer/200706081955-build.log - the 
resulting iso at 
http://xs-dev.laptop.org/xs-live-installer/200706081955-XS.iso


# The following is the partition information you requested
# Note that any partitions you deleted are not expressed
# here so unless you clear all partitions first, this is
# not guaranteed to work
clearpart --linux --drives=sda
part /boot --fstype ext3 --size=100 --ondisk=sda
part pv.6 --size=0 --grow --ondisk=sda
volgroup VolGroup00 --pesize=32768 pv.6
logvol / --fstype ext3 --name=LogVol00 --vgname=VolGroup00 --size=1024 --grow
logvol swap --fstype 
swap --name=LogVol01 --vgname=VolGroup00 --size=512 --grow --maxsize=1024


I'll provide /tmp/syslog shortly, once I've redone an installation with that 
iso.

Comment 3 Daniel Jared Dominguez 2007-06-29 15:16:05 UTC
Here is a copy of the install log:
http://xs-dev.laptop.org/xs-live-installer/20070627-install.log

Comment 4 Sean Bruno 2007-07-08 22:12:07 UTC
http://xs-dev.laptop.org/xs-live-installer/20070627-install.log

Isn't a valid URL any longer.  Please just attach the failures to the ticket, so
there isn't any issues with looking over your errors.

Comment 5 Holger Levsen 2007-07-09 16:53:52 UTC
You hit an unfortunate moment in time, when xs-dev's webserver was 
misconfigured. It should stay up now ;)

I'm attaching the log and config-file now anyway.

Comment 6 Holger Levsen 2007-07-09 16:54:38 UTC
Created attachment 158785 [details]
build log

Comment 7 Holger Levsen 2007-07-09 16:56:30 UTC
Created attachment 158786 [details]
config file used

Comment 8 Holger Levsen 2007-07-16 17:11:42 UTC
any news on this bug? it's currently a little blocker for the olpc 
schoolserver installation "cd"s... 

Comment 9 Jeremy Katz 2007-07-16 21:05:32 UTC
(Sorry, I've been traveling)

The attached bug is the unfixed livecd.py.  And since you sent mail, I *think*
I've fixed what you were hitting from the earlier mail (if you have a separate
/usr, things were falling over due to dangling symlinks in the redhat-artwork
package).  I'm not quite sure why you'd hit that iwthout a separate /usr, though.   

Downloading (slowly) your current iso to hopefully give it a try before I leave
today, but I'm then out of the office again tomorrow.

Comment 10 Holger Levsen 2007-08-21 18:19:40 UTC
finally I can confirm that this bug indeed has been fixed and this bug is a 
duplicate of #244913

Using anaconda/livecd.py from 2007-06-26 works nicely.

*** This bug has been marked as a duplicate of 244913 ***

Comment 11 Jeremy Katz 2007-08-21 18:26:07 UTC
Great, thanks Holger!


Note You need to log in before you can comment on or make changes to this bug.