Bug 244913 - anaconda fails performing post-installation file system changes from live cd
Summary: anaconda fails performing post-installation file system changes from live cd
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 243374 246055 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-19 20:03 UTC by R Bruce Hoffman
Modified: 2007-11-30 22:12 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 21:55:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
reported output from anaconda scp'd to other box (fc6) (116.54 KB, text/plain)
2007-06-19 20:03 UTC, R Bruce Hoffman
no flags Details

Description R Bruce Hoffman 2007-06-19 20:03:19 UTC
Description of problem:
Anaconda fails after copying live image to hard drive while performing
post-installation file system changes.

Version-Release number of selected component (if applicable):


How reproducible: 
4 or 5 tries, unsuccessful

Steps to Reproduce:
1. Load live cd, boot up, log in as root, choose install on hard drive
2. Choose review of file system layout
3. Set up LVM with /=5G, /home=10G, /tmp=5G, /usr=15G, /usr/local=10G, /var=2G
and swap at 2G
4. Get through the rest
5. Let er rip.
  
Actual results:
attached

Expected results:
An install

Additional info:

Comment 1 R Bruce Hoffman 2007-06-19 20:03:19 UTC
Created attachment 157412 [details]
reported output from anaconda scp'd to other box (fc6)

Comment 2 Jeremy Katz 2007-06-20 14:40:04 UTC
Is it still up -- can you see what's running that's stopping /mnt/sysimage/usr
from being unmounted?

Comment 3 R Bruce Hoffman 2007-06-25 17:22:08 UTC
No, it wasn't still up.

I tried this again today, on a spare 30G drive on my thinkpad and got the same
results with different sizes for the partitions.

The fuser shows all the processes using the /mnt but nothing about the
/mnt/sysimage/usr and when I do a straight umount against the /mnt/sysimage/usr
I get "in use" and "not in mtab".

I will leave this one up for a while, so, if there is something specific I can
do to find the user, feel free to let me know.

Comment 4 Jeremy Katz 2007-06-25 17:44:45 UTC
Try `ls -lR /proc/*/fd` and see if there's anything referencing /mnt/sysimage/usr.

And I'll try to set up a reproducer a bit later today if you don't get anything.

Comment 5 R Bruce Hoffman 2007-06-25 17:48:15 UTC
Here's an oddity...

Listing out the /proc/mounts I see that /usr/local (which is one of the
partitions that I allocate separately) is still mounted under /usr...

So, I unmount /mnt/sysimage/usr/local and then I can unmount /mnt/sysimage/usr.

It would seem that either the process knows nothing about allocating /usr/local
or it's a sequencing error.


Comment 6 Jeremy Katz 2007-06-25 18:15:22 UTC
Aha, I see what's going on.  It's definitely due to the /usr/local mountpoint. 
When we go to do the rearranging of bits, it doesn't taken into accounts mount
like that.  Working on a fix...

Comment 7 Jeremy Katz 2007-06-25 21:55:35 UTC
Okay, fixed in anaconda CVS but I want to spend a little bit more time testing
it before being comfortable committing it on the F7 branch for a future update.
 If you want to grab it and test it you can do
  cvs -d:pserver:anonymous@rhlinux.redhat.com:/usr/local/CVS co anaconda/livecd.py

and replace /usr/lib/anaconda/livecd.py with it

Comment 8 Jeremy Katz 2007-06-28 14:57:19 UTC
*** Bug 246055 has been marked as a duplicate of this bug. ***

Comment 9 Holger Levsen 2007-08-21 18:19:43 UTC
*** Bug 243374 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.