Bug 24346 - GUI install display offset
GUI install display offset
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 25158 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-19 05:14 EST by Gene Czarcinski
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-09 16:20:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2001-01-19 05:14:03 EST
I did a gui install.  The video is a RIVA TNT2 with a Dell flat panel
(FP1700).  The display was offset about 0.3 inches to the right which made
it difficult to see/use the scroll bar on the right side.

Video setup worked OK with both the video card and the display being
recognized correctly and selecting 1280x1024 resolution properly positioned
on the panel.
Comment 1 Michael Fulbright 2001-01-19 11:35:59 EST
If you try passing it the proper framebuffer vga=nnn value on the boot
commandline for the installer, does it come up ok?

These values are in the Documentation/ directory of the kernel source, in a file
about the framebuffer. I would try the value for the 1280x1024 mode that works.
Comment 2 Gene Czarcinski 2001-01-21 16:45:18 EST
Huh??  Framebuffer settings??

I am talking about the anaconda gui install (VGA?) screen which is offset.  I
just booted the install disk (like any other user) and it came up offset to the
right.

After installation, the screen came up fine with the selected 1280x1024.
Comment 3 Michael Fulbright 2001-01-24 11:56:37 EST
You can boot the installer with a vga=xxx command line to tell the kernel
framebuffer what resolution to use.  The installer will use this mode.

If you specify this it might run the installer at 1280x1024 and work around
the image shift problem.
Comment 4 Gene Czarcinski 2001-01-31 06:34:03 EST
I tried "nofb" -- no different.

I also tried "lowres" -- this went to text mode.

I have no idea what to specify for "vga=xxx"
Comment 5 Brent Fox 2001-02-02 04:01:46 EST
Try passing vga=793 at the boot prompt.  That will put the kernel in 1280x1024
resolution and 16 bit color.
From the /usr/src/linux/Documentation/fb/vesafb.txt file, here are the valid
framebuffer modes for the kernel:

    | 640x480  800x600  1024x768 1280x1024
----+-------------------------------------
256 |  0x301    0x303    0x305    0x307
32k |  0x310    0x313    0x316    0x319
64k |  0x311    0x314    0x317    0x31A
16M |  0x312    0x315    0x318    0x31B

These numbers are in hexadecimal, so if you convert 319 (Hex) to decimal, you'll
get 793.  I use the Scientific Calculator in KDE to do the conversions easily.
See if that doesn't make the installer line up correctly.  You should see the
installer appear in a 800x600 window in the middle of the screen.
Comment 6 Brent Fox 2001-02-02 04:18:29 EST
*** Bug 25158 has been marked as a duplicate of this bug. ***
Comment 7 Gene Czarcinski 2001-02-02 13:04:54 EST
Sorry but specifying vga=793 at the INSTALLER boot prompt had exactly zero
effect.

I also tried nofb vga=793 and while I got no framebuffer stuff during kernel
bootup, XFree still used the frame buffer driver and had the right shift offset.

BTW, while 25158 MAY be a dup of this bug, I could get around the LEFT shight by
specifying NOFB.
Comment 8 Brent Fox 2001-02-09 16:19:55 EST
Ok, one last try.  Try passing vga=794 at the boot prompt.  If this doesn't
work, I'm out of ideas.
Comment 9 Brent Fox 2001-02-09 20:26:27 EST
I don't think this is anything we can do in software to fix this.

Note You need to log in before you can comment on or make changes to this bug.