Bug 243479 - sm-client daemon for sendmail fails to start with permission denied error
Summary: sm-client daemon for sendmail fails to start with permission denied error
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda   
(Show other bugs)
Version: 7
Hardware: i686
OS: Linux
low
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords:
: 247388 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-08 22:02 UTC by Larry O'Leary
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-28 17:03:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda LOG (109.25 KB, text/plain)
2007-06-25 18:13 UTC, Larry O'Leary
no flags Details

Description Larry O'Leary 2007-06-08 22:02:51 UTC
Description of problem:

When attempting to start sendmail, sm-client fails to start with the following
error message:

can not chdir(/var/spool/clientmqueue/): Permission denied
Program mode requires special privileges, e.g., root or TrustedUser.


Version-Release number of selected component (if applicable):
8.14.1

How reproducible:
After performing an install using the F7 Live CD, attempt to start the sendmail
service:

service sendmail stop
service sendmail start

  
Actual results:
sendmail appears to start but sm-client indicated FAILED

Expected results:
sendmail and sm-client should indicate a status of OK

Additional info:
This issue appears to be caused by the sendmail.sendmail binary in /usr/sbin
being set to setgid.  The file attributes are:

-rwxr-sr-x 1 root smmsp 827548 2007-04-16 04:24 sendmail.sendmail


The directory /var/spool/clientmqueue/ is owned by root and belongs to the group
root.  It appears as:

drwxrwx--- 2 root root 4096 2007-04-16 04:24 /var/spool/clientmqueue


The problem goes away and sendmail and sm-client show status of OK after the
following command is executed:

chown smmsp:smmsp /var/spool/clientmqueue

Comment 1 Thomas Woerner 2007-06-11 16:29:57 UTC
Assigning to anaconda.

Comment 2 Jeremy Katz 2007-06-25 17:30:16 UTC
How did you do your installation?  Can you attach /root/install.log and
/var/log/anaconda.log?

Comment 3 Larry O'Leary 2007-06-25 18:13:07 UTC
Created attachment 157774 [details]
Anaconda LOG

Here is the anaconda.log file that was requested.

Comment 4 Larry O'Leary 2007-06-25 18:16:26 UTC
I did the install from the Fedora Live CD.  Just downloaded the ISO, burned a
CD, booted the laptop and selected the Copy to Hard Drive option from the Desktop.

I do not have an install.log file located in /root.  Not sure why.

Comment 5 Jeremy Katz 2007-06-28 17:03:36 UTC
Okay, I see what it is.  Separate /var is what is causing it.  Fixed in CVS

Comment 6 Jeremy Katz 2007-07-09 15:37:01 UTC
*** Bug 247388 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.