Bug 247388 - F7 Live Install Leaves Bad Permissions in /var
F7 Live Install Leaves Bad Permissions in /var
Status: CLOSED DUPLICATE of bug 243479
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
i686 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-07-08 14:47 EDT by Garry T. Williams
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-09 11:36:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Garry T. Williams 2007-07-08 14:47:36 EDT
Description of problem:
Many directories in /var are installed with incorrect owners.  This leads to
multiple problems immediately after first boot.  See bug #243482 for example.  
The sendmail client daemon fails to start.  The root user's mail from cron isn't
delivered anywhere.

Version-Release number of selected component (if applicable):
F7 Live CD

How reproducible:
The problem seems to be hardware specific.  I have reproduced it on a Dell
Latitude 610 and a Sony Vaio FS640/W.  I cannot reproduce it on a Dell E520.

Steps to Reproduce:
1.  Install from Live CD
Actual results:
hald and sendmail fail to start at first (and subsequent) boots.

Expected results:
Services start.

Additional info:


chown haldaemon:haldaemon /var/cache/hald
chown smmsp:smmsp /var/spool/clientmqueue
chown root:mail /var/spool/{mail,mqueue}
chown rpm:rpm /var/spool/repackage
chown torrent:torrent /var/spool/bittorrent
chgrp mail /var/spool/mail/*
chgrp lock /var/lock
chown torrent:torrent /var/log/bittorrent

(All of the above directories and files were originally root:root owned instead
of their correct owners.)

/etc/init.d/haldaemon stop
/etc/init.d/haldaemon start
/etc/init.d/senmail stop
/etc/init.d/senmail start
Comment 1 Jeremy Katz 2007-07-09 11:36:58 EDT

*** This bug has been marked as a duplicate of 243479 ***

Note You need to log in before you can comment on or make changes to this bug.