Bug 243508 - nedit can not copy/paste: Attempt to copy to unlocked clipboard!
nedit can not copy/paste: Attempt to copy to unlocked clipboard!
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lesstif (Show other bugs)
6
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
: 217163 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 05:56 EDT by Gert Vervoort
Modified: 2007-11-30 17:12 EST (History)
5 users (show)

See Also:
Fixed In Version: 0.95.0-19.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 12:44:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gert Vervoort 2007-06-09 05:56:34 EDT
Description of problem:

copy/paste of text in nedit is not possible.
On the xterm from which nedit was started the message "Attempt to copy to
unlocked clipboard!" appears and incorrect data will be pasted.

Version-Release number of selected component (if applicable):

nedit.x86_64  5.5-10.fc6

How reproducible:

always

Steps to Reproduce:
1. start nedit file.txt
2. select same text and type <ctrl>-c (or via the menu: edit - copy)
3. the message "Attempt to copy to unlocked clipboard!" will now appear in the
xterm on which nedit was started from.
4. now type <ctrl>-v (or via the menu: edit - paste) and now either nothing or
wrong data (from a previous app) will be pasted.
  
Actual results:

- the message "Attempt to copy to unlocked clipboard!" appears
- wrong or no data pasted.

Expected results:

- no error/warning message
- the data copied will be pasted

Additional info:
Comment 1 Sammy 2007-06-13 14:37:22 EDT
Check the nedit site for mailings. I think this has to do with motif or
lesstif.
Comment 2 Gert Vervoort 2007-06-13 15:18:05 EDT
Before I upgraded to FC6, nedit worked without any problems in FC5.

Bug 1440331 from the nedit bug tracker suggests that it is related to lesstif:
https://sourceforge.net/tracker/?func=detail&atid=111005&aid=1440331&group_id=11005

Comment 3 Jindrich Novy 2007-06-18 07:21:23 EDT
Yes, it is lesstif bug, reassigning. Just the reference to upstream:

http://www.nedit.org/pipermail/develop/2006-May/011953.html

This applies also for F7/rawhide.
Comment 4 Thomas Woerner 2007-06-18 07:23:30 EDT
Reassigning to FC6-extras.
Comment 5 Ian Mortimer 2007-07-11 23:52:27 EDT
Also applies to Fedora 7 (affecting nedit on x86_64).
Comment 6 Hans de Goede 2007-08-30 18:43:46 EDT
Nasty 64 bit only bug (sizeof long != sizeof int problem), a fixed version is
building for both rawhide and F-7, I'll push it to updates-testing when the
build is completed, a comment saying that the update is available in
updates-testing will be added here. Gert and/or Ian, please confirm that the
test update fixes this, then I will push it to the regular updates repo.
Comment 7 Hans de Goede 2007-08-30 18:59:06 EDT
*** Bug 217163 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2007-09-04 18:06:25 EDT
lesstif-0.95.0-19.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2007-09-12 12:44:05 EDT
lesstif-0.95.0-19.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 David Jansen 2007-09-18 04:22:05 EDT
Perhaps unrelated, but now I experience a problem on Fedora 7, i386:
$ rpm -q lesstif
lesstif-0.95.0-19.fc7.i386
schelde:jansen [~] $ nedit
nedit: the current locale is utf8 (en_GB.UTF-8)
nedit: changed locale to non-utf8 (en_GB)
Segmentation fault

The segmentation fault occurs when I try to do what was the original problem on
the 64-bit systems: copy tekst (ctrl-c or from menu). Ctrl-v alsso causes a
segmentation fault

Could it be that the 64-bit fix messed up the 32-bit versions?
Comment 11 Hans de Goede 2007-09-18 05:00:04 EDT
Yes, my bad an update fixing this has been pushed to F-7 updates today, so a yum
update should fix it.
Comment 12 David Jansen 2007-09-19 05:43:05 EDT
thanks, the i386 problem is fixed now too.

Note You need to log in before you can comment on or make changes to this bug.