Bug 243550 - Democracy 0.9.5.1-8.fc7 crashes on startup
Democracy 0.9.5.1-8.fc7 crashes on startup
Status: CLOSED DUPLICATE of bug 241981
Product: Fedora
Classification: Fedora
Component: Democracy (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Thorsten Scherf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 12:54 EDT by tengel
Modified: 2013-01-09 23:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-15 05:06:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tengel 2007-06-09 12:54:17 EDT
NOTE: there is no 'Democracy' component, assigning to dbus-python since it's the
related package causing the error.

Description of problem:

Attempting to run/start democracyplayer crashes on startup with a TypeError in
the dbus-python bindings.

Version-Release number of selected component (if applicable):

Democracy-0.9.5.1-8.fc7
dbus-python-0.80.2-3.fc7

How reproducible:

Consistently.

Steps to Reproduce:
1. yum install Democracy
2. democracyplayer
3.
  
Actual results:

/usr/bin/democracyplayer:81: DeprecationWarning: The dbus_bindings module is
deprecated and will go away soon.

dbus-python 0.80 provides only a partial emulation of the old
dbus_bindings, which was never meant to be public API.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  import dbus_bindings
/usr/lib/python2.5/site-packages/dbus_bindings.py:5: DeprecationWarning: The
dbus_bindings module is deprecated and will go away soon.

dbus-python 0.80 provides only a partial emulation of the old
dbus_bindings, which was never meant to be public API.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  from dbus.dbus_bindings import *
Traceback (most recent call last):
  File "/usr/bin/democracyplayer", line 89, in <module>
    onetime.OneTime()
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 105, in
__init__
    bus_name = BusNameFlags('org.participatoryculture.dtv.onetime', bus=bus,
flags=dbus.dbus_bindings.NAME_FLAG_DO_NOT_QUEUE)
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 53, in __new__
    retval = dbus.dbus_bindings.bus_request_name(bus.get_connection(), name,
flags=flags)
TypeError: request_name() takes no keyword arguments

Expected results:

Unknown, never used Democracy before. I would assume some sort of GUI window
like in the screenshots. :)

Additional info:

A full rpm -Va was run to ensure there were no dependency problems known.
Additionally, 'yum upgrade' was run to ensure the latest available components
across the board.
Comment 1 Laurent Rineau 2007-06-14 05:49:22 EDT
I confirm the bug.

Same arch (i386). My rpm versions are identical:
  Democracy-0.9.5.1-8.fc7
  dbus-python-0.80.2-3.fc7
    (and python-2.5-12.fc7)
Comment 2 Joshua Daniel Franklin 2007-06-14 14:44:14 EDT
This closed ticket (with patches) at the Democracy trac site makes 
me think that the problem may be solved in 0.9.6:

https://develop.participatoryculture.org/trac/democracy/ticket/5645
Comment 3 David Zeuthen 2007-06-14 16:16:26 EDT
Reassigning to distribution until there's an appropriate bug component.
Comment 4 Thorsten Scherf 2007-06-15 05:06:44 EDT

*** This bug has been marked as a duplicate of 241981 ***

Note You need to log in before you can comment on or make changes to this bug.