Bug 241981 - Democracy fails to start - dbus_bindings
Summary: Democracy fails to start - dbus_bindings
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: Democracy   
(Show other bugs)
Version: 7
Hardware: All Linux
low
urgent
Target Milestone: ---
Assignee: Thorsten Scherf
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 230800 243550 243558 243603 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-01 02:30 UTC by Jason Farrell
Modified: 2007-11-30 22:12 UTC (History)
7 users (show)

Fixed In Version: 0.9.5.1-10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-02 23:07:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Farrell 2007-06-01 02:30:57 UTC
Description of Problem:
Democracy-0.9.5.1-8.fc7 fails to run on a fresh install of F7. Bombs out with a
dbus_bindings problem:

Additional Info:
$ democracyplayer
/usr/bin/democracyplayer:81: DeprecationWarning: The dbus_bindings module is
deprecated and will go away soon.

dbus-python 0.80 provides only a partial emulation of the old
dbus_bindings, which was never meant to be public API.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  import dbus_bindings
/usr/lib/python2.5/site-packages/dbus_bindings.py:5: DeprecationWarning: The
dbus_bindings module is deprecated and will go away soon.

dbus-python 0.80 provides only a partial emulation of the old
dbus_bindings, which was never meant to be public API.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  from dbus.dbus_bindings import *
Traceback (most recent call last):
  File "/usr/bin/democracyplayer", line 89, in <module>
    onetime.OneTime()
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 105, in
__init__
    bus_name = BusNameFlags('org.participatoryculture.dtv.onetime', bus=bus,
flags=dbus.dbus_bindings.NAME_FLAG_DO_NOT_QUEUE)
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 53, in __new__
    retval = dbus.dbus_bindings.bus_request_name(bus.get_connection(), name,
flags=flags)
TypeError: request_name() takes no keyword arguments

Comment 1 Silas Sewell 2007-06-01 03:19:11 UTC
Workaround (not really):

Run with superuser privileges.

Comment 2 Thorsten Scherf 2007-06-01 06:45:16 UTC
*** Bug 230800 has been marked as a duplicate of this bug. ***

Comment 3 Thorsten Scherf 2007-06-01 06:46:11 UTC
problem is sent upstream. waiting for feedback.


Comment 4 Thorsten Scherf 2007-06-02 18:43:07 UTC
0.9.5.1-10 should fix this problem. any anybody verify this?!


Comment 5 Silas Sewell 2007-06-02 18:52:02 UTC
I am also having this problem, Ubuntu has a thread on it too.

https://bugs.launchpad.net/ubuntu/+source/democracyplayer/+bug/81798

Comment 6 Jason Farrell 2007-06-02 23:07:32 UTC
Thorsten, it seems to be working just great now - thanks. It did take a couple
minutes to upgrade the db from the previous version before the GUI popped up,
though.

http://koji.fedoraproject.org/koji/buildinfo?buildID=7820



Comment 7 Eric Doutreleau 2007-06-03 13:01:44 UTC
 would love to test but where do i find the 0.9.5.1-10 version?

Comment 8 Eric Doutreleau 2007-06-03 14:45:21 UTC
just found it

it works

Comment 9 Thorsten Scherf 2007-06-09 20:38:32 UTC
*** Bug 243558 has been marked as a duplicate of this bug. ***

Comment 10 Thorsten Scherf 2007-06-11 17:30:54 UTC
*** Bug 243603 has been marked as a duplicate of this bug. ***

Comment 11 Thorsten Scherf 2007-06-15 09:06:49 UTC
*** Bug 243550 has been marked as a duplicate of this bug. ***

Comment 12 Andre Robatino 2007-07-21 02:12:19 UTC
  Still broken for me with Democracy-0.9.5.1-11.fc7 and everything else fully
updated.  Please reopen.

[andre@localhost ~]$ democracyplayer 
/usr/lib/python2.5/site-packages/dbus_bindings.py:1: DeprecationWarning: The
dbus_bindings module is not public API and will go away soon.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  from dbus.dbus_bindings import *
Traceback (most recent call last):
  File "/usr/bin/democracyplayer", line 89, in <module>
    onetime.OneTime()
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 112, in
__init__
    dbus.service.Object.__init__(self, bus_name,
'/org/participatoryculture/dtv/OneTime')
  File "/usr/lib/python2.5/site-packages/dbus/service.py", line 424, in __init__
    self._connection._register_object_path(object_path, self._message_cb,
self._unregister_cb)
AttributeError: 'BusNameFlags' object has no attribute '_register_object_path'
Exception exceptions.NameError: "global name 'dbus_bindings' is not defined" in
<bound method BusNameFlags.__del__ of <dbus.service.BusName
org.participatoryculture.dtv.onetime on <dbus.Bus on SESSION at 0xb7bd72fc> at
0xb7bdca2c>> ignored
[andre@localhost ~]$ rpm -q Democracy
Democracy-0.9.5.1-11.fc7
[andre@localhost ~]$

Comment 13 Andre Robatino 2007-07-21 07:13:20 UTC
  Ignore my previous message.  My problem appears slightly different and is
already assigned as bug #244889.


Note You need to log in before you can comment on or make changes to this bug.