Bug 243553 - kernel/softirq.c bug, blocks Xvnc connections.
kernel/softirq.c bug, blocks Xvnc connections.
Status: CLOSED DUPLICATE of bug 240982
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
urgent Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 13:21 EDT by Bill C. Riemers
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-11 09:36:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/usr/share/gdm/defaults.conf (30.83 KB, application/octet-stream)
2007-06-09 13:21 EDT, Bill C. Riemers
no flags Details

  None (edit)
Description Bill C. Riemers 2007-06-09 13:21:12 EDT
Description of problem:

Kernel bug reported when attempting to connect via Xvnc using a gdm greeter. 
This prevents Xvnc logins.

Version-Release number of selected component (if applicable):


How reproducible:

always


Steps to Reproduce:
1. Using libvirt, install a F-7 qemu guest.
2. On the guest change the /usr/share/gdm/defaults.conf
3. reboot the guest.
4. Attemt to connect to the guest from the host using vnc.

  
Actual results:

The vnc session reports the greeter failed.  A kernel bug is reported on the guest.

Expected results:

A gdmgreeter login should be displayed.


Additional info:

This message was displayed on the console:

BUG: warning at kernel/softirq.c:138/local_bh_enbale() (Not tainted)
 [<c042b0cf>] local_bh_enable+0x45/0x92
 [<c06002bd>] cond_resched_softirq+0x2c/0x42
 [<c059adf3>] release_sock+0x4f/0x9d
 [<c05c670d>] tcp_sendmsg+0x90b/0x9f9
 [<c04808a3>] core_sys_select+0x1df/0x2f3
 [<c05dec95>] init_sendmsg+0x3b/0x45
 [<c0598731>] sock_aio_write+0xf6/0x102
 [<c045b740>] generic_file_aio_write+0x5e/0xb3
 [<c043ad9a>] clocksource_get_next+0x39/0x3f
 [<c04754ee>] do_sync_write+0xc7/0x10a
 [<c042e38b>] do_timer+0x4f2/0x6f3
 [<c0436e71>] autoremove_wake_function+0x0/0x35
 [<c0475d47>] vfs_write+0xbc/0x154
 [<c0476342>] sys_write+0x41/0x67
 [<c0404f70>] syscall_call+0x7/0x5
 =======================

I do not know if the following information is relevent:  My guest system is a
i686 install.  My host is on x86_64.  I installed the kqemu kernel module on the
host, so I can use acceleration, since my machine does not support kvm.
Comment 1 Bill C. Riemers 2007-06-09 13:21:12 EDT
Created attachment 156654 [details]
/usr/share/gdm/defaults.conf
Comment 2 Gianluca Varisco 2007-06-11 05:33:53 EDT
According to comment #47 posted into BUG 240982, the problem regarding
"kernel/softirq.c" was resolved in the latest kernel (2.6.21-1.3226.fc7) and
mkinitrd (6.0.9-6) packages. 
Comment 3 Bill C. Riemers 2007-06-11 09:36:22 EDT

*** This bug has been marked as a duplicate of 240982 ***

Note You need to log in before you can comment on or make changes to this bug.