Bug 243558 - Demoncracy crash on Startup
Demoncracy crash on Startup
Status: CLOSED DUPLICATE of bug 241981
Product: Fedora
Classification: Fedora
Component: Democracy (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Thorsten Scherf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 14:27 EDT by Daryll
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-09 16:38:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daryll 2007-06-09 14:27:03 EDT
It looks like there's some version mismatch between Democracy and Dbus-python.

When I start democracy player (Democracy-0.9.5.1-8.fc7) I get:

/usr/bin/democracyplayer:81: DeprecationWarning: The dbus_bindings module is
deprecated and will go away soon.

dbus-python 0.80 provides only a partial emulation of the old
dbus_bindings, which was never meant to be public API.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  import dbus_bindings
/usr/lib/python2.5/site-packages/dbus_bindings.py:5: DeprecationWarning: The
dbus_bindings module is deprecated and will go away soon.

dbus-python 0.80 provides only a partial emulation of the old
dbus_bindings, which was never meant to be public API.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  from dbus.dbus_bindings import *
Traceback (most recent call last):
  File "/usr/bin/democracyplayer", line 89, in <module>
    onetime.OneTime()
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 105, in
__init__
    bus_name = BusNameFlags('org.participatoryculture.dtv.onetime', bus=bus,
flags=dbus.dbus_bindings.NAME_FLAG_DO_NOT_QUEUE)
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 53, in __new__
    retval = dbus.dbus_bindings.bus_request_name(bus.get_connection(), name,
flags=flags)
TypeError: request_name() takes no keyword arguments

I changed onetiem.py to make flags=flags just be flags, but then it runs in to
another error which was more difficult to trace.

dbus-python is dbus-python-0.80.2-3.fc7.
Comment 1 Thorsten Scherf 2007-06-09 16:38:30 EDT

*** This bug has been marked as a duplicate of 241981 ***

Note You need to log in before you can comment on or make changes to this bug.