Bug 243561 - Anaconda stalls on network installation at "Starting Installation"
Anaconda stalls on network installation at "Starting Installation"
Status: CLOSED DUPLICATE of bug 112259
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-09 15:03 EDT by Carl-Johan Kjellander
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-30 17:48:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carl-Johan Kjellander 2007-06-09 15:03:30 EDT
Description of problem:
Anacando gets stuck on a network install just as it is
"Starting Installation", just after formatting filesystem.

Version-Release number of selected component (if applicable):
F7

How reproducible:
100%

Steps to Reproduce:
1. Try to do an x86_64 network install from ftp://ftp.funet.fi/ or
ftp://ftp.chl.chalmers.se/ , either IPv4 or IPv6 in the case of the
latter. 
  
Actual results:
Just after formatting filesystem an xscreensaver comes on and
anaconda stalls. After moving the mouse, anaconda does not refresh.
It takes 1% CPU but sleeps according to top. It never starts the
installation.

Expected results:
Never any screensaver, and not stalling but installing. (pun intended).

Additional info:
Acer Aspire 5110 laptop. Tried 4 times with different servers.
Comment 1 Carl-Johan Kjellander 2007-06-09 15:42:06 EDT
I left the install from ftp://ftp.chl.chalmers.se/ running without touching
it at the unrefreshed anaconda screen and did something else for a while.
After a long time it actually started installing.

But why this long wait with anaconda only using 1% CPU? And since it
doesn't refresh the screen is just grey with a blue and dark grey bar,
with no info about what it's doing.

I did leave the installs from ftp://ftp.funet.fi/ running for 10 minutes and
that is way to long for an unrefreshed screen. People will think that it's
crashed, especially since the screensaver comes on, which should never happen.

Comment 2 NILMONI DEB 2007-07-27 13:11:53 EDT
I also did a network install (via FTP), by booting from USB pen drive 
(diskboot.img).

After I supplied the FTP mirror path, it started downloading the "stage2.img" 
file and thats where it stayed hung for 20 minutes. During this period, all 
its doing is downloading a 90MB file from the FTP server but gives no 
indication of how much has been downloaded. In the absence of any indicator 
(in bytes and/or percentage or even a progress bar) the user would think that 
the installer is hung. I thought the installer was hung and thats why I 
interrupted the install twice before actually going thru with it. I also 
switched console (ctrl-alt-f1 thru f7) and one of the consoles had info about 
what file was being downloaded but no progress indicator.

After formatting the filesystem, once the package installation starts, I saw a 
similar anaconda hang (as reported in comment #1), when I switched to a text 
console and then switched back, the anaconda UI stayed frozen (unrefreshed) 
for a long time before regaining its normal state (displaying messages about 
which package is being installed). It must have stayed frozen for about 15 
minutes or so.
Comment 3 Chris Lumens 2007-08-30 17:48:44 EDT

*** This bug has been marked as a duplicate of 112259 ***

Note You need to log in before you can comment on or make changes to this bug.