Bug 243608 - System event sounds are absent even while turned on
System event sounds are absent even while turned on
Status: CLOSED DUPLICATE of bug 241739
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
i386 Linux
low Severity low
: ---
: ---
Assigned To: John Dennis
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2007-06-10 14:06 EDT by Kamil J. Dudek
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-06-12 18:19:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Log extract (1.55 KB, application/octet-stream)
2007-06-11 15:00 EDT, Kamil J. Dudek
no flags Details

  None (edit)
Description Kamil J. Dudek 2007-06-10 14:06:25 EDT
Description of problem:
System event sounds stopped working properly after changing SELinux memory
protection policies. Maybe that's not a reason of this behaviour, I don't know.
The ESD process is turned off ( 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=156769 ) and system event
sounds are absent, but terminal informs about:

(process:3219): GStreamer-WARNING **: The GStreamer function
gst_init_get_option_group() was
        called, but the GLib threading system has not been initialised
        yet, something that must happen before any other GLib function
        is called. The application needs to be fixed so that it calls
           if (!g_thread_supported ()) g_thread_init(NULL);
        as very first thing in its main() function. Please file a bug
        against this application.

Version-Release number of selected component (if applicable):
GNOME gnome-sound-properties 2.18.0

Steps to Reproduce:
1. Enable memory protection
2. Try to turn on ESD sounds and system event sounds
3. No sounds being heard
Expected results:
Previosusly, few minutes after clean install, all worked fine.

Additional info:

Chosen sound files dedicated for events are playable in gstreamer players like
Comment 1 Bastien Nocera 2007-06-11 05:17:19 EDT
Which SELinux errors do you see in the /var/log/messages?
Comment 2 Kamil J. Dudek 2007-06-11 15:00:11 EDT
Created attachment 156746 [details]
Log extract

I made it shorter because of repeating entries.
Comment 3 Kamil J. Dudek 2007-06-11 15:02:21 EDT
These logs are fragments of mesages written during login to GNOME session. While
launching gnome-sound-properties *nothing* appears in logs...
Comment 4 Bastien Nocera 2007-06-12 05:42:27 EDT
I don't see anything in the log related to SELinux errors, apart from
setroubleshootd not being able to handle some of the messages.

I'll pass this on to setroubleshoot-server.
Comment 5 John Dennis 2007-06-12 18:19:36 EDT
Marking this as a duplicate of bug # 241739, which is tracking a known problem
with setroubleshoot/sealert i18n handling, please see that bug for an update
test package which should resolve the problem.

*** This bug has been marked as a duplicate of 241739 ***
Comment 6 Kamil J. Dudek 2007-06-14 15:18:45 EDT
"System event sounds are absent even while turned on"

I noticed few minutes ago, that GNOME is unable to restore i session when esd
deamon is being used to do it. Logging in hangs, when I kill "esd" process via
tty, restoring session becomes to work again. The same with logging out.
ESD seems to be the only responsible for these hangs...
Comment 7 Danilo Gimenez 2007-06-18 08:06:27 EDT
Is Bug 238680 related to this one?
Comment 8 Kamil J. Dudek 2007-06-18 13:47:59 EDT
A bit. The difference is that esd does hang session but seldom, usually it
simply doesn't work or makes other sound-oriented programs work inproperly.

Note You need to log in before you can comment on or make changes to this bug.