Bug 241739 - Runtime Error: maximum recursion depth exceeded
Summary: Runtime Error: maximum recursion depth exceeded
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: John Dennis
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
: 243077 243608 (view as bug list)
Depends On:
Blocks: 250239
TreeView+ depends on / blocked
 
Reported: 2007-05-30 02:32 UTC by Jens Petersen
Modified: 2008-01-09 18:53 UTC (History)
2 users (show)

Fixed In Version: setroubleshoot-1.10.1-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-09 18:53:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sealert-backtrace.gz (1.38 KB, application/x-gzip)
2007-05-30 02:32 UTC, Jens Petersen
no flags Details
setroubleshootd.log (1.36 KB, text/plain)
2007-05-31 02:58 UTC, Jens Petersen
no flags Details

Description Jens Petersen 2007-05-30 02:32:13 UTC
Description of problem:
sealert often runs for me on my old testbox when I login to the desktop.
Today I got a python backtrace in the "sealert Error" dialog,
which I attach.

Comment 1 Jens Petersen 2007-05-30 02:32:13 UTC
Created attachment 155653 [details]
sealert-backtrace.gz

Comment 2 John Dennis 2007-05-30 15:48:03 UTC
Thanks for reporting this, I could use two more pieces of information

1) What is the package NVR?

2) Does /var/log/setroubleshoot/setroubleshootd.log also have python backtrace's
in it and if so could you attach the log file so I could look at it? 

Thanks

Comment 3 Jens Petersen 2007-05-31 02:55:56 UTC
It is setroubleshoot-1.9.4-2.fc7, the version in F7.


Comment 4 Jens Petersen 2007-05-31 02:58:23 UTC
Created attachment 155769 [details]
setroubleshootd.log

Here is the setroubleshootd.log backtrace that seems to keep occurring.

My desktop is running in ja_JP.UTF-8 if that helps.

Comment 5 John Dennis 2007-05-31 04:34:50 UTC
Thank you for taking the time to report this and follow up with the information,
it is very helpful. This problem looks to be identical to another recent bug
report upstream. I will immediately investigate.

Comment 6 John Dennis 2007-06-05 20:42:47 UTC
update: The issue is still being researched, we know why the problem occurs, but
we don't yet know the best way to address it which will work correctly across
various python versions, python extensions (libxml2 & pygtk), and linux
distributions, each has their own issues :-( We are working on finding a solution.

Comment 7 John Dennis 2007-06-11 13:56:16 UTC
*** Bug 243077 has been marked as a duplicate of this bug. ***

Comment 8 John Dennis 2007-06-12 21:42:28 UTC
I have built ana new RPM (setroubleshoot-1.9.7-1.fc8) in rawhide, I believe this
will fix the problems related to setroubleshootd and sealert being unable to
communicate when the system language is non-latin. The RPM should show up in
rawhide shortly or you may download it here:
 
http://koji.fedoraproject.org/koji/buildinfo?buildID=8705

Please install this and let me know if it resolves the problem, if it does I
will push a similar update to F7.

Comment 9 John Dennis 2007-06-12 22:19:38 UTC
*** Bug 243608 has been marked as a duplicate of this bug. ***

Comment 10 Peter Sabiniewicz 2007-06-14 08:12:12 UTC
http://koji.fedoraproject.org/koji/buildinfo?buildID=8705
Works for me. Waiting for FC 7 Update package.

Comment 11 Fedora Update System 2007-08-27 21:42:51 UTC
setroubleshoot-1.10.1-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.