Bug 212934 - (puplet-kde) puplet doesn't show icon in systray in KDE
puplet doesn't show icon in systray in KDE
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
: Desktop
: 208715 214077 214086 251197 355621 (view as bug list)
Depends On: 214222
Blocks:
  Show dependency treegraph
 
Reported: 2006-10-30 03:02 EST by Michal Piotrowski
Modified: 2007-11-30 17:11 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-12 14:42:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for puplet (496 bytes, patch)
2006-11-03 08:06 EST, Felix Geyer
no flags Details | Diff
$XDG_CONFIG_DIRS/autostart desktop files modified for KDE login (4.28 KB, application/x-tbz)
2007-07-02 07:27 EDT, Niko Mirthes
no flags Details
Patch allowing Puplet's autostart file to start as expected under a KDE session (678 bytes, patch)
2007-07-06 12:51 EDT, Niko Mirthes
no flags Details | Diff

  None (edit)
Description Michal Piotrowski 2006-10-30 03:02:56 EST
Description of problem:
When I start puplet in KDE it doesn't display icon in system tray. There is a
place for icon but it is empty. You also cannot click on this empty place to
show puplet's window.

Version-Release number of selected component (if applicable):
1.2.5-1

How reproducible:
Always

Steps to Reproduce:
1. Log in to KDE
2. Start puplet
  
Actual results:
Puplet doesn't display icon in systray

Expected results:
Puplet shows icon in systray and works correctly in KDE.
Comment 1 Jeremy Katz 2006-10-30 13:46:31 EST
Matthias -- do GtkStatusIcon's work correctly in the kde tray?
Comment 2 André Johansen 2006-10-31 12:23:05 EST
When starting puplet from a command line, I get the following output:
libnotify-Message: Unable to get session bus: Unable to determine the address 
of the message bus (try 'man dbus-launch' and 'man dbus-daemon' for help)
Error: unable to initialize pynotify

(I've got yum-updatesd installed and running -- it should be a Req for puplet, 
but seems to not be so!  The "messagebus" service is also running.)
Comment 3 Felix Geyer 2006-11-03 08:06:54 EST
Created attachment 140242 [details]
Patch for puplet
Comment 4 Felix Geyer 2006-11-03 08:11:59 EST
Comment on attachment 140242 [details]
Patch for puplet

Here is a temporary solution:

1. Install gconf-editor if you don't have already
2. Start gconf-editor, go to /apps/puplet, add the key "always_show" (boolean)
and set it to true
3. Apply this patch to /usr/bin/puplet
Comment 5 Felix Geyer 2006-11-03 08:12:05 EST
Comment on attachment 140242 [details]
Patch for puplet

Here is a temporary solution:

1. Install gconf-editor if you don't have already
2. Start gconf-editor, go to /apps/puplet, add the key "always_show" (boolean)
and set it to true
3. Apply this patch to /usr/bin/puplet
Comment 6 Ville Skyttä 2006-11-05 14:40:41 EST
*** Bug 214086 has been marked as a duplicate of this bug. ***
Comment 7 Esteban Xandri 2006-11-05 17:09:32 EST
I had this problem in GNOME (haven't checked KDE), but after applying the patch
from #5 and  adding the key "always_show" made the applet visible.

PS:(FC5 upgraded w/DVD to FC6)
Comment 8 Jeremy Katz 2006-11-06 13:00:56 EST
It looks like there's a problem with hiding and then showing a GtkStatusIcon
with the kde system tray.  That's filed as bug 214222.  Once that's resolved,
this should be happier.
Comment 9 Jeremy Katz 2006-11-06 13:02:31 EST
*** Bug 214077 has been marked as a duplicate of this bug. ***
Comment 10 Jeremy Katz 2006-11-06 13:08:59 EST
*** Bug 208715 has been marked as a duplicate of this bug. ***
Comment 11 Felix Geyer 2006-11-07 16:37:24 EST
(In reply to comment #8)
> It looks like there's a problem with hiding and then showing a GtkStatusIcon
> with the kde system tray.  That's filed as bug 214222.  Once that's resolved,
> this should be happier.

Yes, but there is another problem on kde:
When the icon is hidden it still uses a slot in the system tray.
Comment 12 Thomas Canniot 2007-04-09 16:04:46 EDT
And why is pupplet not launched by default in KDE as it is in GNOME ?
Comment 13 Thomas Canniot 2007-04-09 16:05:38 EDT
Moreover, the probelm is still there in Fedora 7 Test3.
Comment 14 Felix Geyer 2007-06-05 07:30:23 EDT
Still not fixed in Fedora 7 final.
Comment 15 Jeremy Katz 2007-06-11 11:32:01 EDT
*** Bug 243611 has been marked as a duplicate of this bug. ***
Comment 16 Sergio Monteiro Basto 2007-06-24 20:37:25 EDT
I have this in F 7 updated 
puplet
Traceback (most recent call last):
  File "/usr/bin/puplet", line 372, in <module>
    main()
  File "/usr/bin/puplet", line 369, in main
    p.run()
  File "/usr/bin/puplet", line 356, in run
    self._getOnDbus()
  File "/usr/bin/puplet", line 229, in _getOnDbus
    "/Updatesd")
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 226, in get_object
    follow_name_owner_changes=follow_name_owner_changes)
  File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 236, in __init__
    self._named_service = conn.activate_name_owner(bus_name)
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 165, in
activate_name_owner
    self.start_service_by_name(bus_name)
  File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 261, in
start_service_by_name
    'su', (bus_name, flags)))
  File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 598, in
call_blocking
    message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The
name edu.duke.linux.yum was not provided by any .service files
Comment 17 Peter Sabiniewicz 2007-06-28 05:41:22 EDT
In KDE 3.5.7 on F7 problem still exist.
Comment 18 Patrick Boutilier 2007-06-28 09:15:55 EDT
(In reply to comment #16)
> I have this in F 7 updated 
> puplet
> Traceback (most recent call last):
>   File "/usr/bin/puplet", line 372, in <module>
>     main()
>   File "/usr/bin/puplet", line 369, in main
>     p.run()
>   File "/usr/bin/puplet", line 356, in run
>     self._getOnDbus()
>   File "/usr/bin/puplet", line 229, in _getOnDbus
>     "/Updatesd")
>   File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 226, in get_object
>     follow_name_owner_changes=follow_name_owner_changes)
>   File "/usr/lib/python2.5/site-packages/dbus/proxies.py", line 236, in __init__
>     self._named_service = conn.activate_name_owner(bus_name)
>   File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 165, in
> activate_name_owner
>     self.start_service_by_name(bus_name)
>   File "/usr/lib/python2.5/site-packages/dbus/bus.py", line 261, in
> start_service_by_name
>     'su', (bus_name, flags)))
>   File "/usr/lib/python2.5/site-packages/dbus/connection.py", line 598, in
> call_blocking
>     message, timeout)
> dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The
> name edu.duke.linux.yum was not provided by any .service files
> 

That happens when yum-updatesd is not running:

chkconfig yum-updatesd on
service yum-updatesd start
Comment 19 Sergio Monteiro Basto 2007-06-28 09:35:55 EDT
(In reply to comment #18)
> (In reply to comment #16)
> That happens when yum-updatesd is not running:
> 
yep, thanks for the tip. 
Conclusion pirut needs be depend on yum-updatesd ! when we build the rpm and
install rpm 
 
Comment 20 Niko Mirthes 2007-07-02 07:17:17 EDT
puplet would also benefit (on KDE) from having:

X-KDE-autostart-after=panel
X-KDE-StartupNotify=false
X-KDE-UniqueApplet=true

present in puplet.desktop
Comment 21 Niko Mirthes 2007-07-02 07:26:25 EDT
It's also notable that KDE does not make use of $XDG_CONFIG_DIRS/autostart but 
uses $KDEDIRS/autostart as mentioned in bug #238507. This is of course why 
puplet and the others present in $XDG_CONFIG_DIRS/autostart fail to start at 
login. I've run the desktop-file-validate tool against these files with mixed 
results and attached a tarball of the desktop files in 
$XDG_CONFIG_DIRS/autostart. I'm placing these in ~/.kde/Autostart and they now 
start without error. Seems KDE is much more anal about the content of the 
desktop files as opposed to GNOME.
Comment 22 Niko Mirthes 2007-07-02 07:27:50 EDT
Created attachment 158328 [details]
$XDG_CONFIG_DIRS/autostart desktop files modified for KDE login
Comment 23 Niko Mirthes 2007-07-06 12:48:14 EDT
I've looked at this a little further and concluded the above tarball doesn't 
belong here.

Puplet's .desktop in $XDG_CONFIG_DIRS/autostart seems to only require:

StartupNotify=false

rather than

X-KDE-StartupNotify=false

Also, without

X-KDE-autostart-after=panel

puplet seems to race with KDE's panel (kicker).

Order seems important here, with StartupNotify needing to precede 
X-KDE-autostart-after.

Lastly, I've run desktop-file-validate against puplet.desktop and 
removed 'Application;' from the 'Categories=' list as this entry doesn't 
appear in the registered categories listed in the Desktop Menu Specification 
at http://standards.freedesktop.org/menu-spec/latest/ . desktop-file-validate 
complains about it as well. I've also added 'Monitor;' to the list as it seems 
pertinent.
Comment 24 Niko Mirthes 2007-07-06 12:51:24 EDT
Created attachment 158670 [details]
Patch allowing Puplet's autostart file to start as expected under a KDE session
Comment 25 Jeremy Katz 2007-08-07 16:19:50 EDT
*** Bug 251197 has been marked as a duplicate of this bug. ***
Comment 26 Jeremy Katz 2007-09-12 14:42:00 EDT
Okay, GtkStatusIcon has been fixed and I've made the desktop file completely
compliant with the spec for Fedora 8 test3
Comment 27 Jeremy Katz 2007-10-28 14:16:43 EDT
*** Bug 355621 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.