This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 243662 - yum updating --> TypeError: list objects are unhashable
yum updating --> TypeError: list objects are unhashable
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
6
i386 Linux
low Severity low
: ---
: ---
Assigned To: Adrian Likins
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 07:52 EDT by fx pottier
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-15 10:23:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
file saved from the excetion occured window in Software updater (1.78 KB, application/octet-stream)
2007-06-11 07:52 EDT, fx pottier
no flags Details

  None (edit)
Description fx pottier 2007-06-11 07:52:21 EDT
Description of problem:
while running pup, up2date or yum to update y softwares, it runs into trouble
with the following package : libgii
libgii-0.8.4-2
Looks like there's a problem with returning a list in python while resolving the
dependencies

Version-Release number of selected component (if applicable):

How reproducible:
I think you need to have the packages that seem to cause the issue then try
update with either yum, up2date or pup (is pup the same as up2date ?)

Steps to Reproduce:
1. 
2.
3.
  
Actual results:
I can't update my system (unless i get rid of those packages but i'd rather keep'em)

Expected results:
I'd love to update my system, which was working well until now.

Additional info:
some packages i managed to trace in the dependencies :
libgii-0.8.4-2
libggi-2.0.1-6
svgalib4ggi-0.6-4
quake-svga-1.06-2
Comment 1 fx pottier 2007-06-11 07:52:21 EDT
Created attachment 156698 [details]
file saved from the excetion occured window in Software updater
Comment 2 Nerijus Baliūnas 2007-06-12 15:44:12 EDT
I have the same problem but with yum and Fedora 7:

# yum update
...
Resolving Dependencies
--> Running transaction check
---> Package yumex.noarch 0:1.9.8-2.0.fc7 set to be updated
filelists.sqlite.bz2      100% |=========================| 456 kB    00:07     
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 135, in main
    (result, resultmsgs) = base.buildTransaction() 
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 549, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 794, in resolveDeps
    deps = self._mytsCheck()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 775, in _mytsCheck
    ret.extend(self._checkRemove(txmbr))
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 1029, in
_checkRemove
    for pkgtup in self.rpmdb.whatRequires(provname, None, None):
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 422, in whatRequires
    pkgs = self.searchRequires(name)
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 148, in
searchRequires
    return self.searchPrco(name, 'requires')
  File "/usr/lib/python2.5/site-packages/yum/rpmsack.py", line 127, in searchPrco
    if not result.has_key(po.pkgid):
TypeError: list objects are unhashable
Comment 3 Nerijus Baliūnas 2007-06-13 16:44:51 EDT
fx pottier, how have you found out which package is guilty? I uninstalled some
packages which yum update wanted to update (yumex, ...), and now it just dies as
above:
# yum update
...
Resolving Dependencies
--> Running transaction check
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
...
Comment 4 Nerijus Baliūnas 2007-06-13 17:01:40 EDT
OK, I found it out - it's gdb-6.6-15.fc7.i386.rpm. After I updated it manually,
yum update works.
Comment 5 fx pottier 2007-06-15 09:20:08 EDT
good for you nerijus,
I'm not sure about the package libgii-0.8.4-2 is the one causing the issue but
the yum process dies there while testing the dependencies (or so it seems)

To manually update the package, did you simply download it and rpm -Uvh it ?
Comment 6 fx pottier 2007-06-15 10:23:32 EDT
Since i had no other idea and didnt want to spend to much time on this
I removed the following pacakges and i found that svgalib4ggi was on wrong acrh
(i686 instead of i386) the problem might have come from there.
problem solved.
=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Removing:
 libggi                  i386       2.1.1-1          installed         1.5 M
 libgii                  i386       0.9.1-1          installed         497 k
 quake-svga              i386       1.06-2           installed         735 k
 quake2                  i386       3.20-glibc-6     installed          11 M
Removing for dependencies:
 svgalib4ggi             i686       0.6-4            installed          29 k

Transaction Summary
=============================================================================
Comment 7 Nerijus Baliūnas 2007-06-16 17:37:44 EDT
Yes, I simply downloaded gdb package from F7 updates and installed it with rpm
-Fvh. Then yum update started working. Strange.

Note You need to log in before you can comment on or make changes to this bug.