Bug 24376 - module name conversion
module name conversion
Status: CLOSED DUPLICATE of bug 25550
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
David Lawrence
Florence RC-1
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-19 12:40 EST by Tim Waugh
Modified: 2007-04-18 12:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 22:54:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2001-01-19 12:40:34 EST
Upgrades should probably change /etc/modules.conf (or /etc/conf.modules) 
so that old module names are rewritten as the new names.

At least 3c90x (3c59x) has changed; I don't know if there is a list 
somewhere..
Comment 1 Glen Foster 2001-01-19 16:42:47 EST
Re-assigning to component "kernel".
Comment 2 Glen Foster 2001-01-19 16:55:39 EST
This defect is considered MUST-FIX for Florence Release-Candidate #1
Comment 3 Tim Waugh 2001-01-21 10:31:00 EST
There was talk of doing this in the kernel package's %post, but that doesn't
seem right.  You can install a 2.4 kernel and still want to fall back to a 2.2
kernel, so perhaps it should be a boot-time thing.

There are some nifty modutils directives for saying things like 'try 3c59x, and
if that doesn't work, try 3c90x'.  I wonder if we should make use of them?  Like
this:

probe eth0 3c59x 3c90x
Comment 4 Tim Waugh 2001-01-24 09:18:31 EST
How about if the kernel spec requires sed and this gets put in %post:

cnf=/etc/modules.conf
[ -f $cnf ] || cnf=/etc/conf.modules
sed -e 's/^alias eth0 3c90x$/probe eth0 3c59x 3c90x/' $cnf > $cnf.tmp
mv -f $cnf.tmp $cnf

We already require a recent enough modutils I think.
Comment 5 Arjan van de Ven 2001-01-24 15:00:05 EST
I'd say this is a job for the hardware detection program.
It should find the card and see the correct module isn't assigned to it.
Comment 6 Tim Waugh 2001-01-24 20:57:04 EST
Bill, do you agree?  It makes sense to me..
Comment 7 Bill Nottingham 2001-01-24 21:04:11 EST
No. We explicitly do not change mappings for users on the premise
that if the user picked a particular driver, they did it for
a reason.
Comment 8 Tim Waugh 2001-01-24 21:07:37 EST
Note that we're not necessarily talking about outright _changing_ the alias, but
rather adding a name, like:

before: alias eth0 3c90x
after : probe eth0 3c90x 3c59x
Comment 9 Bill Nottingham 2001-01-24 21:23:42 EST
Eww. That would mean as soon as the installer writes a modules.conf,
kudzu would change it?  There's something rather ugly about that.

It also means that you have to parse this other format to determine
what devices are configured.

Moreover, the kernel package already did this for the 2.2 kernel,
I don't see why it can't do it for 2.4.

In any case, we're now shipping the 3c90x driver in the kernel.
Comment 10 Michael K. Johnson 2001-01-24 22:53:57 EST
We should bring forward the 2.2 stuff to the 2.4 kernel, but it is
not critical unless the aacraid driver actually makes it in, since
that's currently the only use of it...
Comment 11 Bill Nottingham 2001-02-06 13:04:35 EST

*** This bug has been marked as a duplicate of 25550 ***

Note You need to log in before you can comment on or make changes to this bug.