Bug 25550 - eth0 won't start after upgrade with rtl8139 nic
eth0 won't start after upgrade with rtl8139 nic
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
Florence RC-1
:
: 24376 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-02-01 17:21 EST by Gerald Henriksen
Modified: 2014-03-16 22:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-19 19:01:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Henriksen 2001-02-01 17:21:29 EST
Upgraded a Red Hat 7 machine with an Accton SMC2-1211TX network card. 
Guiness treated this card as an RTL8139 in /etc/modules.conf

After the upgrade eth0 failed: (from /var/log/messages)

Feb  1 14:25:22 nutmeg modprobe: modprobe: Can't locate module eth0
Feb  1 14:25:22 nutmeg sysctl: net.ipv4.ip_forward = 0
Feb  1 14:25:22 nutmeg sysctl: net.ipv4.conf.all.rp_filter = 1
Feb  1 14:25:22 nutmeg sysctl: kernel.sysrq = 0
Feb  1 14:25:22 nutmeg sysctl: error: 'net.ipv4.ip_always_defrag' is an
unknown key
Feb  1 14:25:22 nutmeg network: Setting network parameters:  succeeded
Feb  1 14:25:23 nutmeg network: Bringing up interface lo:  succeeded
Feb  1 14:25:23 nutmeg modprobe: Note: /etc/modules.conf is more recent
than /lib/modules/2.4.0-0.99.11/modules.dep
Feb  1 14:25:23 nutmeg modprobe: modprobe: Can't locate module eth0
Feb  1 14:25:23 nutmeg ifup: Delaying eth0 initialization.
Feb  1 14:25:23 nutmeg network: Bringing up interface eth0:  failed

The entry in the Guiness /etc/modules.conf was:
alias eth0 rtl8139 

Changing /etc/modules.conf in Fisher to:
alias eth0 8139too

solved the problem.
Comment 1 Glen Foster 2001-02-02 17:57:08 EST
We (Red Hat) should really fix this before next release
Comment 2 Pekka Savola 2001-02-03 08:36:54 EST
Please post 'lspci -n' and 'lspci -v' lines regarding your NIC.
Comment 3 Bill Nottingham 2001-02-03 14:34:34 EST
The problem is that the module changed names, and we don't migrate
it currently

rtl8139 changed to rtl8129 or 8139too.
Comment 4 sandy 2001-02-03 19:41:19 EST
For some reason my rtl8159 was recognized with the new driver - 8139too -
and was set up properly but the second ether card, a linksys lne100tx v4,
was not found or setup during install - ASUS k7v, 750 Athlon, Matrox G400,
SB Live, 30 MB IBM 75GXP.
Comment 5 Bill Nottingham 2001-02-06 13:04:31 EST
*** Bug 24376 has been marked as a duplicate of this bug. ***
Comment 6 Bill Nottingham 2001-02-08 11:20:29 EST
This should be fixed with the combination of kernel-2.4.0-0.99.25 and
kudzu-0.93-1.

Note You need to log in before you can comment on or make changes to this bug.