Bug 243773 - up converted cmirrors take 90+ seconds to mount
Summary: up converted cmirrors take 90+ seconds to mount
Status: CLOSED DUPLICATE of bug 238629
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: cmirror   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Jonathan Earl Brassow
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On: 242074
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-11 20:11 UTC by Corey Marthaler
Modified: 2010-01-12 02:04 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 17:28:23 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Corey Marthaler 2007-06-11 20:11:43 UTC
Description of problem:
This may not be a bug, but figured I'd document this incase it can be sped up a
bit or incase a customer runs into this.


# Fully synced mirror
[root@link-08 ~]# lvs
  LV       VG         Attr   LSize  Origin Snap%  Move Log          Copy%
  LogVol00 VolGroup00 -wi-ao 72.44G
  LogVol01 VolGroup00 -wi-ao  1.94G
  mirror1  corey1     mwi-a-  1.00G                    mirror1_mlog 100.00
[root@link-08 ~]# time mount -t gfs /dev/corey1/mirror1 /mnt/mirror1
real    0m2.596s
user    0m0.000s
sys     0m0.020s


# Linear
[root@link-08 ~]# umount /mnt/mirror1
[root@link-08 ~]# lvconvert -m 0 corey1/mirror1
  Logical volume mirror1 converted.
[root@link-08 ~]# lvs
  LV       VG         Attr   LSize  Origin Snap%  Move Log Copy%
  LogVol00 VolGroup00 -wi-ao 72.44G
  LogVol01 VolGroup00 -wi-ao  1.94G
  mirror1  corey1     -wi-a-  1.00G
[root@link-08 ~]# time mount -t gfs /dev/corey1/mirror1 /mnt/mirror1

real    0m2.082s
user    0m0.000s
sys     0m0.015s


# One legged mirror
[root@link-08 ~]# umount /mnt/mirror1
[root@link-08 ~]# lvconvert -m 1 corey1/mirror1
  Logical volume mirror1 converted.
[root@link-08 ~]# time mount -t gfs /dev/corey1/mirror1 /mnt/mirror1

real    1m30.281s
user    0m0.000s
sys     0m0.019s
[root@link-08 ~]# umount /mnt/mirror1
[root@link-08 ~]# lvconvert -m 0 corey1/mirror1
  Logical volume mirror1 converted.
[root@link-08 ~]# lvs -a -o +devices
  LV       VG         Attr   LSize  Origin Snap%  Move Log Copy%  Devices
  LogVol00 VolGroup00 -wi-ao 72.44G                               /dev/hda2(0)
  LogVol01 VolGroup00 -wi-ao  1.94G                               /dev/hda2(2318)
  mirror1  corey1     -wi-a-  1.00G                               /dev/sda1(0)



# One legged mirror (core log)
[root@link-08 ~]# lvconvert -m 1 --corelog corey1/mirror1
  Logical volume mirror1 converted.
[root@link-08 ~]# time mount -t gfs /dev/corey1/mirror1 /mnt/mirror1

real    1m37.843s
user    0m0.001s
sys     0m0.024s
[root@link-08 ~]# umount /mnt/mirror1
[root@link-08 ~]# lvconvert -m 0 corey1/mirror1
  Logical volume mirror1 converted.


# Two legged mirror (core log)
[root@link-08 ~]# lvconvert -m 2 --corelog corey1/mirror1
  Logical volume mirror1 converted.
[root@link-08 ~]# time mount -t gfs /dev/corey1/mirror1 /mnt/mirror1

real    1m37.783s
user    0m0.000s
sys     0m0.017s



Version-Release number of selected component (if applicable):
cmirror-kernel-2.6.9-32.0
lvm2-cluster-2.02.21-7.el4

Comment 1 Corey Marthaler 2007-06-11 20:22:37 UTC
This issue is not present on single node mirrors...

[root@link-08 ~]# lvconvert -m 1 --corelog corey1/mirror1
  Logical volume mirror1 converted.
[root@link-08 ~]# time mount -t gfs /dev/corey1/mirror1 /mnt/mirror1

real    0m2.436s
user    0m0.001s
sys     0m0.020s
[root@link-08 ~]# umount /mnt/mirror1
[root@link-08 ~]# lvconvert -m 0 corey1/mirror1
  Logical volume mirror1 converted.
[root@link-08 ~]# lvconvert -m 2 --corelog corey1/mirror1
  Logical volume mirror1 converted.
[root@link-08 ~]# time mount -t gfs /dev/corey1/mirror1 /mnt/mirror1

real    0m2.510s
user    0m0.000s
sys     0m0.018s


Comment 2 Corey Marthaler 2007-06-20 16:40:49 UTC
This issue appears fixed in the lastest kernel mods that Jon gave me
(2.6.9-55.8.ELsmp).



Comment 3 Jonathan Earl Brassow 2007-06-22 14:43:10 UTC
sorry.  Modified -> post... waiting for all patches to settle into the rhkernel.


Comment 4 Jonathan Earl Brassow 2007-08-22 17:25:27 UTC
Should be ready in 4.6.

post -> modified.

Comment 5 Jonathan Earl Brassow 2007-08-22 17:28:23 UTC
this bug is really a dup of 238629.


*** This bug has been marked as a duplicate of 238629 ***


Note You need to log in before you can comment on or make changes to this bug.