Bug 243802 - Yumex hangs while reading repos from suspend2
Yumex hangs while reading repos from suspend2
Status: CLOSED DUPLICATE of bug 242100
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-11 19:10 EDT by Filip Miletic
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-12 02:27:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Miletic 2007-06-11 19:10:59 EDT
Description of problem:
Yumex hangs while reading repos from suspend2

Version-Release number of selected component (if applicable):
yumex-1.9.7-1.0.fc7

How reproducible:
Always

Steps to Reproduce:
1. Download the suspend2 repo information, 
2. Start yumex with --debuglevel=255
3. Enable repo within yumex, refresh.
  
Actual results:


Expected results:


Additional info:
root@cow:/var/lib/rpm
$ yumex --debuglevel=255
bad image index
/usr/lib/python2.5/site-packages/yumgui/widgets.py:142: GtkWarning: Icon cache
'/usr/share/icons/hicolor/icon-theme.cache' is invalid

  gtk.glade.XML.__init__(self, filename,root=rootname,domain=domain)
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
/usr/lib/python2.5/site-packages/yumgui/widgets.py:142: GtkWarning: Icon cache
'/usr/share/pixmaps/hicolor/icon-theme.cache' is invalid

  gtk.glade.XML.__init__(self, filename,root=rootname,domain=domain)
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
bad image index
01:02:07 : Yum Config Setup
01:02:08 : Yum Version : 3.2.0
01:02:08 : GUI Setup Completed
01:02:08 : Setup Yum : Transaction Set
01:02:08 : Setup Yum : RPM Db.
Reading Local RPMDB
01:02:08 : Setup Yum : Repositories.
01:02:08 : Setup Yum : Package Sacks
Setting up Package Sacks
01:02:08 : Setup Yum : Updates
Building updates object
skipping reposetup, pkgsack exists
skipping reposetup, pkgsack exists
putting beagle in complex update
putting kernel-devel in complex update
putting beagle-evolution in complex update
putting glibc in complex update
putting pm-utils in complex update
putting kernel in complex update
putting beagle in complex update
putting beagle-evolution in complex update
putting libbeagle in complex update
putting pm-utils in complex update
putting openssl in complex update
putting pm-utils in complex update
putting beagle-gui in complex update
putting beagle in complex update
putting beagle-gui in complex update
putting kmod-ndiswrapper in complex update
putting pptp-release in complex update
putting beagle-gui in complex update
putting libbeagle in complex update
putting libbeagle in complex update
putting beagle-evolution in complex update
processing beagle
processing kernel-devel.i686
processing beagle-evolution
processing glibc.i686
processing pm-utils
processing kernel.i686
processing beagle
processing beagle-evolution
processing libbeagle
processing pm-utils
processing openssl
processing pm-utils
processing beagle-gui
processing beagle
processing beagle-gui
processing kmod-ndiswrapper
processing pptp-release
processing beagle-gui
processing libbeagle
processing libbeagle
processing beagle-evolution
01:02:13 : Setup Yum : Groups
Getting group metadata
Adding group file from repository: fedora
Adding group file from repository: livna
01:02:13 : Setup Yum : Base setup completed
01:02:13 : Building Package Lists
skipping reposetup, pkgsack exists
01:02:20 : Building Package Lists Completed
01:02:20 : Building Groups Lists
01:02:20 : Building Group Lists Completed
01:02:20 : Getting packages : updates
01:02:20 : Found 0 updates packages
01:02:20 : Sorting packages
01:02:20 : Population view with packages
01:02:20 : Population Completed
01:02:32 : Enabled repositories :
updates,fedora,livna,poptop-stable,pptp-stable,suspend2
skipping reposetup, pkgsack exists
01:02:32 : Setup Yum : Transaction Set
01:02:32 : Setup Yum : RPM Db.
Reading Local RPMDB
01:02:33 : Setup Yum : Repositories.
01:02:33 : Setup Yum : Package Sacks
Setting up Package Sacks
Traceback (most recent call last):
  File "/usr/share/yumex/yumex.py", line 143, in on_repoRefresh_clicked
    self.setupYum()
  File "/usr/share/yumex/yumex.py", line 473, in setupYum
    self.yumbase._setupAgain()
  File "/usr/share/yumex/yumapi.py", line 115, in _setupAgain
    self.doSackSetup()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 356, in doSackSetup
    return self._getSacks(archlist=archlist, thisrepo=thisrepo)
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 387, in _getSacks
    self._pkgSack.excludeArchs(archlist)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 331, in
excludeArchs
    sack.excludeArchs(archlist)
  File "/usr/lib/python2.5/site-packages/yum/sqlitesack.py", line 717, in
excludeArchs
    cur = cache.cursor()
sqlite3.ProgrammingError: Cannot operate on a closed database.
Comment 1 Tim Lauridsen 2007-06-12 02:27:52 EDT

*** This bug has been marked as a duplicate of 242100 ***

Note You need to log in before you can comment on or make changes to this bug.