Bug 243853 - Package rename
Summary: Package rename
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: lablgtk (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Gérard Milmeister
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: bzcl34nup
Keywords:
: 241696 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-12 12:21 UTC by Nigel Jones
Modified: 2008-04-04 13:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-04 13:46:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
wtogami: fedora-cvs+


Attachments (Terms of Use)

Description Nigel Jones 2007-06-12 12:21:37 UTC
+++ This bug was initially created as a clone of Bug #243851 +++

Hi Gemi,

Any chance you can request that lablgtk gets renamed to ocaml-lablgtk (per the 
upcoming ocaml guidelines)?

Also, as you've already said you don't have any intentions to package for EPEL 
at present, would you mind if I requested EL- branches for lablgtk?

-- Additional comment from dev@nigelj.com on 2007-06-12 08:19 EST --
*** Bug 241697 has been marked as a duplicate of this bug. ***

Comment 1 Nigel Jones 2007-06-12 12:22:40 UTC
*** Bug 241696 has been marked as a duplicate of this bug. ***

Comment 2 Richard W.M. Jones 2007-06-12 12:43:07 UTC
I did the changes to the spec file, and a few others as well.  My latest version
of spec/srpm is here:

http://annexia.org/tmp/ocaml/

Comment 3 Gérard Milmeister 2007-06-30 08:57:42 UTC
Package Change Request
======================
Package Name: lablgtk
Rename package to ocaml-lablgtk as of
http://fedoraproject.org/wiki/PackagingDrafts/OCaml
and retain CVS history


Comment 4 Warren Togami 2007-07-06 20:09:35 UTC
Renamed and branched for EL-5.  Please verify that the rename happened as
expected.  You may need to upload source tarballs again.

Comment 5 Gérard Milmeister 2007-07-07 12:46:33 UTC
I built ocaml-lablgtk for rawhide. Please take a look at it,
particularly the requires and build-requires.

Comment 6 Richard W.M. Jones 2007-07-12 09:42:48 UTC
Please take a look at my build of ocaml-lablgtk2 which has
fixes above what is currently in Rawhide:

http://www.annexia.org/tmp/ocaml/ocaml-lablgtk2.spec
http://www.annexia.org/tmp/ocaml/ocaml-lablgtk2-2.6.0_20060908-2.src.rpm

* Correct handling of missing ocamlopt
* Includes lablgl & dependencies
* Package should be called ocaml-lablgtk2

Comment 7 Richard W.M. Jones 2007-08-01 16:44:16 UTC
I have updated the ocaml-lablgtk2 package:

http://www.annexia.org/tmp/ocaml/ocaml-lablgtk2.spec
http://www.annexia.org/tmp/ocaml/ocaml-lablgtk2-2.6.0_20060908-3.fc8.src.rpm

* Wed Aug  1 2007 Richard W.M. Jones <rjones@redhat.com> - 2.6.0_20060908-3
- ExcludeArch ppc64
- added BR: ocaml-camlp4 and ocaml-camlp4-devel
- Patch0: Add -I camlp4/CamlP4Parsers when building gtkdoc.ml file.


Comment 8 Bug Zapper 2008-04-04 12:48:37 UTC
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.


Note You need to log in before you can comment on or make changes to this bug.