Bug 2439 - vi(m) on instimage shouldn't require libX11.so !
vi(m) on instimage shouldn't require libX11.so !
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-30 10:25 EDT by hermann.lauer
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-15 18:03:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hermann.lauer 1999-04-30 10:25:17 EDT
i386/RedHat/instimage/usr/bin> ldd vi
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6
(0x4000f000)
....

A useable vi(m) is very helpfull during install/upgrade,
so why needs the vi(m) on instimage the X11 lib ?
Please use a version which doesn't require libX11.so,
which is hardly available (and not needed) in the
install/upgrade environment. Or, please provide another
useable editor. (vi(m) would be my choise...)
Comment 1 Jeff Johnson 1999-04-30 12:09:59 EDT
There are several versions of vim that can be installed. Use
/bin/vi(m) for install/upgrade work, and /usr/bin/vi(m) for
all the bell's and whistles. There's also a /usr/X11R6/bin/vi(m)
IIRC.
Comment 2 hermann.lauer 1999-05-04 06:15:59 EDT
This is a problem during install, not with an installed system:

Sorry, on boot.img is no /bin/vi or /bin/vim available - also not
on netboot.img. And the directory /usr/X11R6/bin does'nt exist - why
should it ?

During that second stage of the install/upgrade the harddisk of the
computer is generally not available (there may be no linux system
on it !).

I still see no way to get a running editor after pressing <alt>-F2
in the second install stage of redhat-6.0 - this has worked with 5.2
and earlier and I see still no reason, why the
RedHat/instimage/usr/bin/vi(m) on the CDROM should require the X11
libs.
Comment 3 Bill Nottingham 1999-05-10 10:08:59 EDT
*** Bug 2645 has been marked as a duplicate of this bug. ***

I ran ldd on a fully installed system to get this output,
the reference to libX11 causes vim to fail when run from the
text console during the install.

 ldd RedHat/instimage/usr/bin/vim
        libX11.so.6 => /usr/X11R6/lib/libX11.so.6
(0x40007000)
        libncurses.so.4 => /usr/lib/libncurses.so.4
(0x400aa000)
        libdb.so.3 => not found
        libgdbm.so.2 => /usr/lib/libgdbm.so.2 (0x400e9000)
        libdl.so.2 => /lib/libdl.so.2 (0x400ef000)
        libm.so.6 => /lib/libm.so.6 (0x400f2000)
        libc.so.6 => /lib/libc.so.6 (0x4010b000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0x401b0000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2
(0x2aaaa000)
Comment 4 Jeff Johnson 1999-05-15 15:30:59 EDT
Per msw, the wrong version of vi was included. The /bin/vi
is what shopuld have been included.
Comment 5 Jeff Johnson 1999-05-18 11:11:59 EDT
*** Bug 2902 has been marked as a duplicate of this bug. ***

Hi.  Executing vi while the VC2 window is available reports:

vi: error in loading shared libraries: libX11.so.6: cannot
open shared object file: No such file or directory.

Hmm.. This is really beat.  Can't even attempt to fix my
PCMCIA problem.. (which is why I marked it has "high"
priority)

Dave Wreski
dave@nic.com
Comment 6 Jeff Johnson 1999-06-15 07:26:59 EDT
*** Bug 3459 has been marked as a duplicate of this bug. ***

When booting with the Red Hat floppy, you can use,
after some menus, virtual console 2 with Alt-F2,
where you have a bash prompt:  bash#
Listed in /bin are some programs (not much), amongst
others vi and vim. However, when you call vi or vim,
you get this error:

"vi: error in loading shared libraries: libX11.so.6:
 cannot open shared object: No such file or directory"

This is somewhat awkward, as I wanted to edit a file
on the Win98 (vfat) partition, namely a log file of
what I was doing :-)
Note that I was able to mount it:
  /bin/insmod fat.o
  /bin/insmod vfat.o
  mkdir /dos
  mount -t vfat /dev/hda1 /dos
I also was not able to run 'more' (or 'less') and gpm
at installation time.
My idea was to keep a log of what I was doing and
copy it with gpm, so I would not have to write it on
paper and type it in again, should I need to install
again (which I did :-)


------- Additional Comments From jbj@redhat.com  06/14/99 13:58 -------


*** This bug has been marked as a duplicate of 2262 ***
Comment 7 Bill Nottingham 1999-07-15 18:03:59 EDT
fixed in latest install instimage, available in next rawhide

Note You need to log in before you can comment on or make changes to this bug.