This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 243922 - Soundcard not functional on a Thinkpad X60
Soundcard not functional on a Thinkpad X60
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-soundcard (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-12 15:26 EDT by Joe Sadusk
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 04:42:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
scsconfig (53.63 KB, text/plain)
2007-06-12 15:26 EDT, Joe Sadusk
no flags Details
scsrun (195 bytes, text/plain)
2007-06-12 15:26 EDT, Joe Sadusk
no flags Details

  None (edit)
Description Joe Sadusk 2007-06-12 15:26:07 EDT
Description of problem:
I have a Thinkpad X60, which has an Intel High Definition Audio controller in
it.  system-config-sound appears to detect it accurately, and when FC7 was first
installed it played sound fine, but after an update to latest packages, it
produces no sound.  All sound channels are up to the maximum in Volume Control.
 The sound test in system-config-sound also doesn't produce anything.  This is
both with and without headphones plugged in.

Version-Release number of selected component (if applicable):
joe@arthur:~$ rpm -q system-config-soundcard
system-config-soundcard-2.0.6-5.fc7
joe@arthur:~$ rpm -q kernel
kernel-2.6.21-1.3194.fc7
Comment 1 Joe Sadusk 2007-06-12 15:26:07 EDT
Created attachment 156821 [details]
scsconfig
Comment 2 Joe Sadusk 2007-06-12 15:26:56 EDT
Created attachment 156822 [details]
scsrun

more logs
Comment 3 Martin Stransky 2007-06-26 10:44:36 EDT
Hm, the logs look sane. Can you check the latest drivers? (1.0.14). how-to is
here: http://people.redhat.com/stransky/alsa/
Comment 4 Joe Sadusk 2007-06-26 15:28:14 EDT
I installed these:
alsa-driver-1.0.14-61.fc7.i386.rpm
alsa-driver-devel-1.0.14-61.fc7.i386.rpm
alsa-kmdl-2.6.21-1.3228.fc7-1.0.14-61.fc7.i686.rpm

And there was no change.  One thing I noticed while poking around, don't know if
its relevant.  Even though the gnome mixer and alsamixer both report the volume
as being turned all the way up, I see this:
joe@arthur:~$ cat /proc/asound/card0/oss_mixer 
VOLUME "Master" 0
BASS "" 0
TREBLE "" 0
SYNTH "" 0
PCM "PCM" 0
SPEAKER "" 0
LINE "" 0
MIC "Mic" 0
CD "CD" 0
IMIX "" 0
ALTPCM "" 0
RECLEV "" 0
IGAIN "Capture" 0
OGAIN "" 0
LINE1 "" 0
LINE2 "" 0
LINE3 "" 0
DIGITAL1 "IEC958" 0
DIGITAL2 "" 0
DIGITAL3 "" 0
PHONEIN "" 0
PHONEOUT "" 0
VIDEO "" 0
RADIO "" 0
MONITOR "" 0
Comment 5 Martin Stransky 2007-06-27 04:20:18 EDT
It's an oss mixer, not ALSA so it doesn't matter.

But, I have no idea what's wrong here. Could you check the original kernel
distributed with F7? (not from updates)
Comment 6 Martin Stransky 2007-06-27 04:26:42 EDT
Could you please check the non-xen kernel? (see Bug 245479)
Comment 7 Joe Sadusk 2007-06-30 13:26:20 EDT
I apologize, but this turns out not to be a bug.  I screwed up a bios setting
that  muted sound in hardware.  My fault.
Comment 8 Martin Stransky 2007-07-02 04:42:25 EDT
okay, no problem.

Note You need to log in before you can comment on or make changes to this bug.