Bug 243925 - apm: bios not found during boot while running on battery
apm: bios not found during boot while running on battery
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-12 15:32 EDT by Wayne Feick
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-16 17:38:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wayne Feick 2007-06-12 15:32:30 EDT
I'm running Fedora 7 on a Dell Precision M65 (2GHz core 2 duo. I had to add
hpet=disable to the kernel args to get it to boot after install.

I find that the machine boots fine when plugged in, but when I try to boot while
running on battery I get the "apm: bios not found" warning and things stop dead.
It's not 100% of the time, but very close to it.

I have discovered that going into the BIOS setup pages before trying to boot
seems to work around the problem. That suggests some sort of hardware
initialization that the kernel is not doing (or perhaps not properly) but the
BIOS is.

Looking through bugzilla, bug 241249 has some similarities, but I don't think
it's the same thing. Someone more informed might disagree.

I can easily duplicate this if need be, and I'm technical enough to gather
detailed information if that helps. It has been a few years since I've wielded a
kernel debugger, but it doesn't scare me.
Comment 1 Chuck Ebbert 2007-06-12 15:58:39 EDT
Test kernels at http://people.redhat.com/davej may resolve the problem.

Also the ususal workarounds (together or one at a time):

 clocksource=acpi_pm nohz=off maxcpus=1 highres=off
Comment 2 Christopher Brown 2007-09-16 17:38:58 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I'm CC'ing myself to this bug and closing it as it appears to be resolved -
there has been no response to Chuck's request to test later kernels. If I have
erred, please forgive me and re-open with any additional information you are
able to give. I will then try and assist you if I can.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.