Bug 241249 - (dellhang) intel core2 (latitude d620) hangs on boot
intel core2 (latitude d620) hangs on boot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 241506 241983 242096 242235 242719 242867 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-05-24 12:28 EDT by Rex Dieter
Modified: 2007-11-30 17:12 EST (History)
28 users (show)

See Also:
Fixed In Version: 2.6.22.1-27.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 13:10:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of failure on Dell Inspiron 6400 with Core Duo CPU (kernel 3208) (139.45 KB, image/jpeg)
2007-05-29 18:17 EDT, Bojan Smojver
no flags Details
Screen shot of failure on Dell Inspiron 6400 with Core Duo CPU (kernel 3209) (176.52 KB, image/jpeg)
2007-05-29 23:39 EDT, Bojan Smojver
no flags Details
Data obtained from Intel's Firmware Developer Kit, release 2 (83.63 KB, application/zip)
2007-05-30 03:29 EDT, Bojan Smojver
no flags Details

  None (edit)
Description Rex Dieter 2007-05-24 12:28:25 EDT
My Dell Latitude D620 hangs on boot with recent kernels, was/is fine with:
2.6.21-1.3168.fc7

Version-Release number of selected component (if applicable):
2.6.21-1.3194.fc7

How reproducible:
every boot

after removing 'quiet rhgb', the last few items printed to console are:
...
Freeing initrd memory: 2024k freed
apm: BIOS not found.
audit: initializing netlink socket (disabled)
audit(1180005947.937.1): initialized
Comment 1 Rex Dieter 2007-05-25 10:50:55 EDT
snagged kernel-2.6.21-1.3201.fc7 from koji (hoping), but it hangs too, but in a
different spot:

...
ACPI: PCI Interrrupt ...
NET: Regestered protocol family 2
<hang>
Comment 2 Chuck Ebbert 2007-05-25 11:20:04 EDT
Please try booting with kernel parameter

    sysrq_always_enabled

then try hitting alt-sysrq-p (hit "p" while holding down alt and sysrq)
when it locks up.
Comment 3 Rex Dieter 2007-05-25 11:28:27 EDT
bummer, nothing visibily happens.  (keyboard seems dead, numlock, capslock don't
seem to function either  ???)
Comment 4 Chuck Ebbert 2007-05-25 12:01:56 EDT
try booting with "maxcpus=0"

Comment 5 Bastien Nocera 2007-05-25 12:29:49 EDT
Happens on my Latitude D420 as well.

Jeremy's advice of booting with maxcpus=1 fixes the problem (which is a bit of a
bummer for a dual-core machine).
Comment 6 Rex Dieter 2007-05-25 12:52:52 EDT
maxcpus=0
gets *much* further, now it seems to be getting stuck on ata stuff(?):

ata1.00: qc timeout (cmd 0x27)
...
ata1.00: failed to set xfermode (err_mask_0x4)
...
ata2.00: qc timeout (cmd 0xef)
...
ata1.00: failed to set xfermode (err_mask_0x4)
...
Loading ata_generic.ko module
...
mount: count not find filesystem '/dev/root'
...
switchroot: moun filed: No such file or directory
Booting has failed.
Kernel panic - not syncing: ...


will now try maxcpus=1
Comment 7 Rex Dieter 2007-05-25 12:54:36 EDT
maxcpus=1
works nicely.
Comment 8 Nikos Charonitakis 2007-05-25 16:31:14 EDT
also on my d620 kernel 2.6.21-1.3194.fc7 hangs

with maxcpus=0
IOAPIC[0]: Invalid reference to IRQ 0 (5 same messages)
ata1.00: failed to set xfermode (err_mask=0x40) (3 same messages)
ata2.00: failed to set xfermode (err_mask=0x4) (3 same messages)
...
Unable to access resume device (/dev/VolGroup00/LogVol01)
mount: count not find filesystem '/dev/root'
setuproot: moving /dev/failed: No such file or directory
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

with maxcpus=1 boots with no problem
Comment 9 Wart 2007-05-25 21:49:53 EDT
One more data point for those keeping score:

My Dell Precision M65 laptop was working fine with
kernel-2.6.21-1.3189.fc7.i686.  Booting kernel-2.6.21-1.3194.fc7.i686 hangs
unless I set maxcpus=1.
Comment 10 Bastien Nocera 2007-05-26 11:27:09 EDT
-3191 is the last kernel to boot properly, -3194 hangs hard on boot. So it would
be one of those changes:
* Wed May 23 2007 Dave Jones <davej@redhat.com>
- Disable more debug options in the non-debug builds.

* Wed May 23 2007 Dave Jones <davej@redhat.com>
- Disable ub block driver.

* Wed May 23 2007 Dave Jones <davej@redhat.com>
- 2.6.21.2

The bottom one looks the more likely culprit...
Comment 11 Bojan Smojver 2007-05-27 00:03:30 EDT
*** Bug 241506 has been marked as a duplicate of this bug. ***
Comment 12 Bojan Smojver 2007-05-27 00:06:49 EDT
So, as per above duplicate, this affects (some) machines with Pentium Dual Core
CPUs too.
Comment 13 Kevin Kofler 2007-05-27 04:44:29 EDT
That's not too surprising, because the "Pentium" Dual Core is not a real 
Pentium, it's a stripped-down Core Duo, similar to how the Celerons were 
stripped-down Pentiums.
Comment 14 Bojan Smojver 2007-05-27 05:11:45 EDT
Yeah, the old marketing tricks kicked in there for Intel ;-)

Anyhow, I actually have another Dell Inspiron 6400, with "real" Core Duo this
time and that one doesn't hang (it did once, but not after that). Go figure...

Anyhow, the workaround of maxcpus=1 worked in the Pentium box. The other
suggested workaround, maxcpus=0, didn't. Something about APIC going nuts got
printed on the console.
Comment 15 Bojan Smojver 2007-05-27 23:09:54 EDT
Just had a second hang on the Core Duo notebook (Dell Inspiron 6400) and then a
successful boot straight after that.
Comment 16 Bojan Smojver 2007-05-28 17:27:55 EDT
Two new pieces of information:

- once current devel tree is installed (kernel 3194), the system consistently
hangs (i.e. no longer intermittently, like it did from the CD) on my Core Duo
Dell Inspiron 6400 (maxcpus=1 still works around it)

- the new kernel, just built in koji (3208), still hangs (the last message is
apm: no BIOS or something and then it locks up - with numlock on)
Comment 17 Wart 2007-05-28 19:33:22 EDT
3207 locks up my Dell Precision M65 unless I have maxcpus=1, but 3208 boots fine
for me.
Comment 18 Rex Dieter 2007-05-29 10:37:23 EDT
3208 worksforme too (dell latitude d620, bios revision a08)
Comment 19 shmuel siegel 2007-05-29 10:46:06 EDT
3208 is also working on my latitude d620 Core Duo
Comment 20 Bojan Smojver 2007-05-29 18:17:11 EDT
Created attachment 155648 [details]
Screen shot of failure on Dell Inspiron 6400 with Core Duo CPU (kernel 3208)
Comment 21 Bojan Smojver 2007-05-29 18:23:42 EDT
The above screen shot is for kernel 3208.
Comment 22 Bojan Smojver 2007-05-29 23:39:55 EDT
Created attachment 155657 [details]
Screen shot of failure on Dell Inspiron 6400 with Core Duo CPU (kernel 3209)
Comment 23 Bojan Smojver 2007-05-30 02:12:31 EDT
Workaround with 3209 on Dell Inspiron 6400: clocksource=acpi_pm, as per:
http://lkml.org/lkml/2007/3/7/554
Comment 24 Bojan Smojver 2007-05-30 03:29:17 EDT
Created attachment 155660 [details]
Data obtained from Intel's Firmware Developer Kit, release 2

I'm not sure if this is useful to someone, but here it is nonetheless.
Comment 25 Bojan Smojver 2007-05-30 06:26:10 EDT
F7 Live RC2 CD boots on my other Inspiron 6400 with clocksource=acpi_pm. This is
kernel 3194. So, at least on this hardware, maxcpus=1 is not required.

There were patches to clocksource.[ch] in stable 2.6.21 series, so maybe that's
where the problem is.
Comment 26 Bojan Smojver 2007-05-30 06:46:17 EDT
Yep, the clocksource=acpi_pm works on my first Inspiron 6400 with 3194 kernel as
well.
Comment 27 Brian Manning 2007-05-31 13:24:05 EDT
(In reply to comment #26)
> Yep, the clocksource=acpi_pm works on my first Inspiron 6400 with 3194 kernel as
> well.

I would like to add that my Dell XPS 1210M with a T2500 CoreDuo chip also
exhibited this exact bug, and adding the "clocksource=acpi_pm" seems to make it
work again with both cores!
Comment 28 Brian Millett 2007-05-31 20:07:02 EDT
Is this the kernel that is on the Fedora 7 Live CD?  Because it will not boot my
dell d820 unless I add the maxcpus=1 to the boot line.

If it is, this really SUCKS for a new release.
Comment 29 Brian Millett 2007-05-31 22:21:50 EDT
Ok, the clocksource=acpi_pm works also.  This looks the the better way to boot
the livecd, rescue cd and the dvd.
Comment 30 Jarod Wilson 2007-05-31 22:56:15 EDT
*** Bug 241983 has been marked as a duplicate of this bug. ***
Comment 31 S. Senthil Anand 2007-06-01 03:15:11 EDT
ntel Core Duo. Live CD did not boot. maxcpus=1 made it work. Then I installed
the PAE kernel version 3194 from repos since it had NX bit support. Now the
system boots without any trouble.
Comment 32 Brian G. Anderson 2007-06-01 10:06:22 EDT
I have a D620 with a Core 2 Duo and it has the same problem, so it isn't just a
core duo problem. The clocksource parameter allows boot.
Comment 33 Andy Grimm 2007-06-01 23:59:57 EDT
So, here is an added wrinkle to this one ... 3194 boots just fine for me on my
D620 *if* I'm docked.  Undocked, I worked around the freeze with "noacpi", but
will try the clocksource option...
Comment 34 Phil Anderson 2007-06-02 00:42:50 EDT
Same problem with Dell Inspiron 9400 with a Centrino Duo T2400.  clocksource
allows the system to boot.
Comment 35 Andres Moore 2007-06-02 22:47:58 EDT
Same here, Dell Latitude D820. 
maxcpus=1 works. This machine is not a "real" Core 2 duo, its the old Core duo.
Comment 36 Dave Jones 2007-06-03 14:43:22 EDT
The in-progress kernel at http://people.redhat.com/davej/kernels/Fedora/fc7/ 
fixes this for some folks. It'd be good to know if it doesn't fix it for anyone
tracking this bug.
Comment 37 Brian Manning 2007-06-03 17:42:13 EDT
(In reply to comment #36)
> The in-progress kernel at http://people.redhat.com/davej/kernels/Fedora/fc7/ 
> fixes this for some folks. It'd be good to know if it doesn't fix it for anyone
> tracking this bug.

It did not fix it for my Dell XPS 1210M, CoreDuo T2500, A6 bios rev.

It hangs right after ACPI messages and says "checking if image is initramfs..."
then one last message of "Switched to high resolution mode on CPU 1"

Then dead hang, must power-cycle to reboot.

This kernel as well as the stock FC7 do work with "clocksource=acpi_pm" for me.

If you need more info, please feel free to ask.
Comment 38 Bojan Smojver 2007-06-03 18:04:35 EDT
Regarding comment #36, did you have a look at that clocksource patch in .2? Does
it look suspect?
Comment 39 Phil Anderson 2007-06-03 18:46:48 EDT
kernel-2.6.21-1.3212.fc7.i686 still does not boot for me without the clocksource
line on my Inspiro 9400 (Centrino Duo T2400).
Comment 40 Thomas Gleixner 2007-06-04 12:53:32 EDT
Can you please try with "hpet=disable" on the kernel command line ?

Thanks,
  tglx

Comment 41 Brian Millett 2007-06-04 14:08:07 EDT
Too bad, so sad. "hpet=disable" does not work.
Comment 42 Jeremy Katz 2007-06-04 15:00:56 EDT
*** Bug 242235 has been marked as a duplicate of this bug. ***
Comment 43 Tim Behrsin 2007-06-04 16:17:14 EDT
Dell Inspiron 9400, Intel Centrino Duo T5200

clocksource=acpi_pm works for me
Comment 44 Phil Lembo 2007-06-04 19:48:26 EDT
Dell Dimension E150n, with Pentium D, same issue. None of the workarounds
presented here work. Stands still at "Ready" prompt. Unbootable.
Comment 45 Phil Lembo 2007-06-04 21:56:14 EDT
(In reply to comment #44)
> Dell Dimension E150n, with Pentium D, same issue. None of the workarounds
> presented here work. Stands still at "Ready" prompt. Unbootable.

Sorry, correction, E510n. Pentium D 820 (Smithfield).
Comment 46 Stuart Foote 2007-06-05 00:54:02 EDT
Updated via DVD image from FC6 completed, but hung at first boot;
delete and try the Fedora 7 DVD again from scratch, hangs at same point at first
boot...

  applied the "clocksource=acpi_pm" workaround to grub kernel line; clean boot
and made the change permanent to /boot/grub/grug.conf

So, update probably would have been salvagable; do not appear to need the
"maxcpus=1" with both cores fully functional

sf
=-=-=
Dell Inspiron E1705 (9400), Intel Core 2 Duo T7200
Intel 82891G
Mobile Intel 945GM/GU/PM/GMS/940GML/943GML and Intel 945GT
nVidia GeForce Go 7900 GS
Comment 47 Jeremy Katz 2007-06-05 11:06:28 EDT
*** Bug 242719 has been marked as a duplicate of this bug. ***
Comment 48 Gilles Berger Sabbatel 2007-06-06 10:33:59 EDT
I have the same problem with an update of a Dell Latitude D620 with i386 install.
However, another D620 installed (not updated) in x86_64 works fine.
BTW, I also tried to upgrade from an i386 installation to an x86_64, and it
resulted in a mess...
Comment 49 Hans de Goede 2007-06-06 11:00:23 EDT
*** Bug 242867 has been marked as a duplicate of this bug. ***
Comment 50 G. Michael Carter 2007-06-06 15:07:17 EDT
Don't know about others but I used clocksource=acpi_pm on my D620 and everything
is working great.

Comment 51 Stephen Hamilton 2007-06-06 17:01:06 EDT
I had the same issue of my laptop not booting.  I have a Dell Inspiron E1705
Core Duo, and the xen kernel booting without any issues, but until I added
maxcpus=1, the standard kernel would not boot.
Comment 52 Hans de Goede 2007-06-10 06:35:40 EDT
*** Bug 242096 has been marked as a duplicate of this bug. ***
Comment 53 Need Real Name 2007-06-10 22:24:50 EDT
clocksource=acpi_pm fixes the problem on my Dell Latitude D820 (Core 2 Duo).

I see a lot of "me too"s here, but nobody with any answers.  Has anyone figured
out what's causing this?
Comment 54 Bojan Smojver 2007-06-11 04:30:23 EDT
I think there was some discussion on LKML regarding this, related to the next
stable patch to 2.6.21. Hopefully, we'll see a fix soon.
Comment 55 Bojan Smojver 2007-06-11 04:49:37 EDT
BTW, latest builds of kernel in Koji
(http://koji.fedoraproject.org/koji/buildinfo?buildID=8524) may contain RCs of
the next stable patch. Maybe worth trying and reporting back. I haven't had a
chance yet...
Comment 56 Tarjei Knapstad 2007-06-11 06:21:45 EDT
clocksource=acpi_pm also works for me. 

Dell Precision M65, BIOS A08 (Core 2 Duo, T7200)
Comment 57 Patrick Steiner 2007-06-11 06:37:00 EDT
clocksource=acpi_pm also work for me.

Dell Latitude D420, BIOS A04 (Core 2 Duo, U2500)
Comment 58 Steve 2007-06-11 09:31:13 EDT
clocksource=acpi_pm works for me.  Does this mean that I am not using the
tickless kernel?

Dell Precision M90 BIOS A06 (Core 2 Duo, T7400)
Comment 59 Bojan Smojver 2007-06-11 18:27:43 EDT
Kernel 3226 boots fine on both of my Inspiron 6400s, with no special options
related to this problem (I only have combined_mode=libata, for the performance
of DVD-RW).
Comment 60 Susi Lehtola 2007-06-13 04:02:28 EDT
Kernel 2.6.21-1.3226.fc7 works for me too; my Latitude D420 (Core Duo U2500)
didn't work with 3194.
Comment 61 Stuart Foote 2007-06-14 12:57:51 EDT
(In reply to comment #46)

Updated today to .3228 from the DVD iso's .3194

Removed the clocksource kernel param from grub.conf, boots without issue.

So, believe the "clocksource=acpi_pm" workaround is no longer needed from .3226
foward as per #60 (Except of course for new install or reinstall from
distribution ISO).

sf
Comment 62 Bojan Smojver 2007-06-15 20:26:07 EDT
3228 works here.
Comment 63 Steve 2007-06-15 23:15:03 EDT
I can also confirm that 3228 works here too.  It can boot without the
clocksource parameter.
Comment 64 Patrick Steiner 2007-06-16 03:59:59 EDT
3228 also works for me. on my dell d420
Comment 65 Thomas Gleixner 2007-06-16 04:11:34 EDT
It would be great, when someone with an affected machine could test drive:

http://www.tglx.de/projects/hrtimers/2.6.22-rc4/patch-2.6.22-rc4-hrt10.patch

Thanks,

   tglx
Comment 66 gj 2007-06-21 16:42:07 EDT
Ok, my Dell Dimension E510 with dual core freezes no matter whether I use
maxcpu=1, maxcpu=0 or clocksource=acpi_pm...
What do I do next? Wait for FC8?
Comment 67 Chuck Ebbert 2007-06-21 16:45:13 EDT
(In reply to comment #66)
> Ok, my Dell Dimension E510 with dual core freezes no matter whether I use
> maxcpu=1, maxcpu=0 or clocksource=acpi_pm...
> What do I do next? Wait for FC8?

that's "maxcpus"
Comment 68 gj 2007-06-21 16:50:21 EDT
sorry, typo in my mail, not in the boot trials...
Comment 69 Bojan Smojver 2007-06-21 17:16:44 EDT
Regarding comment #66, this is with the latest kernel, 3228, right?
Comment 70 gj 2007-06-21 17:56:31 EDT
This is from the default FC7 DVD, F-7-i386-DVD.iso. Forgive my lack of
knowledge, I just don't know how to update from FC6 to FC7 if I can't boot in
the first place. I expect the 3228 kernel to resolve the issue but how do I get
there? Any advice or links to documentation are highly welcome.
Comment 71 Bojan Smojver 2007-06-21 19:06:01 EDT
If you system is already running FC6, you can use "yum upgrade" to do this.
Install the fedora-release RPM from F7 (you will need to install both
fedora-release-7-3 and fedora-release-notes-7.0.0-1 packages) using RPM. Then
run yum upgrade. This should pick up the updates repository and install the
latest kernel (3228) for you. Anyhow, you should see that in your transaction
before agreeing to go ahead.

A word of caution - don't do this from an X session as your X may die during the
upgrade, which will leave you with a whole lot of duplicate packages. Better
drop to a text console and do it from there.

If you want to test a few more boot options, some of them are listed here:

http://fedoraproject.org/wiki/Fedora7/FAQ#head-1d333d02c2c2e2f3b06d18ce92d41dcbba823d59

For instance, my P3 machine won't run my third NIC correctly without either
acpi=off or acpi=noirq.
Comment 72 Bojan Smojver 2007-06-21 19:32:27 EDT
Oh, one more thing. You probably want to make sure you BIOS is up to date as well.
Comment 73 Tarjei Knapstad 2007-06-22 06:09:32 EDT
Confirmed working with 3228

Dell Precision M65, BIOS A08 (Core 2 Duo, T7200)
Comment 74 Linus Walleij 2007-06-26 10:50:12 EDT
Positives:
This Dell XPS 210 has no problems whatsoever, not with the default install
CD or any later kernels, despite being a Core 2 duo machine. Tell me if 
there's anything you want me to test on this hardware.
Comment 75 Sijis Aviles 2007-06-27 12:14:13 EDT
I have a D520 (Intel Centrino Duo) and I'm having the same issues. I'm currently
using kernel 2.6.21-1.3228.fc7. I'm only able to boot using clocksource=acpi_pm
or maxcpus=1 (my default). If I remove any of the mentioned options, the system
stays put at "Uncompressing Linux... OK, booting the kernel". I waited 5 minutes
and it never passed that point.
Comment 76 NILMONI DEB 2007-07-27 12:57:03 EDT
I see the same boot-time hang in a Dell latitude D620 (dual core T2400) with 
the default kernel-2.6.21-1.3194.fc7. The hang is catastrophic and power cycle 
reset is the only way out. After using the boot option "acpi=off", the system 
boots fine.
Comment 77 Rex Dieter 2007-07-27 13:10:19 EDT
All releases since 3208 (May 29 comment #18) work fine (for me), particularly
recent kernel-2.6.22.1 (-27.fc7, -33.fc7) updates.

afaic, problem is resolved, closing.
Comment 78 NILMONI DEB 2007-07-28 02:56:09 EDT
(In reply to comment #77)
> All releases since 3208 (May 29 comment #18) work fine (for me), 
particularly
> recent kernel-2.6.22.1 (-27.fc7, -33.fc7) updates.
> 
> afaic, problem is resolved, closing.

I can confirm that kernel 2.6.22.1-33.fc7 boots fine without any special 
options.

Comment 79 Sijis Aviles 2007-08-03 17:48:03 EDT
(In reply to comment #75)
> I have a D520 (Intel Centrino Duo) and I'm having the same issues. I'm currently
> using kernel 2.6.21-1.3228.fc7. I'm only able to boot using clocksource=acpi_pm
> or maxcpus=1 (my default). If I remove any of the mentioned options, the system
> stays put at "Uncompressing Linux... OK, booting the kernel". I waited 5 minutes
> and it never passed that point.

I can also confirm that these kernels now work without any special boot options:

2.6.22.1-33.fc7
2.6.22.1-41.fc7
Comment 80 Stan Klein 2007-08-27 10:25:44 EDT
I'm having a problem installing F7 from DVD on a Dell Vostro 200 with its
processor described as an "Intel® Pentium® Dual-Core Processor E2140".  The
machine has a SATA drive with an Intel ICH9 chip set.  The installer tries the
ata_piix driver, and hangs for awhile.  Then it enters the selection menus for
installing.  I did some Googling and found out that the proper driver is the
ahci.  However, in doing the menus, it seems to go two items for each key press.
 For example, in going forward or back it always goes two menus instead of one.
 When it gets to a menu listing the drivers, if I up or down arrow, it goes two
selections,  It won't let me select the ahci driver, always skipping over it.

I tried two different keyboards, and get the same result.  I also used the same
DVD on an older machine with different processor and an ATA-100 EIDE hard drive
and had no problems.

Is this the same bug, and is there any workaround for getting F7 installed on
this machine?
Comment 81 Ender Everett 2007-10-24 07:18:12 EDT
I am experiencing the same issue since FC6. I am not running Intel X Dell,
though, I am on an HP Pavillion dv6000, AMD 64X2.

I'm getting consistent boot hangs immediately after HAL starts when the screen
blanks for the X restart. This failure is 100% whenever the network cable is
plugged in and eth0 acquires an identity. If the network cable is unplugged and
eth0 fails, I have about a 40% chance of a successful boot.

The same failure occurs when I log out locally from an X session and the network
connection is active. If I disable the network and unplug the cable, then I have
the same chance to restart X successfully as if it were boot time.

Don't know how they are related, but they definitely are. Extremely irritating.

Have not tried this since an FC7 update, however. I will update and make another
try shortly.
Comment 82 Ender Everett 2007-10-24 19:02:47 EDT
Updated as of 2007.10.24. Exact same problems. Hopefully this gets fixed so I
can use Fedora again someday. This is pretty much a system-killer bug, as no
casual user will ever stick with a distro past getting black-screened 3 times or so.

So why is this issue considered of "medium" importance? Dual-core AMD64 laptops
are in no way rare these days...
Comment 83 Chuck Ebbert 2007-10-25 19:40:50 EDT
(In reply to comment #80)
> I'm having a problem installing F7 from DVD on a Dell Vostro 200 with its
> processor described as an "Intel® Pentium® Dual-Core Processor E2140".  The
> machine has a SATA drive with an Intel ICH9 chip set.  The installer tries the
> ata_piix driver, and hangs for awhile.  Then it enters the selection menus for
> installing.  I did some Googling and found out that the proper driver is the
> ahci.  However, in doing the menus, it seems to go two items for each key press.
>  For example, in going forward or back it always goes two menus instead of one.
>  When it gets to a menu listing the drivers, if I up or down arrow, it goes two
> selections,  It won't let me select the ahci driver, always skipping over it.
> 
> I tried two different keyboards, and get the same result.  I also used the same
> DVD on an older machine with different processor and an ATA-100 EIDE hard drive
> and had no problems.
> 
> Is this the same bug, and is there any workaround for getting F7 installed on
> this machine?


Fedora 7 respins are now available:

http://spins.fedoraunity.org/spins
Comment 84 Chuck Ebbert 2007-10-25 19:42:19 EDT
(In reply to comment #81)
> I am experiencing the same issue since FC6. I am not running Intel X Dell,
> though, I am on an HP Pavillion dv6000, AMD 64X2.
> 
> I'm getting consistent boot hangs immediately after HAL starts when the screen
> blanks for the X restart. This failure is 100% whenever the network cable is
> plugged in and eth0 acquires an identity. If the network cable is unplugged and
> eth0 fails, I have about a 40% chance of a successful boot.

That is a completely different problem. Please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.