Bug 244030 - powernow-K8 doesn't load on MP systems
Summary: powernow-K8 doesn't load on MP systems
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 6
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-13 13:36 UTC by Alec Leamas
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-29 17:51:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Alec Leamas 2007-06-13 13:36:43 UTC
Description of problem: powernow-K8 doesn't load on MP systems, and power
consumption thus becames (too) high.


Version-Release number of selected component (if applicable):

kernel 2.6.20-1.2952.fc6. Has been around since I changed mobo, before FC6 was
released.

How reproducible: Always at boot time.

Steps to Reproduce:
1. Boot FC6 on my Asus M2N32 WS Pro mobo
2. See dmesg log "powernow-k8: MP Systems not supported by PSB BIOS structure"

  
Actual results: CPU always runs at max speed, Error dialogs when starting Gnome  UI.


Expected results: powernow-K8 running, decreased CPU speed when applicable,
decreased pwer consumption.

Additional info: This is basically a bug in the Asus BIOS. However, it seems
unlikely that it ever will be fixed, and we thus might be forced to live with it.

Hw: Asus M2N32 WS pro CPU: : AMD Athlon(tm) 64 X2 Dual Core Processor 4200+
BIOS: Asus firmware 1102

Possibly a dup to bug 185578, reported against RH4.

Comment 1 Tim Born 2007-07-19 00:29:53 UTC
I'm also seeing this error ('powernow-k8: MP systems not supported by PSB BIOS
structure') on every boot up of a Dell Inspiron 531s, Athlon 64 X2.  I'm running
RHEL5 at the moment.

Would love to help test any fix.  I really don't need to be running full out all
the time.  Waste of energy and it generates a lot of heat.

Comment 2 Tim Born 2007-07-19 00:56:06 UTC
Found the solution in the BIOS (Dell Inspiron 531s).  It's not in the power
section, it's under Advanced / CPU Configuration / AMD Cool'n'Quiet Function. 
It ships in the disabled state, for some reason, but when enabled the powernow
seems to load correctly.

Comment 3 Martin Bacovsky 2007-08-29 11:29:39 UTC
I suppose this is assigned on kdnssd-avahi by mistake. Changing component to 
kernel. 

Comment 4 Chuck Ebbert 2007-08-29 17:51:47 UTC
This is almost certainly a BIOS bug.


Note You need to log in before you can comment on or make changes to this bug.