Bug 244048 - [RHEL4]: ip6tables failing on ipv6headers module
Summary: [RHEL4]: ip6tables failing on ipv6headers module
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iptables (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On: 244047
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-13 14:28 UTC by Chris Lalancette
Modified: 2018-10-20 00:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-31 02:45:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Lalancette 2007-06-13 14:28:31 UTC
+++ This bug was initially created as a clone of Bug #244047 +++

Description of problem:
This is the RHEL-4 version of the same problem listed in BZ 165145: namely, when
you do the following:

# ip6tables -A INPUT -m ipv6header --header route -j DROP

Couldn't load match `ipv6header':/lib/iptables/libip6t_ipv6header.so: cannot
open shared object file: No such file or directory

I tracked this down into the iptables package proper.  If you look in
iptables/extensions/Makefile, there is a test near the beginning called
"PF6_EXT_SLIB_OPTS".  What it does is run through all of the .*-test6 files,
running each of them, and adding them to the "PF6_EXT_SLIB_OPTS" list if they
print out their own name.  In the case of .ipv6header-test6, it looks to see if
both the ip6t_ipv6header.h *and* ip6t_ipv6header.c files are present in
/usr/include/linux, which is obviously not the case, so the match fails.  So the
kernel has ipv6header built-in, but the test is failing so the requisite
ipv6tables .so is not being built.

The second part of the problem is that the part that builds the man pages
completely ignores what was found, and just builds the man page for *all*
possible modules, regardless of they were built or not.

So my recommendation here is:
1)  Fix upstream so that only the parts of iptables/ip6tables that are built are
included in the man page.  This should be a fairly simple Makefile fix.
2)  Fix the tests in the extensions/ directory to only look for the header file.
 Besides the ipv6header module, there are/may be some other modules that are not
being built into the iptables package despite having proper kernel support built in.

Chris Lalancette

Comment 2 RHEL Product and Program Management 2008-02-01 19:06:45 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".


Note You need to log in before you can comment on or make changes to this bug.