Bug 244047 - [RHEL5]: ip6tables failing on ipv6headers module
Summary: [RHEL5]: ip6tables failing on ipv6headers module
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: iptables   
(Show other bugs)
Version: 5.0
Hardware: All Linux
low
low
Target Milestone: ---
: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
Keywords:
: 339511 (view as bug list)
Depends On:
Blocks: 244048
TreeView+ depends on / blocked
 
Reported: 2007-06-13 14:25 UTC by Chris Lalancette
Modified: 2018-10-19 23:22 UTC (History)
3 users (show)

Fixed In Version: RHBA-2008-0333
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 15:42:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0333 normal SHIPPED_LIVE iptables bug fix update 2008-05-20 13:13:05 UTC

Description Chris Lalancette 2007-06-13 14:25:34 UTC
Description of problem:
This is the RHEL-5 version of the same problem listed in BZ 165145: namely, when
you do the following:

# ip6tables -A INPUT -m ipv6header --header route -j DROP

Couldn't load match `ipv6header':/lib/iptables/libip6t_ipv6header.so: cannot
open shared object file: No such file or directory

I tracked this down into the iptables package proper.  If you look in
iptables/extensions/Makefile, there is a test near the beginning called
"PF6_EXT_SLIB_OPTS".  What it does is run through all of the .*-test6 files,
running each of them, and adding them to the "PF6_EXT_SLIB_OPTS" list if they
print out their own name.  In the case of .ipv6header-test6, it looks to see if
both the ip6t_ipv6header.h *and* ip6t_ipv6header.c files are present in
/usr/include/linux, which is obviously not the case, so the match fails.  So the
kernel has ipv6header built-in, but the test is failing so the requisite
ipv6tables .so is not being built.

The second part of the problem is that the part that builds the man pages
completely ignores what was found, and just builds the man page for *all*
possible modules, regardless of they were built or not.

So my recommendation here is:
1)  Fix upstream so that only the parts of iptables/ip6tables that are built are
included in the man page.  This should be a fairly simple Makefile fix.
2)  Fix the tests in the extensions/ directory to only look for the header file.
 Besides the ipv6header module, there are/may be some other modules that are not
being built into the iptables package despite having proper kernel support built in.

Chris Lalancette

Comment 1 RHEL Product and Program Management 2007-10-31 18:25:09 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Thomas Woerner 2007-11-29 17:00:52 UTC
*** Bug 339511 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2008-05-21 15:42:42 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0333.html



Note You need to log in before you can comment on or make changes to this bug.