Bug 244144 - [HTS-i386-server] - Memory Test given Traceback Error
[HTS-i386-server] - Memory Test given Traceback Error
Status: CLOSED NOTABUG
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
5
i386 Linux
low Severity low
: ---
: ---
Assigned To: YangKun
: Desktop
: 244145 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-14 01:35 EDT by Satyabrata Maitra
Modified: 2008-07-16 17:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 02:06:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Hts-memory-traceback error log (849 bytes, text/plain)
2007-06-14 01:35 EDT, Satyabrata Maitra
no flags Details
i386-server-memory results.xml file (169.88 KB, text/xml)
2007-06-26 01:07 EDT, Satyabrata Maitra
no flags Details
output.log file (2.12 KB, text/plain)
2007-07-17 08:26 EDT, Satyabrata Maitra
no flags Details
results.xml-latest (89.45 KB, text/xml)
2007-07-17 08:27 EDT, Satyabrata Maitra
no flags Details

  None (edit)
Description Satyabrata Maitra 2007-06-14 01:35:22 EDT
Description of problem:
hts memory test on i386 server given traceback error.

Version-Release number of selected component (if applicable):
hts-5.0-48

How reproducible:
Always

Steps to Reproduce:

HTS is going to be run on "RHEL5 Server".

  1. download the latest HTS, dt, lmbench, stress package from porkchop:
      http://porkchop.devel.redhat.com/brewroot/packages/hts/5.0/
      http://porkchop.devel.redhat.com/brewroot/packages/dt/15.14/2.EL5/i386/
    http://porkchop.devel.redhat.com/brewroot/packages/lmbench/3.0a7/6.EL5/i386/
  http://porkchop.devel.redhat.com/brewroot/packages/stress/0.18.8/1.3.EL5/i386/
  http://porkchop.redhat.com/brewroot/packages/mt-st/0.9b/2.2.2/i386/

  2. install HTS on both "test machine" -- stable system(i386-server) and "server
machine" -- Any other system.
      # rpm -ivh hts-5.0-XX.noarch.rpm
  3. start HTS server daemon on "server machine":
      # hts server start

  4. make the "plan" on "test machine":
      # hts plan --server X.X.X.X  // "X.X.X.X" is the IP addr of "server
                                   //  machine"

  5. run all "planned" tests on "test machine":
      # hts print                  // list all planned tests, then run
                                   // each of them as following
  6. Run Command : hts certify --test memory
  7. Wait until the test is complete. Observe the result on terminal.

Actual results:
Memory test giving traceback error

Expected results:
It should PASS successfully finishing test!

Additional info: Error log is attached with this bug report.
Comment 1 Satyabrata Maitra 2007-06-14 01:35:22 EDT
Created attachment 156954 [details]
Hts-memory-traceback error log
Comment 2 Satyabrata Maitra 2007-06-14 09:10:17 EDT
How reproducible:
Random

Actually its making test PASS or FAIL, randomly, not all the time PASS or all
the time FAIL! 
Comment 3 Greg Nichols 2007-06-19 11:45:27 EDT
The traceback seems to indicate that the failing test run was the third run,
which leads me to believe that the test proceedure you outlined is not entirely
complete.

Please perform the following steps:

1) clean the hts logs and temporary files using the "hts clean" command.
Note any errors.

2) run "hts plan" to create a test plan.

3) run "hts certify --test memory" 

4) attach the /var/hts/results.xml file 

Thanks!
Comment 4 Satyabrata Maitra 2007-06-26 01:07:01 EDT
Created attachment 157854 [details]
i386-server-memory results.xml file

Hi Greg

This time memory test for i386-server is PASSED. I got the results.xml once
test completed. it is attached here.
And one more thing i observed, that for any test, if its failed, or quiting,
giving traceback error, the results.xml for that test is not creating in
/var/hts directory? As for some test which failed, I mentioned before that I
did not find results.xml. And this may be the reason, pls inform me the actual
fact behind not finding results.xml somewhere even if test performed and
FAILED.
Comment 5 YangKun 2007-07-03 04:27:01 EDT
Hi Satyabrata,

A short answer to your question is : remember to remove all former HTS related
files(files which under /var/hts/ and /var/log/hts/) before running the new tests.

Because HTS's output is "run-number" based(each "run" has a specific
run-number), in other words, the output logs are numbered ! Information which
stored in "results.xml" are consistent with "plan.xml" and "config.xml" and all
the contents under /var/log/hts/. If there are in-consistency between these
files, there will be trouble and errors.

Another notable thing is HTS is changing fast :) . Different releases may have
very big changes. So please remember to remove ALL old HTS related files(files
which under /var/hts/ and /var/log/hts/) before testing the new release.


Please confirm whether we can close this bug now ?

Thanks
-YK
Comment 6 YangKun 2007-07-03 04:31:25 EDT
*** Bug 244145 has been marked as a duplicate of this bug. ***
Comment 7 Satyabrata Maitra 2007-07-17 08:26:23 EDT
Created attachment 159423 [details]
output.log file

Memory Test on i386-5Server has been performed, and Its PASS for this time. The
output.log and results.xml file ia attached with this bug below.
Comment 8 Satyabrata Maitra 2007-07-17 08:27:12 EDT
Created attachment 159425 [details]
results.xml-latest
Comment 9 Satyabrata Maitra 2007-07-17 08:27:54 EDT
Please resolve this bug as it has been PASS.
Comment 10 YangKun 2007-07-18 09:13:25 EDT
Hi Satyabrata,

I'm confused. Do you mean the MEMORY test works well on i386 arch this time and
we can close this bug now ?

-YK
Comment 11 Satyabrata Maitra 2007-07-19 01:42:31 EDT
YK

Yes, absolutely right. its works well on i386 this time, pls close this bug. If
problem arise in future, we may reopen it. 

Note You need to log in before you can comment on or make changes to this bug.