Bug 244215 - kernel dm snapshot: activating of snapshot marked invalid causes incorrect mapping
Summary: kernel dm snapshot: activating of snapshot marked invalid causes incorrect ma...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Milan Broz
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
: 243130 251326 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-14 15:33 UTC by Milan Broz
Modified: 2013-03-01 04:05 UTC (History)
6 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 19:53:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Milan Broz 2007-06-14 15:33:44 UTC
+++ This bug was initially created as a clone of Bug #244214 +++
RHEL5 clone

Activation of volume group with overfilled snapshot (snapshot marked invalid in
metadata) causes incorrect mapping and causing userspace tools fails.

device-mapper: snapshot is marked invalid
device-mapper: Failed to read snapshot metadata
device-mapper: error adding target to table
  device-mapper: reload ioctl failed: Invalid argument


Snapshot should be "activated" normally but marked invalid only.

Also the mapping table for snapshot in kernel is then incorrect.

Reproducer script:
DEV=/dev/sdb1
VG=vg_test
LV=lv_test

pvcreate $DEV
vgcreate $VG $DEV
lvcreate -L 100M -n $LV $VG
lvcreate -s -L 4M -n "$LV"_snap $VG/$LV

#overfill snapshot
dd if=/dev/zero of=/dev/$VG/$LV bs=5M count=1
sync

vgchange -a n $VG

#activate VG with invalid snapshot
vgchange -a y $VG

#cleaning
vgchange -a n $VG
lvremove $VG/"$LV"_snap
lvremove $VG/"$LV"
vgremove $VG
pvremove $DEV

Comment 2 RHEL Product and Program Management 2007-06-14 16:54:00 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Don Zickus 2007-07-10 16:19:04 UTC
in 2.6.18-33.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 7 Milan Broz 2007-07-30 08:48:23 UTC
*** Bug 243130 has been marked as a duplicate of this bug. ***

Comment 8 Milan Broz 2007-09-13 16:46:21 UTC
*** Bug 251326 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2007-11-07 19:53:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.