Bug 244426 - gdm forget to sessreg a user
gdm forget to sessreg a user
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gdm (Show other bugs)
5.0
All Linux
high Severity high
: ---
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
:
Depends On:
Blocks: 668957
  Show dependency treegraph
 
Reported: 2007-06-15 12:00 EDT by Klaus Ethgen
Modified: 2011-10-19 14:02 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-19 14:02:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for /etc/gdm/PreSession/Default (804 bytes, patch)
2007-06-15 12:00 EDT, Klaus Ethgen
no flags Details | Diff

  None (edit)
Description Klaus Ethgen 2007-06-15 12:00:08 EDT
Description of problem:
In /etc/gdm/PreSession/Default should be normally the counterpart to
/etc/gdm/PostSession/Default to register a session properly. But this small part
seems to be forgotten in EL5.

How reproducible:
Just login under X and check if you logged in (from a console as root or per
ssh. If you open a terminal this will register the session if it is marked as
loginshell.)

Additional info:
I add a patch.
Comment 1 Klaus Ethgen 2007-06-15 12:00:08 EDT
Created attachment 157128 [details]
patch for /etc/gdm/PreSession/Default
Comment 2 R P Herrold 2007-07-26 09:56:50 EDT
This looks like a regression from prior behaviour under RHEL 4 and before ---
was it an intentional diminishment of functionality?  If so, why in the world
was it done as it makes auditing harder.
Comment 3 Ian Donaldson 2007-10-29 20:58:40 EDT
On FC7 I found that gdm seems to put a wtmp entry in by itself without
needing to use sessreg, but it doesn't put in a utmp entry.  

Comments in the gdm TODO indicate that adding a utmp entry is yet to be done.

The attached patch, above, will result in a duplicate wtmp entry, so
instead of "-w /var/log/wtmp" you need "-w none" on the sessreg line.

ie:
      exec "$SESSREG" -a -w none -u /var/run/utmp -x "$X_SERVERS" -h
"$REMOTE_HOST" -l "$DISPLAY" "$USER"
Comment 4 Adam Stokes 2009-07-27 11:03:19 EDT
This problem still exists in latest gdm release.

I assume this problem slipped under the radar due to the flag not being set for a update release.

Thanks,
Adam
Comment 5 Ray Strode [halfline] 2009-07-27 14:07:15 EDT
indeed.
Comment 10 RHEL Product and Program Management 2010-08-09 15:05:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 12 RHEL Product and Program Management 2011-05-31 10:22:32 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 13 Ray Strode [halfline] 2011-10-18 10:20:33 EDT
devack+
Comment 14 Vitezslav Humpa 2011-10-19 11:33:58 EDT
Could you please elaborate more on the issue/reproducer? Seems unclear for qa ack right now.
Comment 15 Klaus Ethgen 2011-10-19 11:54:34 EDT
Ehem, It is not clear for me what could be unclear about the reproducibility. Please specify your question a bit more.

I wounder why such a bug which is trivial to fix, needs more than 4 years to fix.
Comment 16 Ray Strode [halfline] 2011-10-19 14:02:05 EDT
Hi,

Reproduction instructions:

1) Log in via GDM
2) Open a terminal
3) run "w"

At this point you should see one entry for the display and one entry for the terminal launched in step 2, but with the bug, you'll only see an entry for the terminal and not one for the display.

I did a little digging today and rediscovered we actually fixed this a few years ago.

The update advisory where this was fixed is here:

https://rhn.redhat.com/errata/RHBA-2008-0398.html

Note You need to log in before you can comment on or make changes to this bug.