Bug 244506 - Compiz freezes at log-out
Compiz freezes at log-out
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kristian Høgsberg
:
: 244572 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-16 06:26 EDT by Nicolò
Modified: 2007-11-30 17:12 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-19 15:33:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolò 2007-06-16 06:26:22 EDT
Description of problem:
I enabled Compiz from the desktop-effects utility: they worked fine (wobbling,
cube, etc), but if I try to log-out, or disable effects, computer freezes,
Crtl-Alt-BkSpc has no effect, and I need to hard-reboot

Version-Release number of selected component (if applicable):
Compiz 0.3.6-8
Xorg-x11-drv-nvidia 100.14.09-1.lvn7
kmod-nvidia 100.14.09-1.2.6.21_1.3228

How reproducible:
Always

Steps to Reproduce:
1.Enable desktop effects
2.Try to log-out
OR
3.Try to disable desktop-effects
  
Actual results:
Complete system freeze

Expected results:
Log-out
OR
Disabling of Desktop Effects

Additional info:
Reinstalling Compiz did not help
Comment 2 Roel Gloudemans 2007-06-18 11:13:27 EDT
I've seen this too. I solved it by disabling the following lines in xorg.conf:

Option     "AllowGLXWithComposite" "true"
Option     "RenderAccel" "True"
Option     "ConnectedMonitor" "DFP"
Option      "AddARGBGLXVisuals" "true"
Option      "DisableGLXRootClipping" "true"
Option   "XAANoOffscreenPixmaps"    "true"

The last one is not used by the nvidia driver any more (last version), the first
lines are the default anyway, so in theory this should change nothing. However;
my problem is solved.
Comment 3 Roel Gloudemans 2007-06-18 14:13:19 EDT
Never mind, problem rappeared after fixing another problem with gtk-window-decorator
Comment 4 Nicolò 2007-06-18 14:26:23 EDT
what is your other problem??

However, the fix seems to work for me...
Comment 5 Roel Gloudemans 2007-06-18 14:34:14 EDT
gtk-window-decorator didn't start properly. I had to start it manually with a
nohup. Traced it to the theme I was using. It caused gtk-window-decorator to
send output to the controlling terminal. And since there isn't any on logging in....

Selecting the default clearlooks theme solved this, but made this come back
after it was working again.
Comment 6 Nicolò 2007-06-18 14:39:25 EDT
I don't have this problem, my session starts OK

However this fix worked only once (I.E. one log-out), now it's broken again. I
didn't make ANY change in between, this sounds very strange...
Comment 7 Aleksey Klimov 2007-06-23 16:40:18 EDT
I have this problem too.

nVidia Corporation NV44 [GeForce 6200 TurboCache(TM)] (rev a1)
Compiz 0.3.6-8
Xorg-x11-drv-nvidia 100.14.09-1.lvn7
kmod-nvidia 100.14.09-1.2.6.21_1.3228
Comment 8 David Fyfe 2007-06-25 03:38:51 EDT
Same problems her but some other interesting notes:
<alt><ctrl><backspace> also crashes the same as a log out - window decorations
start to disappear before a crash, within a minute the hard drive is accessed
occasionally, but after that the computer just sits there.
some luck when switching to a virtual console and doing a shutdown -h
This is all happening with the latest compiz, Xorg and kmod-nvidia.

I have tried to remove the lines (at least comment out)
"DisableGLXRootClipping"
 "AddARGBGLXVisuals"
but they were added back in again!
Comment 9 Nicolò 2007-06-25 06:52:04 EDT
Quote
I have tried to remove the lines (at least comment out)
"DisableGLXRootClipping"
 "AddARGBGLXVisuals"
but they were added back in again!

I experienced this too, very strange

However, this is probably a driver problem, since 96xx driver works for me...
Comment 10 Cort 2007-07-02 07:40:58 EDT
I don't have a proper fix for this, but I found that if I enable the magic sysrq
key, I can proceed with the normal shutdown sequence by using ALT+SYSRQ+K to
kill off Compiz/X once it hangs. This will at least avoid problems with file
system corruption that may occur due to improper shutdown.
Comment 11 Steve 2007-07-20 04:23:21 EDT
Exactly same problems here:

compiz-0.3.6-8.fc7
xorg-x11-drv-nvidia-100.14.11-1.lvn7
kmod-nvidia-100.14.11-1.2.6.21_1.3228.fc7
livna-config-display-0.0.14b-1.lvn7

You cal also log-in via ssh from another machine to reboot...
Comment 12 Steve 2007-07-21 04:07:23 EDT
Please have a look at here:

http://fedoraforum.org/forum/showthread.php?t=155615&page=4&pp=15

It seems to be a driver bug...
Comment 13 Nicolò 2007-07-22 11:59:53 EDT
So this is going to remain unfixed until (at least) the next Nvidia Driver,
correct? :(
Comment 14 Mohd Izhar Firdaus Ismail 2007-08-25 15:13:10 EDT
this bug happens only on NVidia card .. 

some folks from fedoraforum said that it is caused by indirect-rendering .. So i
decided to investigate ..

I compiled 2 compiz 0.5.2 .. one with the aiglx-defaults patch applied .. and
one without .. and tested in my friend's computer ( I dont have nvidia card )

and the result .. the compiz with aiglx-defaults patch crashes X when it is
killed .. and the one without the patch runs okay

running compiz --direct-rendering on the patched compiz does _not_ crash X too ..
Comment 15 Francesco 2007-08-29 10:30:11 EDT
I had this bug too. I solved it by disabling the following two lines in xorg.conf:

Option      "DisableGLXRootClipping" "true"
Option   "XAANoOffscreenPixmaps"    "true"

and downgrading from latest nvidia driver 100.14.11 to the 96xx series, and now
it works.
Comment 16 Aleksey Klimov 2007-09-06 11:49:03 EDT
I installed compiz 0.5.2. it's work fine, xorg-x11-drv-nvidia-100.14.11-1.lvn7.
Comment 17 Matěj Cepl 2007-09-06 17:41:18 EDT
Reporter, could you confirm comment 16 and that the problem has been fixed, please?

Thank you.
Comment 18 Matěj Cepl 2007-09-06 17:43:49 EDT
*** Bug 244572 has been marked as a duplicate of this bug. ***
Comment 19 Oliver Cole 2007-09-10 12:27:36 EDT
I had identical symptoms as the reporter, with latest packages as of this morning.

compiz 0.5.2 from source works fine - bug not reproducible.
Comment 20 Matěj Cepl 2007-09-17 07:09:57 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 21 Mohd Izhar Firdaus Ismail 2007-09-17 08:30:08 EDT
(In reply to comment #19)
> I had identical symptoms as the reporter, with latest packages as of this morning.
> 
> compiz 0.5.2 from source works fine - bug not reproducible.

back to my comment at comment #14 , this bug probably caused by
aiglx-defaults.patch in compiz RPM package which makes compiz to use indirect
rendering by default .. 

running compiz (from RPM), with --direct-rendering option does not crashes X
when compiz exited .. happens only on systems using NVidia binary drivers .. 

compiz from source works fine because it uses direct-rendering by default .. 
Comment 22 sangu 2007-09-19 04:43:22 EDT
This problem is Fixed in nvidia-driver100.14.19.
Comment 23 Matěj Cepl 2007-09-19 15:33:20 EDT
So, this is not our bug, and it is closed. WHy in the world I haven't closed
this yet?
Comment 24 Steve 2007-09-19 16:59:37 EDT
See Comment #12...
Comment 25 Matěj Cepl 2007-09-19 18:30:33 EDT
I meant this is not our bug, because it happens only nVidia binary-only drivers.
As far as I can read, there was no report of anything happening with nv driver
neither here nor in the fedoraforum discussion. We really cannot help anybody
with this binary blobs, as we don't see inside of them any better than you do.
So, this is CANTFIX. 
Comment 26 Matěj Cepl 2007-09-19 18:32:06 EDT
Standard notice for nVidia driver bugs follows:

Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo

Note You need to log in before you can comment on or make changes to this bug.