Bug 244511 - wpa_supplicant service $driver set to ndiswrapper instead of wext by default
wpa_supplicant service $driver set to ndiswrapper instead of wext by default
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wpa_supplicant (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 248444 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-16 08:07 EDT by Casual J. Programmer
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.5.7-4.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-14 22:35:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Casual J. Programmer 2007-06-16 08:07:42 EDT
Description of problem:
While running wpa_supplicant manually connecting to OPEN/WEP/WPA networks is
possible, wheras running it as service is not.

Investigation shows, that /etc/sysconfig/wpa_supplicant DRIVERS="-Dndiswrapper"
instead of DRIVERS="-Dwext". This variable is used in the
/etc/init.d/wpa_supplicant script when starting the service.

Version-Release number of selected component (if applicable):

wpa_supplicant 0.5.7-3

How reproducible:

cat /etc/sysconfig/wpa_supplicant

Actual results:
DRIVERS="-Dndiswrapper"

Expected results:
DRIVERS="-Dwext"
Comment 1 Dan Williams 2007-06-17 12:09:41 EDT
I'm not really sure this is a bug per-se, because you obviously need to change
the config file for wpa_supplicant to match your local hardware configuration. 
It may work by default with more peoples setups with "-Dwext", but you still
need to change INTERFACES to whatever your interface is, regardless of what
DRIVER is...

So basically, ndiswrapper should get changed to wext yes, but your expected
result is wrong because you have to configure it manually anyway.
Comment 2 Casual J. Programmer 2007-06-18 02:19:33 EDT
OK, but it shouldn't be set to ndiswrapper in the first place, as it seems to be
not part of the repository. 

There is some other shortcoming, which would make it easier to find out what's
going on:

in /etc/init.d/wpa_supplicant 

start() {
 	echo  $"Starting $prog: $conf, $interfaces, $drivers"

should read

start() {
 	echo  $"Starting $prog: $conf, $INTERFACES, $DRIVERS"

so you are aware which driver is actually being referenced. 

Also using ndiswrapper without it being installed leads to really nasty problems
in my installation ( FSC Amilo Si1520 Notebook with ipw3945 WLAN ).



Comment 3 Peter Lemenkov 2007-08-02 05:29:09 EDT
*** Bug 248444 has been marked as a duplicate of this bug. ***
Comment 4 Fedora Update System 2007-10-10 21:46:21 EDT
wpa_supplicant-0.5.7-4.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update wpa_supplicant'
Comment 5 Fedora Update System 2007-11-14 22:35:12 EST
wpa_supplicant-0.5.7-4.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.