Bug 244565 - PUP crash
Summary: PUP crash
Status: CLOSED DUPLICATE of bug 244537
Alias: None
Product: Fedora
Classification: Fedora
Component: yum   
(Show other bugs)
Version: 7
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: James Antill
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-17 12:11 UTC by Peter
Modified: 2014-01-21 22:58 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-17 13:46:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
bugzilla log (1.43 KB, text/plain)
2007-06-17 12:11 UTC, Peter
no flags Details

Description Peter 2007-06-17 12:11:40 UTC
Description of problem:
Product updater(pup) crash

Version-Release number of selected component (if applicable):


How reproducible:
run updater(pup)

Steps to Reproduce:
1.run updater(pup)
2.click apply updates
3.wait for resolving dependencies
4.crash
  
Actual results:
Component: Software Updater
Summary: TB8a9b4f2f packageSack.py:600:returnNewestByNameArch:PackageSackError:
No Package Matching kernel.i686

Traceback (most recent call last):
  File "/usr/sbin/pup", line 409, in _apply
    self.applyChanges(self.mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 718, in
applyChanges
    self.checkDeps(mainwin)
  File "/usr/lib/python2.5/site-packages/pirut/__init__.py", line 481, in checkDeps
    (result, msgs) = self.buildTransaction()
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 549, in
buildTransaction
    (rescode, restring) = self.resolveDeps()
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 856, in resolveDeps
    (checkdep, missing, conflict, errormsgs) = self._processConflict(dep)
  File "/usr/lib/python2.5/site-packages/yum/depsolve.py", line 662, in
_processConflict
    po = self.pkgSack.returnNewestByNameArch((confpkg.name,confpkg.arch))[0]
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 308, in
returnNewestByNameArch
    return bestofeach.returnNewestByNameArch(naTup)
  File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 600, in
returnNewestByNameArch
    raise PackageSackError, 'No Package Matching %s.%s' % naTup
PackageSackError: No Package Matching kernel.i686

Local variables in innermost frame:
highdict: {}
self: <yum.packageSack.ListPackageSack object at 0xc63c94c>
naTup: ('kernel', 'i686')
where: None


Expected results:
update

Additional info:

Comment 1 Peter 2007-06-17 12:11:40 UTC
Created attachment 157220 [details]
bugzilla log

Comment 2 Gianluca Varisco 2007-06-17 12:28:19 UTC
I think that the message "No Package Matching kernel.i686" refers to the problem
with libraw1394 reported here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=244474 

Comment 3 Gianluca Varisco 2007-06-17 12:32:52 UTC
We also should change the Component field from 'up2date' to 'pirut', CC:ed
katzj@redhat.com.

Comment 4 Ignacio Vazquez-Abrams 2007-06-17 13:46:32 UTC

*** This bug has been marked as a duplicate of 244537 ***


Note You need to log in before you can comment on or make changes to this bug.