Bug 2446 - Two Xsun problems with Ultra 1 + two cgsixes
Two Xsun problems with Ultra 1 + two cgsixes
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.0
sparc Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
:
: 971 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-30 15:40 EDT by sergent
Modified: 2008-05-01 11:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-08-31 09:36:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sergent 1999-04-30 15:40:06 EDT
I have an Ultra 1 with two cgsix framebuffers.
Two problems:

-- I cannot use both framebuffers -- Xsun hangs if I try
   "Xsun -dev /dev/fb0:/dev/fb1".  I've seen this work
   on Linux/SPARC before.  Once it locks up, I can't kill
   the server with Ctrl-Alt-Backspace.  Ctrl-Alt-Delete
   does work (although typing blindly at the console doesn't
   work).  I'm not sure exactly what state the system is in.

-- When I'm only using one framebuffer, Xsun works, except
   the bottom of the screen is garbled (about the last 50
   pixels or so).  About the bottom 45 pixels are shifted
   left and up, and overlap the approx 5 pixels above it.
   I do xrefresh and it happens again.  It happens
   regardless of application or WM, so it's a server bug,
   not an application writing bogus data.

I'm using the XFree86-Sun package from the 6.0 release.

I can email a jpeg screenshot of the garbled screen.
Comment 1 Jeff Johnson 1999-05-16 20:25:59 EDT
*** Bug 971 has been marked as a duplicate of this bug. ***

I'm using XFree 3.3.3.1 on a SparcServer 4.  It has the
onboard TCX and a single-slot GX card, both of which are
8-bit color framebuffers.  Xsun will start on both heads and
even let me send clients to display :0.1, but as soon as I
send something to :0.0 it dumps core.  I'm using kernel
2.0.35-15 (built from the rpms on your ftp site).  Things
work fine when I use either head as a separate X display.
This problem only evidences itself when I try to start up
Xsun in a dual-headed configuration.

------- Additional Comments From pbrown@redhat.com  03/22/99 16:04 -------
Jeff, do you know of any patches to fix this issue?

------- Additional Comments From jbj@redhat.com  04/09/99 14:34 -------
We'll try to fix this in XFree86-4.0.
Comment 2 David Miller 1999-05-18 03:01:59 EDT
It smells like a fbcon issue for the multi-head bug and thus
a kernel bug.  I have two cg6's so I can work on this locally.

The garbled bottom screen issue is easy to solve for me
too, since I have an Ultra1 machine which exhibits the behavior.
Comment 3 David Miller 1999-07-23 18:49:59 EDT
I have fixed the second issue, garbled contents at bottom
of screen.  It was a kernel bug and will be in the next kernel
updates.

It was also UltraSparc specific.
I will try to address the multi-head issue right now since I
finally have two cards in the CG6 family.
Comment 4 David Miller 1999-07-23 21:38:59 EDT
I have discovered and fixed the multi-head bug as well.
A bug in the LBX extension in the X server caused it to
corrupt memory when more than one screen existed.  This
is not surprising because whoever coded the most recent changes
in the Xfree86-3.3.x LBX area had no chance to test it, since
only the Sparc servers support multi-head and none of the
PCI etc. ones do.

I am sending the fix to the Sparc and Xfree86 package maintainers.
Once both a kernel and X update is posted with these fixes, this
bug can be closed finally.
Comment 5 Preston Brown 1999-08-31 09:35:59 EDT
fixes are now integrated.
Comment 6 alderd 1999-09-03 18:36:59 EDT
I see that as of 8.31.99 the bug fixes for this problem have been
integrated.  However, I cannot find the updated build for the
appropriate RPM's.

I am also having this problem on an Sparc Ultra1.

I downloaded updates for
XFree86-3.3.3.1-52.sparc.rpm
XFree86-Sun*-3.3.3.1-52.sparc.rpm
XFree86-Mach64-3.3.3.1-52.sparc.rpm

but from all update sites, build 52 is dated around June 14.
Where can I get the latest build that integrates these fixes?

Thanks in advance,
Dave Alderson
alderd@stanford.edu

Note You need to log in before you can comment on or make changes to this bug.