Bug 24472 - (AT3D) APM Server module trashes graphics in areas where movement occurs.
(AT3D) APM Server module trashes graphics in areas where movement occurs.
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 51259 58920 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-20 19:41 EST by John Eckerdal
Modified: 2007-04-18 12:30 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-26 02:29:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Eckerdal 2001-01-20 19:41:48 EST
A Hercules Stingray 128/3D using the APM module with XFree86 4.0.2 leaves
traces of
the mouse pointer, windows and texts. Areas might also sometimes be
corrupted with other
strange graphics. This does only happen in areas where something is
changing though,
like behind the mouse pointer (in any application). Moving windows also
leave strange
graphics (most of the time but not allways).
Starting netscape or mozilla (Raw Hide RPMS) terminates X with a signal 11,
smaller applications like xterm, gtv (from SMPEG) or XMMS works.

XFree86 version 4.0.2 (from Raw Hide) as configured by Xconfigurator 4.5
(also Raw Hide)
(I checked the configuration and it looked OK except for the DRI module
which I commented
out since DRI does not support a Voodoo Rush - tried once with the DRI
module loaded though to check if the problem disappeared. It didn't).
Earlier versions of Xconfigurator used the old XF86_SVGA from XFree86 3.3.6
instead. This
is the first version to actually use the new server module APM from XFree86
4.0.

If X is started using the XFree86 3.3.6 XF86_SVGA server instead all
problems disappears
(with a config file matching that server ofcourse).

In previous versions the APM module did not work at all - computer either
locked up solidly
or the screen went black and pressing CTRL-ALT-BACKSPACE did not restore
the videocard to a text mode (computer could however be rebooted).
Xconfigurator was not used here, rather xf86cfg (since Xconfigurator used
the old XF86_SVGA server). The RedHat 7.0
XFree86 APM module does not work either.
Comment 1 John Eckerdal 2001-02-05 06:19:02 EST
Tried the RedHat Fisher (beta) XFree86 4.0.2 with the same result, altough it was
somewhat more visible now (mouse pointer continously wrong). Also managed to get
the X-server terminated very easy.
Comment 2 Mike A. Harris 2001-04-02 12:32:59 EDT
Ok, to look into this, I will need 'all' of the following from ya:
X server logs from after a crash or after corruption/problem manifests,
copy of your configuration file, the output of all of the following:

lspci -v
lspci -vn
cat /proc/cpuinfo

attach each using the link below.

Comment 3 John Eckerdal 2001-04-02 13:39:19 EDT
More information: Tried XFree86 4.0.3 Rawhide RPMS and the problems remained.

Ok, here follows (parts of - skipping IDE,USB and such) lspci -v:

00:08.0 VGA compatible controller: Alliance Semiconductor Corporation ProMotion AT3D (rev 02) (prog-if 00 [VGA])
        Flags: 66Mhz, slow devsel
        Memory at e0000000 (32-bit, non-prefetchable)
        I/O ports at 65000

and parts of lspci -vn:
00:08.0 Class 0300: 1142:643d (rev 02)
        Flags: 66Mhz, slow devsel
        Memory at e0000000 (32-bit, non-prefetchable)
        I/O ports at 6500

Can't provide information about the server crash since it leaves the console
entirely black - hence it's quite hard to see anything.
Corruption of graphics does not normally mean a crash and when exiting after
corruption no errors are reported.
When a crash occurs it either locks the computer or leaves everything black,
ctrl-alt-del do still work.

The XF86Config-4 (your naming):

Section "ServerLayout"
        Identifier "XFree86 Configured"
        Screen     0 "Screen0" 0 0
        InputDevice  "Mouse0" "CorePointer"
        InputDevice  "Keyboard0" "CoreKeyboard"
EndSection

# By default, Red hat Linux 6.0 and later use xfs

Section "Files"
        FontPath "unix/:-1"
EndSection

# This loads all the modules
Section "Module"
        Load "GLcore"
        Load "dbe"
#       Load "dri"
        Load "extmod"
        Load "glx"
        Load "pex5"
        Load "record"
        Load "xie"
#       Load "v4l"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "keyboard"
        Option      "XkbLayout" "se"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Device" "/dev/mouse"
        Option      "Protocol" "Microsoft"
        Option      "Emulate3Buttons" "off"
        Option      "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
        Identifier "SAM1d73"
        VendorName "Unknown"
        ModelName  "Unknown"
        HorizSync 30 - 54
        VertRefresh 50 - 120
        Option "DPMS"
EndSection

Section "Device"
        Identifier "My Video Card"
        Driver "apm"
        BoardName "Unknown"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device "My Video Card"
        Monitor "SAM1d73"
        DefaultDepth 24
        Subsection "Display"
            Depth 24
            Modes "1024x768"
        EndSubSection
EndSection

Section "DRI"
EndSection

(This is not cut'n'paste since I have never bothered to configure it - any
obvious spelling errors are mine and not the configuration file).
The original file was generated by Xconfigurator, that one did not work either. I later modified it (commented out parts and removed video modes).
Comment 4 Mike A. Harris 2001-05-10 23:38:20 EDT
Wrong component.
Comment 5 John Eckerdal 2001-06-14 11:06:02 EDT
Also tried version 4.1.0 from Rawhide now.

Same result. Either the screen is entirely black (computer sometimes still
responsive for an CTRL+ALT+DEL) or if it starts graphics is corrupted when
anything on the screen changes and the X-server almost allways crashes after
a while.

Also note that the 3.3.6 SVGA driver works as it is supposed to work (no
trashed graphics and it works every time).

In the mean time I've got a new USB mouse (the other was serial), but the
problem remained. The mouse do however work in 3.3.6.

Is this a problem that will remain unfixed?
Is more information needed?
Comment 6 Alexei Podtelezhnikov 2001-06-18 17:09:39 EDT
ATTACH your /var/log/XFree86.?.log using link bellow please.
Does you card have 16 MB of video ram? 
Would you please reduce color depth to 16 bpp? 24 bpp is a bad idea.
I bet you won't see a difference.
In general, what happenes at other (lower) resolutions?
Comment 7 John Eckerdal 2001-06-18 18:30:50 EDT
Sorry, but I could not get attach to work in Opera 5 (it says that either the file does not exist or
it is empty - I even tried to copy it and change owner of it but it did not help). Can only "attach"
it to this message (by marking it in another browser window and copy&paste).

And I tried to use 16bpp instead. Same result. Either black screen or graphics gets trashed.
Did not try to get the computer to lock up. In 3.3.6 I use 16bpp (so I assumed, wrongly that
I used that also for 4.x.x).
Have not tried lower resolutions with 4.1.0 but in 4.0.0 320x200 in 256 colours worked OK and 
that was the highest resolution I could get in that version. I think the graphics were garbeled at
lower resolutions also in version 4.0.1 - 3, but I am not sure. Will check this next.

The videocard has 6 MB of memory but only 4 MB is available to the AT3D. The other two
is for the 3Dfx-Rush card.

-- The XFree86.0.log --
XFree86 Version 4.1.0 (Red Hat Linux release: 4.1.0-0.0.1) / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 2 June 2001
        If the server is older than 6-12 months, or if your card is
        newer than the above date, look for a newer version before
        reporting problems.  (See http://www.XFree86.Org/FAQ)
Build Operating System: Linux 2.2.17-8smp i686 [ELF] 
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Tue Jun 19 00:22:09 2001
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
         (++) from command line, (!!) notice, (II) informational,
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "XFree86 Configured"
(**) |-->Screen "Screen0" (0)
(**) |   |-->Monitor "SAM1d73"
(**) |   |-->Device "My Video Card"
(**) |-->Input Device "Mouse0"
(**) |-->Input Device "Keyboard0"
(**) Option "XkbLayout" "se"
(**) XKB: layout: "se"
(==) Keyboard: CustomKeycode disabled
(**) FontPath set to "unix/:-1"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 3

(WW) Cannot open APM
(II) Module ABI versions:
        XFree86 ANSI C Emulation: 0.1
        XFree86 Video Driver: 0.4
        XFree86 XInput driver : 0.2
        XFree86 Server Extension : 0.1
        XFree86 Font Renderer : 0.2
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.0.0
        Module class: XFree86 Font Renderer
        ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 0.1.0
        ABI class: XFree86 Video Driver, version 0.4
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x80003ac0, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,7100 card 0000,0000 rev 01 class 06,00,00 hdr 00
(II) PCI: 00:07:0: chip 8086,7110 card 0000,0000 rev 01 class 06,01,00 hdr 80
(II) PCI: 00:07:1: chip 8086,7111 card 0000,0000 rev 01 class 01,01,80 hdr 00
(II) PCI: 00:07:2: chip 8086,7112 card 0000,0000 rev 01 class 0c,03,00 hdr 00
(II) PCI: 00:07:3: chip 8086,7113 card 0000,0000 rev 01 class 06,80,00 hdr 00
(II) PCI: 00:08:0: chip 1142,643d card 0000,0000 rev 02 class 03,00,00 hdr 00
(II) PCI: 00:0a:0: chip 8086,1229 card 8086,0001 rev 02 class 02,00,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 0.1.0
        ABI class: XFree86 Video Driver, version 0.4
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 0 I/O range:
        [0] -1  0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
        [0] -1  0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
        [0] -1  0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus -1: bridge is at (0:7:0), (0,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(0:8:0) Alliance Semiconductor ProMotion AT3D rev 2, Mem @ 0xe0000000/
24, I/O @ 0x6500/4
(II) Addressable bus resource ranges are
        [0] -1  0x00000000 - 0xffffffff (0x0) MX[B]
        [1] -1  0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
        [0] -1  0xffe00000 - 0xffffffff (0x200000) MX[B](B)
        [1] -1  0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
        [2] -1  0x000f0000 - 0x000fffff (0x10000) MX[B]
        [3] -1  0x000c0000 - 0x000effff (0x30000) MX[B]
        [4] -1  0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [5] -1  0x0000ffff - 0x0000ffff (0x1) IX[B]
        [6] -1  0x00000000 - 0x000000ff (0x100) IX[B]
(II) Active PCI resource ranges:
        [0] -1  0xe1000000 - 0xe1ffffff (0x1000000) MX[B]E
        [1] -1  0xe1100000 - 0xe11fffff (0x100000) MX[B]E
        [2] -1  0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
        [3] -1  0x00006600 - 0x000066ff (0x100) IX[B]E
        [4] -1  0x00006400 - 0x000064ff (0x100) IX[B]E
        [5] -1  0x0000f000 - 0x0000f0ff (0x100) IX[B]E
        [6] -1  0x00006500 - 0x0000650f (0x10) IX[B](B)
(II) PCI Memory resource overlap reduced 0xe1000000 from 0xe1ffffff to 0xe10ffff
f
(II) Active PCI resource ranges after removing overlaps:
        [0] -1  0xe1000000 - 0xe10fffff (0x100000) MX[B]E
        [1] -1  0xe1100000 - 0xe11fffff (0x100000) MX[B]E
      [2] -1  0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
        [3] -1  0x00006600 - 0x000066ff (0x100) IX[B]E
        [4] -1  0x00006400 - 0x000064ff (0x100) IX[B]E
        [5] -1  0x0000f000 - 0x0000f0ff (0x100) IX[B]E
        [6] -1  0x00006500 - 0x0000650f (0x10) IX[B](B)
(II) OS-reported resource ranges after removing overlaps with PCI:
        [0] -1  0xffe00000 - 0xffffffff (0x200000) MX[B](B)
        [1] -1  0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
        [2] -1  0x000f0000 - 0x000fffff (0x10000) MX[B]
        [3] -1  0x000c0000 - 0x000effff (0x30000) MX[B]
        [4] -1  0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [5] -1  0x0000ffff - 0x0000ffff (0x1) IX[B]
        [6] -1  0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
        [0] -1  0xffe00000 - 0xffffffff (0x200000) MX[B](B)
        [1] -1  0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
        [2] -1  0x000f0000 - 0x000fffff (0x10000) MX[B]
        [3] -1  0x000c0000 - 0x000effff (0x30000) MX[B]
        [4] -1  0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [5] -1  0xe1000000 - 0xe10fffff (0x100000) MX[B]E
        [6] -1  0xe1100000 - 0xe11fffff (0x100000) MX[B]E
        [7] -1  0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
        [8] -1  0x0000ffff - 0x0000ffff (0x1) IX[B]
        [9] -1  0x00000000 - 0x000000ff (0x100) IX[B]
        [10] -1 0x00006600 - 0x000066ff (0x100) IX[B]E
        [11] -1 0x00006400 - 0x000064ff (0x100) IX[B]E
        [12] -1 0x0000f000 - 0x0000f0ff (0x100) IX[B]E
        [13] -1 0x00006500 - 0x0000650f (0x10) IX[B](B)
(II) LoadModule: "GLcore"
(II) Loading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Module GLcore: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.0.0
        ABI class: XFree86 Server Extension, version 0.1
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.0.0
        Module class: XFree86 Server Extension
        ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.0.0
        Module class: XFree86 Server Extension
        ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.a
(II) Module glx: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.0.0
        ABI class: XFree86 Server Extension, version 0.1
(II) Loading sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Reloading /usr/X11R6/lib/modules/extensions/libGLcore.a
(II) Loading extension GLX
(II) LoadModule: "pex5"
(II) Loading /usr/X11R6/lib/modules/pex5.so
dlopen: /usr/X11R6/lib/modules/pex5.so: undefined symbol: PexExtensionInitPtr
(EE) Failed to load /usr/X11R6/lib/modules/pex5.so
(II) UnloadModule: "pex5"
(EE) Failed to load module "pex5" (loader failed, -1073742888)
(II) LoadModule: "record"
(II) Loading /usr/X11R6/lib/modules/extensions/librecord.a
(II) Module record: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.13.0
        Module class: XFree86 Server Extension
        ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension RECORD
(II) LoadModule: "xie"
(II) Loading /usr/X11R6/lib/modules/xie.so
dlopen: /usr/X11R6/lib/modules/xie.so: undefined symbol: XieInitPtr
(EE) Failed to load /usr/X11R6/lib/modules/xie.so
(II) UnloadModule: "xie"
(EE) Failed to load module "xie" (loader failed, -1073742888)
(II) LoadModule: "apm"
(II) Loading /usr/X11R6/lib/modules/drivers/apm_drv.o
(II) Module apm: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.0.0
        Module class: XFree86 Video Driver
        ABI class: XFree86 Video Driver, version 0.4
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.0.0
        Module class: XFree86 XInput Driver
        ABI class: XFree86 XInput driver, version 0.2
(II) APM: driver for the Alliance chipsets: AP6422, AT24, AT3D
(II) Primary Device is: PCI 00:08:0
(--) Assigning device section with no busID to primary device
(--) Chipset AT3D found
(II) resource ranges after xf86ClaimFixedResources() call:
        [0] -1  0xffe00000 - 0xffffffff (0x200000) MX[B](B)
        [1] -1  0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
        [2] -1  0x000f0000 - 0x000fffff (0x10000) MX[B]
        [3] -1  0x000c0000 - 0x000effff (0x30000) MX[B]
        [4] -1  0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [5] -1  0xe1000000 - 0xe10fffff (0x100000) MX[B]E
        [6] -1  0xe1100000 - 0xe11fffff (0x100000) MX[B]E
        [7] -1  0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
        [8] -1  0x0000ffff - 0x0000ffff (0x1) IX[B]
        [9] -1  0x00000000 - 0x000000ff (0x100) IX[B]
        [10] -1 0x00006600 - 0x000066ff (0x100) IX[B]E
        [11] -1 0x00006400 - 0x000064ff (0x100) IX[B]E
        [12] -1 0x0000f000 - 0x0000f0ff (0x100) IX[B]E
        [13] -1 0x00006500 - 0x0000650f (0x10) IX[B](B)
(II) resource ranges after probing:
        [0] -1  0xffe00000 - 0xffffffff (0x200000)MX[B](B)
        [1] -1  0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
        [2] -1  0x000f0000 - 0x000fffff (0x10000) MX[B]
        [3] -1  0x000c0000 - 0x000effff (0x30000) MX[B]
        [4] -1  0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [5] -1  0xe1000000 - 0xe10fffff (0x100000) MX[B]E
        [6] -1  0xe1100000 - 0xe11fffff (0x100000) MX[B]E
        [7] -1  0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
        [8] 0   0x000a0000 - 0x000affff (0x10000) MS[B]
        [9] 0   0x000b0000 - 0x000b7fff (0x8000) MS[B]
        [10] 0  0x000b8000 - 0x000bffff (0x8000) MS[B]
        [11] -1 0x0000ffff - 0x0000ffff (0x1) IX[B]
        [12] -1 0x00000000 - 0x000000ff (0x100) IX[B]
        [13] -1 0x00006600 - 0x000066ff (0x100) IX[B]E
        [14] -1 0x00006400 - 0x000064ff (0x100) IX[B]E
        [15] -1 0x0000f000 - 0x0000f0ff (0x100) IX[B]E
        [16] -1 0x00006500 - 0x0000650f (0x10) IX[B](B)
        [17] 0  0x000003b0 - 0x000003bb (0xc) IS[B]
        [18] 0  0x000003c0 - 0x000003df (0x20) IS[B]
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 0.1.0
        ABI class: XFree86 Video Driver, version 0.4
(==) APM(0): RGB weight 565
(==) APM(0): Default visual is TrueColor
(==) APM(0): Using SW cursor
(--) APM(0): Chipset: "AT3D"
(--) APM(0): Linear framebuffer at 0xE0000000
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.0.0
        ABI class: XFree86 Video Driver, version 0.4
(II) Loading sub module "i2c"
(II) LoadModule: "i2c"
(II) Loading /usr/X11R6/lib/modules/libi2c.a
(II) Module i2c: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.2.0
        ABI class: XFree86 Video Driver, version 0.4
(II) Loading sub module "int10"
(II) LoadModule: "int10"
(II) Loading /usr/X11R6/lib/modules/linux/libint10.a
(II) Module int10: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.0.0
        ABI class: XFree86 Video Driver, version 0.4
(II) APM(0): initializing int10
(II) APM(0): Primary V_BIOS segment is: 0xc000
(WW) System lacks support for changing MTRRs
(--) APM(0): VideoRAM: 4096 kByte
(II) APM(0): I2C bus "Alliance bus" initialized.
(II) APM(0): I2C device "Alliance bus:ddc2" registered.
(II) APM(0): I2C device "Alliance bus:ddc2" removed.
(--) APM(0): No DDC signal
(==) APM(0): Using gamma correction (1.0, 1.0, 1.0)
(==) APM(0): Min pixel clock set to 23 MHz
(==) APM(0): Max pixel clock is 144 MHz
(II) APM(0): SAM1d73: Using hsync range of 30.00-54.00 kHz
(II) APM(0): SAM1d73: Using vrefresh range of 50.00-120.00 Hz
(II) APM(0): Clock range:  23.12 to 144.00 MHz
(II) APM(0): Not using default mode "1024x768" (bad mode clock/interlace/doubles
can)
(II) APM(0): Not using default mode "1024x768" (hsync out of range)
(II) APM(0): Not using default mode "1024x768" (hsync out of range)
(II) APM(0): Not using default mode "1024x768" (hsync out of range)
(II) APM(0): Not using default mode "1152x864" (hsync out of range)
(II) APM(0): Not using default mode "1280x960" (hsync out of range)
(II) APM(0): Not using default mode "1280x960" (bad mode clock/interlace/doubles
can)
(II) APM(0): Not using default mode "1280x1024" (hsync out of range)
(II) APM(0): Not using default mode "1280x1024" (hsync out of range)
(II) APM(0): Not using default mode "1280x1024" (bad mode clock/interlace/double
scan)
(II) APM(0): Not using default mode "1600x1200" (bad mode clock/interlace/double
scan)
(II) APM(0): Not using default mode "1600x1200" (bad mode clock/interlace/double
scan)
(II) APM(0): Not using default mode "1600x1200" (bad mode clock/interlace/double
scan)
(II) APM(0): Not using default mode "1600x1200" (bad mode clock/interlace/double
scan)
(II) APM(0): Not using default mode "1600x1200" (bad mode clock/interlace/double
scan)
(II) APM(0): Not using default mode "1792x1344" (insufficient memory for mode)
(II) APM(0): Not using default mode "1792x1344" (insufficient memory for mode)
(II) APM(0): Not using default mode "1856x1392" (insufficient memory for mode)
(II) APM(0): Not using default mode "1856x1392" (insufficient memory for mode)
(II) APM(0): Not using default mode "1920x1440" (insufficient memory for mode)
(II) APM(0): Not using default mode "1920x1440" (insufficient memory for mode)
(II) APM(0): Not using default mode "1400x1050" (hsync out of range)
(II) APM(0): Not using default mode "1400x1050" (bad mode clock/interlace/double
scan)
(--) APM(0): Virtual size is 1024x768 (pitch 1024)
(**) APM(0): Default mode "1024x768": 65.0 MHz, 48.4 kHz, 60.0 Hz
(II) APM(0): Modeline "1024x768"   65.00  1024 1048 1184 1344  768 771 777 806 -
hsync -vsync
(==) APM(0): DPI set to (75, 75)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.0.0
        ABI class: XFree86 ANSI C Emulation, version 0.1
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
        compiled for 4.1.0, module version = 1.0.0
        ABI class: XFree86 Video Driver, version 0.4
(II) do I need RAC?  No, I don't.
(II) resource ranges after preInit:
        [0] 0   0xe0000000 - 0xe0ffffff (0x1000000) MS[B]
        [1] -1  0xffe00000 - 0xffffffff (0x200000) MX[B](B)
        [2] -1  0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
        [3] -1  0x000f0000 - 0x000fffff (0x10000) MX[B]
        [4] -1  0x000c0000 - 0x000effff (0x30000) MX[B]
        [5] -1  0x00000000 - 0x0009ffff (0xa0000) MX[B]
        [6] -1  0xe1000000 - 0xe10fffff (0x100000) MX[B]E
      [7] -1  0xe1100000 - 0xe11fffff (0x100000) MX[B]E
        [8] -1  0xe0000000 - 0xe0ffffff (0x1000000) MX[B](B)
        [9] 0   0x000a0000 - 0x000affff (0x10000) MS[B](OprD)
        [10] 0  0x000b0000 - 0x000b7fff (0x8000) MS[B](OprD)
        [11] 0  0x000b8000 - 0x000bffff (0x8000) MS[B](OprD)
        [12] 0  0x00006500 - 0x0000650f (0x10) IS[B]
        [13] -1 0x0000ffff - 0x0000ffff (0x1) IX[B]
        [14] -1 0x00000000 - 0x000000ff (0x100) IX[B]
        [15] -1 0x00006600 - 0x000066ff (0x100) IX[B]E
        [16] -1 0x00006400 - 0x000064ff (0x100) IX[B]E
        [17] -1 0x0000f000 - 0x0000f0ff (0x100) IX[B]E
        [18] -1 0x00006500 - 0x0000650f (0x10) IX[B](B)
        [19] 0  0x000003b0 - 0x000003bb (0xc) IS[B](OprD)
        [20] 0  0x000003c0 - 0x000003df (0x20) IS[B](OprD)
(==) APM(0): Backing store disabled
(==) APM(0): Silken mouse enabled
(II) APM(0): Using XFree86 Acceleration Architecture (XAA)
        Screen to screen bit blits
        Solid filled rectangles
        8x8 mono pattern filled rectangles
        Screen to Screen color expansion
        Solid Horizontal and Vertical Lines
        Offscreen Pixmaps
        Driver provided FillImageWriteRects replacement
        Driver provided WriteBitmap replacement
        Driver provided TEGlyphRenderer replacement
        Driver provided WritePixmap replacement
        Setting up tile and stipple cache:
                32 128x128 slots
                10 256x256 slots
(**) Option "dpms"
(**) APM(0): DPMS enabled
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(**) Option "Protocol" "ImPS/2"
(**) Mouse0: Protocol: "ImPS/2"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/input/mice"
(==) Mouse0: Buttons: 3
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(II) Keyboard "Keyboard0" handled by legacy driver
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
GetModeLine - scrn: 0 clock: 65000
GetModeLine - hdsp: 1024 hbeg: 1048 hend: 1184 httl: 1344
              vdsp: 768 vbeg: 771 vend: 777 vttl: 806 flags: 10
(II) APM(0): I2C bus "Alliance bus" removed.
Comment 8 John Eckerdal 2001-06-18 18:40:24 EDT
Tried 640x480 in 16bpp. The result is the same.

If XFree86 3.3.6 is run before the screen is pitch black but the computer is almost allways responsive and can be rebooted (I don't know of any other way of restoring the video-mode).
If cleanly rebooted I get graphics but as soon as I move anything there will be strange graphics
on the screen where movement is occuring (either by not showing the background or by showing
strange graphics).
It does not just occur by the pointer, but also where if I move or resize a window residues are left
here and there.
Comment 9 Joaquim Duran 2001-06-24 15:42:47 EDT
Hello,

My name is Joaquim Duran., I've an Allicance AT3D video card and
using Xfree 4.0.2. I've confiured X server and I've been unable to
start Xfree server. I've added the comment to this bug becouse I also
use the APM driver to my video card.

Using Xconfigurator 4.9.29, the Xserver locks all computer, removing
and without removing DRI module. However, some time ago, I generated
a new file settings witch are able to start Xserver and show the
'grey' screen (shown just before to start the wm) and the server
crached becouse it received the signal number 11.
Comment 10 Mike A. Harris 2001-08-08 09:16:54 EDT
DRI doesn't exist for this card anyway so no use enabling it as you
wont see any hardware 3D accel.

Also, in future please do not cut and paste huge files into the bug
report.  Use file attach feature.  If your browser does not work with
it, then use Mozilla or Netscape please.

For the time being, please use 3.3.6 as it supports the card as you
say.
Comment 11 John Eckerdal 2001-11-04 15:12:42 EST
In the mail "Announcing the availability of Red Hat Linux 7.2 (Enigma)"

Red Hat takes the following position:
  - XFree86 3.3.6 is now deprecated and will be removed from a future
    release of Red Hat Linux.  It is currently included for compatibility.

Does this mean that I no longer will be able to run X on this machine when the next release
comes out? Will this mean that I have to run an alternative Linux distribution?
Because even in version XFree86 4.1.0 (as packaged with Red Hat 7.2)  moving the pointer or resizing windows result in trashed graphics. I have not tested it very much since it is not
useable to have graphics trashed but it seems slightly more stable since Xconfigurator actually managed to detect graphics modes and such.
It still works as it should by using the back compatibility 3.3.6 modules - no trashed graphics no
instability.
Comment 12 Mike A. Harris 2001-11-04 21:01:43 EST
It means just what it says.  That some future release of Red Hat Linux
that is yet to come out, will no longer ship XFree86 3.3.6.  There is
no indication given of when that will occur.  Rather than just shipping
some new release without 3.3.6, it has been mentioned in the release
notes of Red Hat Linux 7.2, that XFree86 3.3.6 is deprecated and will
be removed at some point.  The purpose of mentioning this, is to inform
users that currently use and/or rely on 3.3.6, that support for 3.3.6
will be dropped in the future at some point, rather than it just happening
as a surprise.

When it does happen, users have several options:
- Purchase new video hardware that is supported by XFree86 4.x

- Use XFree86 3.3.6 servers that shipped in a past release and work
  ok for them

Most modern common video hardware now works with 4.x.  For that hardware
that does not work well, or at all with 4.x, either 4.x needs to be
fixed or new support added for the older hardware.  The way things stand
right now, people just use 3.3.6, and so no effort to make the stuff
work in 4.x occurs.  We cant and wont support 3.3.6 indefinitely, as it
is a lot of extra work to do.

It is my hope that people having trouble with 4.x will report their
bugs upstream to XFree86 maintainers, and also to Red Hat, and other
vendors, so that future releases of XFree86 4.x properly support the
widest range of video hardware out there.
Without feedback on 4.x bugs, and time to implement solutions, some
hardware will just fall into the "not supported anymore" category.

I will file the above bug report with the upstream driver maintainer,
since there is little to nothing that I/we can do without having
sample hardware and documentation.
Comment 13 Mike A. Harris 2002-01-23 10:37:47 EST
For troubleshooting purposes only, please try using the following
option(s) in your XF86Config-4 file in the "Device" section:

Option "swcursor"

If that does not work, try using:

Option "noaccel"

Try using both of them as well.  Update the report with your results
from this, and we can try to troubleshoot things further.

Thanks.
Comment 14 John Eckerdal 2002-01-23 19:38:52 EST
If I run X 4.1.0 (XFree86-4.1.0-3 RPM) with noaccel & swcursor no screen 
trashing occur, on the other hand if I only run X with swcursor the screen 
trashing appears again. So it seems like the acceleration function does 
something illegal.

One thing to note: X was not useful with option noaccel. Redrawing a simple
XTerm (moderately sized to 80x40) took between one and two seconds just to
scroll one row.

One other thing to note: If I run XFree with SVGA 3.3.6 compat module first
and then XFree 4.1.0 with real APM module no useful video mode will be set.
The computer is still responsive though and can be CTRL-ALT-DEL resetted
without problems.

I did mail Alliance (the manufacturer of the AT3D chip) but the person did 
not know where to find any specifications. Other developers that do have 
the specifications are reluctant to share them because of signed NDAs.
Since the driver code is virtually uncommented it is very hard to figure 
out exactly what is going on and it is even harder to fix it.
Comment 15 Mike A. Harris 2002-01-29 20:03:36 EST
Ok, we can narrow this problem down now, to minimalize the slowdown, so
it is useable for you, and also find the problem areas, so they can
possibly be debugged and fixed properly.  What I need you to do now,
since I do not have this hardware available to me at all, is I need
you to look at the XF86Config manpage, and search for the various
options that start with "XAANo......".  You'll need to do the following
to pinpoint the problem area:

Enable "swcursor" as you've been doing, but do not use "noaccel".
Instead of "noaccel" use one of the XAANo.... options from the manpage,
then start up X and see if the problem goes away, or gets better at all.
If not, swap the XAANo.. option with the next one in the manpage, and
continue until you've tried all of them.  If you find the exact option
that fixes the problem, please continue to test the other remaining
options also, as more than one may fix the problem, and that info is
useful in finding a solution.

Once you've tried this, please update the bug report with your findings,
and I will have a look into the are of code that seems to be troublesome.
Comment 16 Mike A. Harris 2002-01-29 20:49:24 EST
*** Bug 51259 has been marked as a duplicate of this bug. ***
Comment 17 Mike A. Harris 2002-01-29 20:49:45 EST
*** Bug 58920 has been marked as a duplicate of this bug. ***
Comment 18 Mike A. Harris 2002-01-29 20:53:39 EST
Another note to all experiencing problems with AT3D cards, is that
XFree86 4.2.0 is now available.  I have no idea if it will change things
or not, however it is a good idea to test it out as well.  There
are RPM packages of it available for Red Hat Linux 7.2 at my ftp
space:

ftp://people.redhat.com/mharris/testing/7.2

You'll need the latest XFree86 version-release available there, as
well as the glut packages that are there too.  You will also need
the rawhide kernel when installing, or it will fail with a drm
dependancy.  Since this card isn't supported by DRI anyway, if there
are no other dependancy failures besides the kernel-drm one, you can
safely use --nodeps to install/upgrade.
Comment 19 Mike A. Harris 2002-01-29 20:54:49 EST
Another possibility is to edit XF86Config-4, and change the driver
name to "vesa".  If you do so, please provide updated feedback here
as well.
Comment 20 John Eckerdal 2002-01-30 19:14:01 EST
Some notes:

1. About VESA. The BIOS on the card does only support VESA 1.2 and I assume
   that much like the kernel frame buffers only VESA 2.0 is supported since
   linear framebuffers and some protected mode interfaces were not added
   until version 2.0 if memory serves me correctly.

2. I installed XFree86 4.2.0 from Rawhide RPMS (without Glide or kernel).
   Then I added the following XaaNo...
      Option "XaaNoScreenToScreenCopy"
      Option "XaaNoSolidFillRect"
      Option "XaaNoSolidFillTrap"
      Option "XaaNoSolidTwoPointLine"
      Option "XaaNoSolidBresenhamLine"
      Option "XaaNoSolidHorVertLine"
      Option "XaaNoDashedTwoPointLine"
      Option "XaaNoDashedBresenhamLine"
      Option "XaaNoMono8x8PatternFillRect"
      Option "XaaNoMono8x8PatternFillTrap"
      Option "XaaNoColor8x8PatternFillRect"
      Option "XaaNoColor8x8PatternFillTrap"
      Option "XaaNoCPUToScreenColorExpandFill"
      Option "XaaNoScanlineCPUToScreenColorExpandFill"
      Option "XaaNoScreenToScreenColorExpandFill"
      Option "XaaNoImageWriteRect"
      Option "XaaNoScanlineImageWriteRect"
      Option "XaaNoPixmapCache"
      Option "XaaNoOffscreenPixmaps"
      Option "XaaNoFillImageWriteRects" is not used
      Option "XaaNoTEGlyphRenderer" is not used
      Option "XaaNoWriteBitmap"
      Option "XaaNoWritePixmap"

The four last I same mentioned in the logs that they were provided by the
driver and then used. Not that FillImageWriteRects and TEGlyphRenderer 
options are WW and not used according to the logs so I could not disable 
those.
These were all options I could find.

Removing the noaccel option and just using the XaaNo did however _not_ make 
any difference. The graphics is still corrupted. The corruptions disappears 
when "noaccel" is added.
I also tried combining this with various swcursor options but that did not
help.

I also noted something in the logs that might be of interrest:

Symbol XAAPixmapIndex from module /usr/X11R6/lib/modules/drivers/apm_drv.o 
is unresolved!
Symbol XAAPixmapIndex from module /usr/X11R6/lib/modules/drivers/apm_drv.o 
is unresolved!
Symbol XAAPixmapIndex from module /usr/X11R6/lib/modules/drivers/apm_drv.o 
is unresolved!

Most of the screen redrawing is slow if much text is printed to, for example,
an xterm sometimes it speeds up for a short while. I would not call X very
useful for anythat requires that graphics changes alot on the screen.

By the way: How do I start the compat XF86_SVGA server with the Rawhide 
XFree86 4.2.0 package? Is there any way besides editing startx?
Comment 21 John Eckerdal 2002-01-31 18:04:20 EST
I tried to use VESA. This time the card tried to set some kind of illegal 
graphics mode (or several). X did not even start correctly and when I use 
CTRL-ALT-Backspace to return text mode the monitor took some time to restore 
a nice graphics mode (like the monitor was turned of and then turned on 
again).
This might however be some kind of error on my side since the man page was 
not very helpful about limiting graphics modes.

I also took a screen shot (via gimp since that opens up a few windows).
I also chose to have no solid background since that shows the corruption
more clearly. The screen shot is here:
http://www.df.lth.se/~john_e/corruption.png
This is with all "XaaNo..." options enabled but "noaccel" disabled.

Also tried the new XFree86-4.2.0 4.0 version with the same result.
Comment 22 Joaquim Duran 2002-02-14 18:43:27 EST
Sorry for the delay byt last days I've got many work to do, so I
haven't time to test XFree 4.2.0 before. By now, I've tested the
'vesa' driver with an Alliance AT3D video Card. These are the results:
- XFree 4.2.0 runs slow (well I've a Pentium 133 and XFree 3.3.6 with
apm driver was much faster)
- The screen blinks a little
- There is no graphics corruption in the movement of windows
- Control-Alt+ +,- works are reversed (pressing Crtl+Alt++, windows
are seen bigger, this means lower resolution)
- When maximizing a window, the size of the window outpaces the size
of the display.
- Using the Spanish keyboard, there are problem when typing characters
with key 'Alt Gr' + 3 (#) and similars.
- Sometimes, X server dies due to signal 11.
I'll attach the configuration file and the Xfree 4.0.2 report
Comment 23 Joaquim Duran 2002-02-14 19:00:02 EST
Sorry, in the last line of the previous comment, I've written
'XFree 4.0.2' and it should be 'XFree 4.2.0'.

Sorry for the inconveniences
Comment 24 Joaquim Duran 2002-02-19 19:22:59 EST
This is the report using the "apm" driver in XFree 4.2.0. (in advance, many
thanks to
upodtele$ucsd.edu -- the keyboad has some problems -- for his/her suggestion to
reduce the
number of color/resolution in tests):

I've found that the maximal screen resolution that the 'apm' driver supports is
1024x768 at any color
depth (8, 14 and 24). If larger (bigger?) resolution is used, then XFree locks
the computer or it shows nothing at screen but Xserver can be killed.

If a virtual display is defined (1162x862), it's working fine.

However, there is a problem to update of display where mouse pointer is placed.
That is, I can
move the mouse pointer a long the screen. But if I close a window by pressing to
the close button
'X', then in a small rectangle arround the mouse cursor is still showing the
previous 'X' button. The
window has been closed successfully. Also, when I move a window along the
screen, arround the
mouse pointer apperars many images of the mouse pointer. A similar effect is
shown in a web page
when I scroll the web page using the key cursors and the pointer is on the web
page: many images
of the mouse pointer appears on the web page. (I hope that you have an idea with
these three samples).

Note that the previous results was obtained in the acceleraded configuration.
Also, I am not able to
eliminate the previous problem by activating any of the Xaa... options that 
e96je$efd.eth.se reported
previously. (Please, could somebody tell me which are the opctions related to
SWCursor if there are
any?)

ACTIVATING the options XaaNoPixmapCache or XaaNoScreenToScreenCopy,  I'm able to
reproduce the graphic effects while I'm moving windows along the display in the
same way
that e96je$efd.eth.se shown in a .png image.

Hope this helps.
Comment 25 John Eckerdal 2002-06-09 12:43:17 EDT
An update:

After a bit of testing the very annoying graphics corruption only occurs under the mouse pointer.
Exactly when it occurs is a bit hard to define but it seems to be when the graphics change below 
the pointer. My knowledge of lowlevel X is not great but it seems like  the area where the graphics 
that where behind the mouse-pointer is rather wrong when change below the mouse-pointer 
occurs.

My current install of XFree86 the 4.2.0-50.13-rpm. I also compiled a "magic" version a while ago 
since the master XFree86-cvs tree was updated with new code for the APM driver. This was a 
"drop" and "replace" of the old source code in the APM-driver directory tree. The results were the 
same - still corrupted graphics.

The following errors reported earlier can be avoided by not compiling in support for the Voodoo 
Rush chip (present on my Hercules Stingray 128/3D).
Symbol XAAPixmapIndex from module /usr/X11R6/lib/modules/drivers/apm_drv.o is unresolved!
Symbol XAAPixmapIndex from module /usr/X11R6/lib/modules/drivers/apm_drv.o is unresolved!
Symbol XAAPixmapIndex from module /usr/X11R6/lib/modules/drivers/apm_drv.o is unresolved!

I sort of tracked it down to a declaration of non-existant PixmapIndex declaration somewhere in 
the Rush tree (I think). This should however be unrelated to the problem since the version I did 
compile was without Rush support and it still happened.

A note: Either run with noaccel or with shadowfb both work correctly.

My, somewhat, educated guess is that a something does not notify the APM driver when graphics 
change below the mouse-pointer or the driver is notified but the with something wrong in that call.
This also happens with "swcursor". Since the shadowfb mode works it seems to be related to 
something in the acceleration stuff. I have checked the source-code out a bit (and will continue to 
do so) but I think the coding style very hard to follow so it may take a while.

Final note: If the latest source from the APM driver is not used in the current RPM I suggest that 
it is imported since there are some stuff fixed in there (not that it has bitten me but...).
Comment 26 John Eckerdal 2002-06-14 13:07:30 EDT
I might have a configuration that works now (not entirely sure though see
below for more information). This is XFree86-4.2.0-50.16

First the relevant parts of XF86Config-4

# XFree86 4.2.0 configuration generated by Xconfigurator 4.10.7

Section "Module"
        Load "dbe"              # Double-buffering
        Load "GLcore"           # OpenGL support
        # Load "dri"            # Direct rendering infrastructure
        # Load "glx"            # OpenGL X protocol interface
        # Load "vbe"
        Load "int10"
        Load  "extmod"          # Misc. required extensions
        # Load  "v4l"           # Video4Linux
        # Load  "record"        # X event recorder
        # You only need the following two modules if you do not use xfs.
        # Load  "freetype"       # TrueType font handler
        # Load  "type1"         # Adobe Type 1 font handler
EndSection

Section "Device"
        Identifier "AT3D"
        Driver "apm"
        BoardName "Hercules Stringray 128/3D"
        Option "HWCursor" "yes"
        Option "PciRetry" "no"
        # Option "swcursor" "yes"
        # Option "no_accel"
        # Option "shadowfb"
        # Option "nolinear"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device "AT3D"
        Monitor "SAM1D73"
        DefaultDepth 16
        Subsection "Display"
                Depth 16
                Modes "1024x768" "800x600" "640x480"
        EndSubSection
EndSection


It was adding '' Load "int10" '' (in the modules section) and
'' Option "HWCursor" "yes" '', '' Option "PciRetry" "no" '' in the Device 
section that got it working (no more trashed graphics behind the mouse 
pointer). Only load "int10" does not fix it, and last time I tried the 
Option "HWCursor" "yes" did not do much good.

While this fixes the cursor-trashing an new interresting graphic-bug is now
showing itself. XMMS is visually behaving very strange with the latest Raw 
Hide RPMs (X and XMMS and base-RPMS). The graphics is quite corrupted but 
it is very regular and does not allways show.
I am not sure if this is the APM driver messing things up or XMMS in Raw 
Hide messing things up. My guess is currently XMMS since it fails to load 
one of my skins that have previously worked.

My guess is that it is resolved but since XMMS is not behaving I am not 
100% sure.
Comment 27 Mike A. Harris 2002-06-17 08:37:18 EDT
If xmms was at fault (which I doubt) then that problem would be reported
on a variety of video hardware.  Any display corruption problems are
almost always 2D acceleration and/or hardware mouse cursor problems.

In the case of this bug, after going over it, it seems that the 2D accel
code might be stomping on the memory used to hold the hardware mouse
cursor perhaps.  Just a theory.

Alan, care to comment?  I'm having a look at the XFree86 CVS code right
now to see if there are any fixes that might play a part.
Comment 28 Alan Hourihane 2002-06-17 09:04:58 EDT
There has been a large patch to the apm driver in the current CVS Mike.

It may be worth sucking over the driver source into Rawhide and compiling
there.
Comment 29 Mike A. Harris 2002-06-18 15:24:50 EDT
Thanks Alan, I've updated our driver to the current CVS code as of
a few hours ago checkout.  I went over the code and it looks quite sane,
and should be an improvement hopefully.

I'm going to build a binary module for testing so you guys don't need
to update to rawhide just to test the new driver. If possible, please
test the driver with XFree86 4.2.0 in RHL 7.3.  The driver may or may
not also work with 4.1.0.  It is compiled against an XFree86 4.2.0
source base, so no guarantees.

ftp://people.redhat.com/mharris/test-drivers/apm-4.2.0/apm_drv.o

Comment 30 Mike A. Harris 2002-07-16 04:48:20 EDT
No bugs reported since this change was made.  I'm assuming it works, but
changing it to MODIFIED for confirmation from someone with hardware.

If it does work, it can be closed as RAWHIDE, or as CURRENTRELEASE if
closed after we release our next distro release.
Comment 31 John Eckerdal 2002-07-25 17:12:12 EDT
It does not work, atleast not in XFree86-4.2.0-53 which I believe contain 
the new version. The man-page looks like the man-page for the new version.

Graphics corruption still occur. Not under the mouse though - XMMS exhibits 
some very subtle problems which I did not notice at first. Also GQView and 
GV can both exhibit problems with corruption when (in GV) scrolling a 
Postscriptf file or in GQView while "scrolling" around in an zoom image.
They are not nerely as severe as before and sometimes goes by undetected.
I have not been able to reproduce any corruption by resizing windows at 
all. Also I am using Opera quite extensively and Opera shows no problems.

If one can live with this minor but sometimes annoying corruptions (I have
been using this version for some time now) it "works" but sometimes when
viewing Postscript files it might get annoying.
See: http://www.df.lth.se/~john_e/gvcorruption.png
What I did here was load the file and scroll the contents down and up. The
bottom text is quite unreadable. This document allways display this kind of 
corruption while others are a lot less severe - one of the reasons why it 
took so long time to notice.

Comment 32 Mike McLean 2003-01-02 14:05:38 EST
Changing back to assigned based on reporter's comment
Comment 33 Mike A. Harris 2003-01-26 02:29:58 EST
That would be nice if http://www.df.lth.se/~john_e/gvcorruption.png actually
existed to look at, but it doesn't when i click on it.  One of the
reasons that such things should be attached directly to the bug report
with bugzilla's bug attachment feature.

To be honest, since this hardware is quite ancient, and since I don't have
it or have access to it, there is not anything I can do really to fix the
driver to work properly.  If I did have the hardware, it would still be
a very low priority simply because very few users have this hardware and
are using it in Linux (or it would stand to reason that there would be many
more bug reports), so unfortunately this is a very low priority issue.

About all I can do with this at all, is to have the driver modified to
disable functionality that doesn't work correctly, such as disabling
parts of broken 2D acceleration, etc.

It is possible however that the latest XFree86 code may possibly have
fixed this problem, but hard to be sure without testing by someone who
has the hardware.  If the latest XFree86 fixes the problem, then it is
possible to backport the fixes to older releases perhaps too.

As such, I'm going to close this issue as WONTFIX for now, however, if
anyone who still has this hardware, is willing to install Red Hat Linux
current beta release (phoebe) and test it out, and report wether or not
it works properly for them, and if not, to use various config file
tweaks to disable things that are broken, and then report them back here,
I can change the driver so that it works by default in the future.  In
that case, once someone has tested the beta, please feel free to reopen
this if you're still interested in having it work out of the box.

Note You need to log in before you can comment on or make changes to this bug.