Bug 244777 - Dell 2007WFP 1680x1050 not configured properly
Summary: Dell 2007WFP 1680x1050 not configured properly
Status: CLOSED DUPLICATE of bug 231359
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
(Show other bugs)
Version: 7
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-19 04:41 UTC by Jens Petersen
Modified: 2018-04-11 11:40 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-01 20:21:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (1.13 KB, application/octet-stream)
2007-09-25 12:24 UTC, Jens Petersen
no flags Details
Xorg.0.log (41.88 KB, text/plain)
2007-09-25 12:51 UTC, Jens Petersen
no flags Details
Xorg.0.log (67.52 KB, text/plain)
2007-09-25 22:49 UTC, Jens Petersen
no flags Details
xorg.conf (577 bytes, text/plain)
2007-09-25 23:17 UTC, Jens Petersen
no flags Details
Xorg.0.log (67.52 KB, text/plain)
2007-09-25 23:19 UTC, Jens Petersen
no flags Details
xorg.conf (577 bytes, text/plain)
2007-09-30 01:51 UTC, Jens Petersen
no flags Details
Xorg.0.log (50.21 KB, text/plain)
2007-09-30 01:53 UTC, Jens Petersen
no flags Details

Description Jens Petersen 2007-06-19 04:41:29 UTC
Description of problem:
When I install Fedora 7 on a machine connected to a Dell UltraSharp 2007WFP
it boots by default into 800x600.  Further it is not easy to get it
configured right to work at the native 1680x1050@60Hz resolution.
This is with an ATI Radeon card if it matters, but I noticed the same
problem when I connected the monitor to my laptop with an Intel chipset.

How reproducible:
every time

Steps to Reproduce:
1. install Fedora 7 or boot Live CD
2. try to reconfigure with system-config-display
  
Actual results:
1. comes up in 800x600 iirc
2. configuring to 1680x1050 and trying to restart X puts X into a loop
Expected results:


Additional info:
I can provide the working xorg.conf file if it helps
and the non-working one generated by system-config-display later.

Comment 1 Matěj Cepl 2007-09-06 13:26:24 UTC
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.


Comment 2 Jens Petersen 2007-09-25 12:24:12 UTC
Created attachment 205411 [details]
xorg.conf

here is the working xorg.conf file (which was editted by hand to get X working)

Comment 3 Jens Petersen 2007-09-25 12:30:05 UTC
Reverting this to F7 since currently (pre-test3 livecd) I can't
get X to start on the ATI Radeon Xpress 200 box at all (X starts looping
at 99% cpu - I'll file another bug for that).

Comment 4 Jens Petersen 2007-09-25 12:51:33 UTC
Created attachment 205431 [details]
Xorg.0.log

This is the log with the above working config.

But I guess you want the log when it is not working...

Comment 5 Jens Petersen 2007-09-25 12:56:31 UTC
Ugh, dunno if you want to ignore those - they are actually with fglrx
(with which I still can't get 3d to work but anyway...) - still dunno
if that matters so much for detecting the monitor correctly?

Comment 6 Matěj Cepl 2007-09-25 14:05:14 UTC
Yes, I don't want to ignore this -- could you please reproduce this with open
source drivers? Unless you will be able to do so in a month, I will have to
close this bug as CANTFIX (because we can't).

Comment 7 Jens Petersen 2007-09-25 22:46:22 UTC
Ok, I managed to reproduce this now with following steps:

1. boot Fedora Desktop Live spun from yesterday's rawhide from usb stick
   at runlevel 3
2. # rpm -e xorg-x11-drv-ati
3. # rm -f /etc/X11/xorg.conf
4. $ X


Comment 8 Jens Petersen 2007-09-25 22:49:29 UTC
Created attachment 206201 [details]
Xorg.0.log

Here is the log after those steps.

Is that sufficient information?

Comment 9 Jens Petersen 2007-09-25 23:17:48 UTC
Created attachment 206231 [details]
xorg.conf

Can also reproduce with this system xorg.conf present after the livecd has
booted.

If I s/radeon/vesa/ X starts but again the monitor says it can't display
the mode.

Comment 10 Jens Petersen 2007-09-25 23:19:03 UTC
Created attachment 206241 [details]
Xorg.0.log

log with the above xorg.conf file using vesa to workaround problems
with current ati driver.

Comment 11 Jens Petersen 2007-09-25 23:50:58 UTC
If I use the radeon driver and turn off DRI then everything seems to be ok.

Comment 12 Matěj Cepl 2007-09-26 15:14:02 UTC
Thanks, I will pass this to developers.

Comment 13 Adam Jackson 2007-09-27 14:32:37 UTC
Logs from the vesa driver aren't helpful, since they're not the case we're
trying to fix here.  Do you have a log from trying to start with the radeon driver?

Comment 14 Jens Petersen 2007-09-28 05:58:50 UTC
I think there is no problem here under F8, so let me test again with F7,
in case it is related to the problem with the radeon driver and
my RC410 (Xpress 200).

Comment 15 Jens Petersen 2007-09-30 01:51:10 UTC
Created attachment 211531 [details]
xorg.conf

Here is the config file generated by the F7 Live image.

Comment 16 Jens Petersen 2007-09-30 01:53:29 UTC
Created attachment 211541 [details]
Xorg.0.log

and here is the log file.

Comment 17 Adam Jackson 2007-10-01 20:21:53 UTC
Okay, that looks familiar.

Fixed in F8, will look into a backport to F7 once F8 is out.

*** This bug has been marked as a duplicate of 231359 ***


Note You need to log in before you can comment on or make changes to this bug.