Bug 244790 - Blackberry device not charging
Blackberry device not charging
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
: 247773 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-19 04:10 EDT by Sacha Labourey
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version: kernel 2.6.22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 07:25:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
result of lsusb -v (26.89 KB, text/plain)
2007-06-19 04:10 EDT, Sacha Labourey
no flags Details

  None (edit)
Description Sacha Labourey 2007-06-19 04:10:02 EDT
Description of problem:
As advertised, kernel 2.6.21-1.3228.fc7 is supposed to have a specific feature
to load BB devices. However, this is not working. The device starts charging
during 5 seconds then the charging symbol disappears and the device stops charging.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Plug your BB device on any USB port of your system
2.See it start charging during 5 seconds
3.it then stops charging
  
Actual results:


Expected results:


Additional info:
Comment 1 Sacha Labourey 2007-06-19 04:10:02 EDT
Created attachment 157353 [details]
result of lsusb -v
Comment 2 Chuck Ebbert 2007-06-19 11:37:17 EDT
Is the berry_charge driver loaded?
Comment 3 Sacha Labourey 2007-06-19 11:45:16 EDT
yes:

[slaboure@sacha ~]$ lsmod | grep ber
berry_charge            8005  0 
Comment 4 Chuck Ebbert 2007-06-20 12:43:35 EDT
Kernel is auto suspending the device because it thinks it's not in use.
Upstream developers think this should be solved by udev:
  http://thread.gmane.org/gmane.linux.usb.devel/55192/focus=55199

Some workarounds:

 - boot with kernel parameter: usbcore.autosuspend=0
 - echo "on" >/sys/bus/usb/.../device/power/level
   (but finding exactly what "..." should be is rather
   involved, see below)

If you look in /sys/class/usb_device you'll
find a bunch of subdirectories with names like "usbdev1.2".  Here the
first number is the bus number and the second is the usbfs device
number, so you can go directly to the one you want.  In that directory
is a symbolic link named "device" which points to the actual sysfs
device directory.  As a complete example, the usbfs path
/proc/bus/usb/002/003 corresponds to the sysfs path
/sys/class/usb_device/usbdev2.3/device.
Comment 5 Sacha Labourey 2007-06-21 05:16:30 EDT
Thanks. However, it seems that the structure I am getting in /sys and /proc is
not exactly the same as yours. It also means that I cannot set the power level.
Output below:

[root@sacha slaboure]# cat /sys/bus/usb/devices/1-1/manufacturer 
Research In Motion
[root@sacha slaboure]# echo "on" > /sys/bus/usb/devices/1-1/power/level
bash: /sys/bus/usb/devices/1-1/power/level: Permission denied
[root@sacha slaboure]# ls -l /sys/bus/usb/devices/1-1/power
total 0
-rw-r--r-- 1 root root 4096 2007-06-21 11:11 autosuspend
-rw-r--r-- 1 root root 4096 2007-06-21 11:11 wakeup
[root@sacha slaboure]# ls -l /sys/bus/usb/devices/1-1/
total 0
drwxr-xr-x 3 root root    0 2007-06-21 11:10 1-1:1.0
-r--r--r-- 1 root root 4096 2007-06-21 11:10 bcdDevice
-rw-r--r-- 1 root root 4096 2007-06-21 11:10 bConfigurationValue
-r--r--r-- 1 root root 4096 2007-06-21 11:10 bDeviceClass
-r--r--r-- 1 root root 4096 2007-06-21 11:10 bDeviceProtocol
-r--r--r-- 1 root root 4096 2007-06-21 11:10 bDeviceSubClass
-r--r--r-- 1 root root 4096 2007-06-21 11:10 bmAttributes
-r--r--r-- 1 root root 4096 2007-06-21 11:11 bMaxPacketSize0
-r--r--r-- 1 root root 4096 2007-06-21 11:10 bMaxPower
-r--r--r-- 1 root root 4096 2007-06-21 11:10 bNumConfigurations
-r--r--r-- 1 root root 4096 2007-06-21 11:10 bNumInterfaces
lrwxrwxrwx 1 root root    0 2007-06-21 11:10 bus -> ../../../../../bus/usb
-r--r--r-- 1 root root 4096 2007-06-21 11:10 configuration
-r--r--r-- 1 root root 4096 2007-06-21 11:10 devnum
lrwxrwxrwx 1 root root    0 2007-06-21 11:10 driver ->
../../../../../bus/usb/drivers/usb
lrwxrwxrwx 1 root root    0 2007-06-21 11:11 ep_00 ->
../../../../../class/usb_endpoint/usbdev1.15_ep00
-r--r--r-- 1 root root 4096 2007-06-21 11:10 idProduct
-r--r--r-- 1 root root 4096 2007-06-21 11:10 idVendor
-r--r--r-- 1 root root    0 2007-06-21 11:10 manufacturer
-r--r--r-- 1 root root 4096 2007-06-21 11:10 maxchild
drwxr-xr-x 2 root root    0 2007-06-21 11:11 power
-r--r--r-- 1 root root 4096 2007-06-21 11:11 product
-r--r--r-- 1 root root 4096 2007-06-21 11:11 quirks
-r--r--r-- 1 root root 4096 2007-06-21 11:10 speed
lrwxrwxrwx 1 root root    0 2007-06-21 11:10 subsystem -> ../../../../../bus/usb
--w------- 1 root root 4096 2007-06-21 11:11 uevent
lrwxrwxrwx 1 root root    0 2007-06-21 11:11 usb_device:usbdev1.15 ->
../../../../../class/usb_device/usbdev1.15
lrwxrwxrwx 1 root root    0 2007-06-21 11:11 usb_endpoint:usbdev1.15_ep00 ->
../../../../../class/usb_endpoint/usbdev1.15_ep00
-r--r--r-- 1 root root 4096 2007-06-21 11:10 version


Are we working on the same kernel/system/environment?
Comment 6 Dave Jones 2007-08-29 14:37:32 EDT
This should be working in the latest 2.6.22 update, can you confirm ?
Comment 7 Christopher Brown 2007-09-17 07:25:00 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

There hasn't been much activity on this bug for a while and Dave has indicated
this should be resolved in 2.6.22 so I am closing. If I have erred, please
accept my profuse apologies and re-open and I will attempt to assist in its
resolution.

Cheers
Chris
Comment 8 Christopher Brown 2007-09-18 10:45:12 EDT
*** Bug 247773 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.