Bug 244924 - Use wiki forward instead of tinyurl
Use wiki forward instead of tinyurl
Status: CLOSED CANTFIX
Product: Fedora Documentation
Classification: Fedora
Component: release-notes (Show other bugs)
devel
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Release Notes Tracker
Karsten Wade
:
Depends On:
Blocks: fc-relnotes-traqr
  Show dependency treegraph
 
Reported: 2007-06-19 17:15 EDT by Till Maas
Modified: 2008-10-08 11:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-08 11:48:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Till Maas 2007-06-19 17:15:11 EDT
I noticed that in the release notes a URL to a bugzilla page is obfuscated with
tinyurl. Imho it would be better to use a page on the wiki, that redirects users
to the bugzilla page. I created an example page at
http://fedoraproject.org/wiki/TillMaas/ForwardTest

You can see the used code, here:
http://fedoraproject.org/wiki/TillMaas/ForwardTest?action=edit&editor=text

So if you like this idea, you only need to use above code on a well selected
page in the wiki, e.g.

http://fedoraproject.org/wiki/Docs/BugillaFeedbackForm
Comment 1 Karsten Wade 2007-06-20 19:35:22 EDT
Thanks for the idea; we just began exploring the #REFRESH directive, which does
an  actual <meta http-equiv="refresh"...>.

I definitely see advantages in this approach:

* Don't have to modify the URL each release (as we do in getting a new tinyurl)
* Memorable URL
* Relies upon tool that aren't likely to break or change in behavior

However, I'm curious what made you think about this in the first place?  That
is, you refer to obfuscation, which has a negative connotation -- as if we are
intentionally trying to hide something.  Or is it just that tinyurl.com links
are risky because you don't know where they go, even if you trust the source
that wrote them?

Comment 2 Till Maas 2007-06-24 08:20:10 EDT
(In reply to comment #1)

> However, I'm curious what made you think about this in the first place?  That
> is, you refer to obfuscation, which has a negative connotation -- as if we are
> intentionally trying to hide something.  Or is it just that tinyurl.com links
> are risky because you don't know where they go, even if you trust the source
> that wrote them?

I used obfuscation because one cannot see what is behind the tinurl link or
whether or not one already knows this. E.g. when there would be instead a link
to bugzilla I would know, what I can expect from the link and do not need to
follow it. Also I get this information, when I am offline while reading the
release notes. Additionally I saw the advantages of using the wiki or some other
 method and imho using tinyurl in a the release notes looks not very professional.
Comment 3 Till Maas 2008-10-08 11:48:00 EDT
Mediawiki does not support this, therefore it needs to be solved some other way or kept as it is.

Note You need to log in before you can comment on or make changes to this bug.