Bug 245122 - PS3 does not shutdown/reboot
PS3 does not shutdown/reboot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
powerpc Linux
low Severity high
: ---
: ---
Assigned To: Dave Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 05:35 EDT by Piergiorgio Sartor
Modified: 2015-01-04 17:29 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.23.12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-17 23:21:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from /var/log/messages (2.84 MB, text/plain)
2007-09-22 18:33 EDT, Jason
no flags Details

  None (edit)
Description Piergiorgio Sartor 2007-06-21 05:35:12 EDT
Description of problem:
When trying to poweroff or reboot F7 on a Playstation 3, the system performs the
usual steps (shutting down services, syncing the disk, ...) up to the real HW
shutdown. At this point everything just stays locked, until the power switch is
used.
The old 2.6.16 for PS3 was working fine, i.e. reboot was rebooting and poweroff
was powering off.

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3228.fc7.ppc64.rpm   

How reproducible:
Always

Steps to Reproduce:
1.
Install, if you can, F7 on a PS3
2.
From console, as root, type reboot or poweroff
  
Actual results:
The system goes into shutdown, but is actually hangs at the end.

Expected results:
The system should reboot or switch off.

Additional info:
As mentioned above, the 2.6.16 for PS3 was working.
As an other hint, the last messages are something related to the ps3fb,
something like:

ps3fb_remove -> 1144
ps3fb_??? -> 1130
Comment 1 Jason 2007-07-23 22:14:40 EDT
TThis is happening to me as well. Exactly as described.
Comment 2 Christopher Brown 2007-09-17 07:43:01 EDT
Hello folks,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 3 Jason 2007-09-19 12:17:10 EDT
The most recent F7 kernel still does not shutdown/reboot correctly. Updated and 
tried last night, with the same result as in the passed (2007 09 18)
Comment 4 Christopher Brown 2007-09-20 04:33:27 EDT
Thanks for the update Jason. Could you try running the following command as root:

# shutdown -r now

and see if this performs the reboot correctly for you? If not, if you have the
chance to test the latest kernel from rawhide I believe there are a number of
updates for ppc64 that should resolve this.

Cheers
Chris
Comment 5 Jason 2007-09-20 22:54:17 EDT
I tried this with the most recent F7 kernel 2.6.22.5-76.fc7 and it did not 
work. I went ahead and installed the current rawhide kernel 
2.6.23-0.189.rc6.git8.fc8 and it did not work any better.
Comment 6 Christopher Brown 2007-09-21 04:32:56 EDT
Okay, thanks for testing Jason. You could attach the output from
/var/log/messages as this may well give more clues to what is causing the hang.

Cheers
Chris
Comment 7 Jason 2007-09-22 18:33:57 EDT
Created attachment 203271 [details]
Output from /var/log/messages

The attachment is the output from /var/log/messages you requested.
Comment 8 Christopher Brown 2007-09-23 13:54:32 EDT
The following may be of some interest:

https://bugzilla.redhat.com/show_bug.cgi?id=249217
http://forums.fedoraforum.org/showthread.php?t=161805

It looks like rebooting on the PS3 is an ongoing issue. Please can you test as
suggested in the above posts and post back the results.
Comment 9 Jason 2007-09-23 21:27:04 EDT
using 'shutdown -rn now' reboot the PS3, however this does nothing to fix 
actually shutting own the PS3. Also, if you change the boot flag prior to 
rebooting, using this method to reboot causes you to reboot into linux again, 
rather than reboot into the game os. I would expect, if I change the boot flag, 
nd then reboot, to boot into the game os. Whether this is possible or not I 
don't know, but that's what I would have expected...
Comment 10 Christopher Brown 2007-09-24 07:14:17 EDT
Well if 'shutdown -rn now' works for rebooting then 'shutdown -n now' should
work for shutting down. Not sure if that is what you were getting at. I have no
knowledge of PS3 with linux however one fix mentioned on the above link was:

/sbin/other-os-flash-util -b /dev/ps3flash

which seems to fixe booting into the game OS. Were you able to try this?
Comment 11 Bill Blake 2007-10-11 18:29:11 EDT
(In reply to comment #10)
> /sbin/other-os-flash-util -b /dev/ps3flash
> 
> which seems to fixe booting into the game OS. Were you able to try this?

Yes, that fixes booting into the game OS, but we still need a way to get the PS3
to shutdown and reboot into game OS without having to power off / on.

As mentioned, the "shutdown -rn now" method causes it to shutdown and restart
into Linux even if the boot flag has been changed.  Also when using this method
your most recent shell commands don't appear to be saved.

All versions of YDL 5.0.x shut down properly and reboot into game OS, but I
don't know enough about it to see what is different there.

billb - Fedora Forums
Comment 12 Dave Horton 2007-11-10 09:45:08 EST
The latest kernel does allow the ps3 to shutdown and reboot. Unfortunately, it
doesn't boot into the game-os correctly.

Running the command '/sbin/other-os-flash-util -b /dev/ps3flash' changes the
boot flag, but the boot flag doesn't get read on reboot. If you shut down the
ps3 completely (with 'shutdown -h now bye'), it reads the boot flag, and boots
into the correct os. All of the reboot commands I've tried reboot back into
linux even when the boot flag has been changed to game-os.
Comment 13 Bill Blake 2007-11-10 15:38:47 EST
Reboot to Game OS is now working properly for me with 2.6.23.1-21.fc7

This is my boot-game-os script:
 
#!/bin/sh

/sbin/other-os-flash-util -b /dev/ps3flash ||
{
        echo "ERROR: can't change boot flag" 2>&1;
        exit 1;
}

reboot
Comment 14 Dave Horton 2007-11-11 19:52:55 EST
My boot-game-os script is the same as the one posted above, but my ps3 will not
boot into the game-os. When I run the boot-game-os script, it says "boot flag
changed", but it still boots back into linux.
Comment 15 Christopher Brown 2008-01-09 10:06:47 EST
Dave,

Is this still an issue for you? What happens when running the boot-game-os
script as a regular user opposed to root? Difference?
Comment 16 Dave Horton 2008-01-17 18:25:41 EST
This is not an issue for me anymore. It now works as expected.
Comment 17 Christopher Brown 2008-01-17 23:21:19 EST
Okay, as both you and Dave seem happy I'm closing as CURRENTRELEASE. Thanks for
adding yourself to the bug and making your comments.
Comment 18 Jason 2008-01-18 12:21:27 EST
Working for me as well.

Note You need to log in before you can comment on or make changes to this bug.