Bug 245176 - i386 cyrus-sasl-* plugin libraries not available for x86_64
i386 cyrus-sasl-* plugin libraries not available for x86_64
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mash (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-21 10:15 EDT by John Haxby
Modified: 2014-03-16 23:07 EDT (History)
4 users (show)

See Also:
Fixed In Version: 0.1.18-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 15:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Haxby 2007-06-21 10:15:00 EDT
Description of problem:


Version-Release number of selected component (if applicable): 2.1.22-6

How reproducible:  Every time.


Steps to Reproduce:
1. Take some i386 program that uses cyrus-sasl for SASL authentication, install.
2. Attempt to install corresponding cyrus-sasl-{plain,md5,gssapi,ntlm,...} plugins.
  
Actual results:

Can't authenticate using any of the plug-in methods for the i386 application
even though the i386 cyrus-sasl-lib.i386 is installed.

Expected results:

Should be able to do "yum install cyrus-sasl-md5.i386", for example.

Additional info:

This looks like exactly the same problem that we had in FC6 in bug 216432 and it
looks as though the fix for that didn't get carried forward to F7.

Please can I have the i386 cyrus-sasl-* plugins back?
Comment 1 Jesse Keating 2007-06-21 11:20:43 EDT
Hrm, I would have thought these plugins would have been caught by one of the
filters in mash.  Looking closer.
Comment 2 Bill Nottingham 2007-06-21 13:30:52 EDT
Fixed in 0.1.18.
Comment 3 Fedora Update System 2007-06-21 16:02:35 EDT
mash-0.1.18-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2007-07-03 12:25:37 EDT
mash-0.1.18-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Nalin Dahyabhai 2007-07-10 09:11:55 EDT
I don't see the i386 plugins in the x86_64 releases, updates, or updates-testing
repositories.  Was there an additional step to solving the problem that was
missed?  Do I need to push the released packages as updates?
Comment 6 John Haxby 2007-08-02 07:03:56 EDT
It's been a while now and I still haven't seen the i386 plugins in the x86_64
releases either.
Comment 7 Bill Nottingham 2007-08-02 10:42:40 EDT
Yes, to get this fixed for F7, it would require releasing the packages as updates.
Comment 8 Nalin Dahyabhai 2007-08-02 11:03:34 EDT
Okay, I've added the dist-fc7-updates-candidate tag to the cyrus-sasl-2.1.22-6
build we included in F7 and submitted it to be pushed as a stable update.
Comment 9 Bill Nottingham 2007-09-20 15:34:45 EDT
Should be fixed by now.

Note You need to log in before you can comment on or make changes to this bug.