Bug 245286 - F7 CD/DVD hangs with message "Ready" even when SATA drive is disconnected and onboard SATA controller is disabled
F7 CD/DVD hangs with message "Ready" even when SATA drive is disconnected and...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 01:42 EDT by Brent Goodrick
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-17 08:23:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 239585 None None None Never

  None (edit)
Description Brent Goodrick 2007-06-22 01:42:16 EDT
Description of problem:
FC7 test4 CD/DVD hangs with message "Ready" after loading the kernel. In
contrast to bug #239585, even without the SATA drive, the kernel hangs at READY.
That bug implied unplugging the drive cables, but I will not try unplugging any
drive cable while the machine is running, which is dangerous in my opinion.  See
http://forums.fedoraforum.org/forum/showthread.php?t=158365 for my post that
goes into great detail for the things I have tried.  Notably, even when I
disconnect the one SATA cable from the motherboard, and disable the on-board
SATA controller, the F7 DVD boot sequence still hangs at "READY". I'm marking
this as a kernel issue because it seems more related to kernel initialization
than an anaconda issue.

Note that I have also tried installing the FC6 DVD (x86, not x86_64) and its DVD
installed onto the first SATA drive just fine, but upon first boot into the SATA
drive after installation, the screen shows:

GRUB Loading stage2...
<blink>

where <blink> is the cursor sitting there and nothing happening. The theory is
that the kernel is failing to initialize properly here since at least GRUB
managed to get to stage2.

Version-Release number of selected component (if applicable):
This is using FC7 rescue cd media

This was on the second Abit KN9 SLI motherboard using BIOS ID 20.

How reproducible:


Steps to Reproduce:
1. Use any F7 boot media
2. Boot
3. System hangs with message: "Ready"
  
Actual results:
Hangs at "Ready".

Expected results:
Media should boot normally.

Additional info:

Ubuntu 7.04 64bit Desktop edition Alternate CD also hangs.  But, I heard that it
is still considered to be in beta.

I have tried all kernel options that have been documented to no affect. I've
tried changing the video card from a PCI-Express Nvidia card to a PCI card, with
no affect.

Hardware specifics:

    * Motherboard: Abit KN9 SLI (NVidia NForce 570 SLI) (v1.00 on sticky, BIOS
version 20)
    * RAM: Corsair Twin 2x2048-6400 (DDR2-800) (4GB total)
    * Video Card: XFX PVT71JUHE4 GeForce 7950GT 570M 256MB DDR3 HDCP DUAL DVI
    * CPU: AMD Athlon 64 X2 4600+ 65W AM2 2.4Ghz Dual-Core (OPN: AD04600CUBOX)
    * Power supply: Seasonic S12 430W
    * DVDRW: Plextor PX-740A (on master IDE connector, pinned as Master)
    * Floppy drives: Combo 3.5" and 5.25" on the one floppy connector
    * HD: Seagate 320G ST 7K 16M SATA2 ST3320620NS on first SATA connector
Comment 1 Brent Goodrick 2007-06-24 03:41:17 EDT
I gave up and went with a different motherboard, a Abit Fatal1ty AN9 32X, as
I've exhausted all options on the KN9 SLI. There is some chance that the Abit
KN9 SLI is a badly designed board, and that nothing can be done about it in the
Linux kernel.  I'll leave this bug open in case I'm wrong, and someone with more
knowledge than I wants to investigate it further.  

See http://forums.fedoraforum.org/forum/showthread.php?t=158365&page=2&pp=15 for
more details as to what I (bgoodr) tried there.  See post 36
(http://forums.fedoraforum.org/forum/showpost.php?p=816758&postcount=36) on that
thread for where I gave up on the KN9 SLI.

bgoodr
Comment 2 Tim Waugh 2007-06-25 11:19:00 EDT
Fixing component and reassigning.
Comment 3 Brent Goodrick 2007-06-26 00:59:07 EDT
An Update: note that I changed out the motherboard from a Abit KN9 SLI to a
Fatal1ty AN9 32X but kept everything else the same.  With that new setup, I
succeeded in installing the FC7 x86_32 DVD.  See the current Smolt profile with
that new motherboard at
http://smolt.fedoraproject.org/show?UUID=d5c71955-b2b6-4f61-823d-b9919a31c45f

Reference my HCL report at:
http://www.linuxquestions.org/hcl/showproduct.php?product=3881#review1

(pardon the malformed HTML in that post ... that forum has a bug in its enhanced
WYSIWYG).

bgoodr
Comment 4 Christopher Brown 2007-09-17 08:23:03 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug. As you are now using alternate hardware it might
be difficult to troubleshoot further therefore I am considering closing this bug
as CANTFIX. If you are still able to test please could you try the latest
version of Fedora 8, available from:

http://fedoraproject.org/wiki/Distribution/Download

as this would be a help in trying to fix this in time for the next release.

Cheers
Chris
Comment 5 Brent Goodrick 2007-09-17 23:55:48 EDT
Hi Chris,

I would be happy to do that, but unfortunately I do not have access to that
motherboard anymore.  I suspect that motherboard's design or BIOS to be broken.
I suspect your project is not funded enough to purchase that specific brand of
motherboard to retest. If that is the case, you have really no choice but to
close this ticket.  Hopefully it will show up in web searches to ward people
away from it.

bgoodr
Comment 6 Christopher Brown 2007-09-18 04:57:24 EDT
Hi Brent,

You're right about the funding. I'm sorry it took a while to getting around to
this. I will close as CANTFIX then but thanks for lodging the bug anyway - good
move on adding the HCL entry, I will note this for future reference.

The bug you mentioned at:

https://bugzilla.redhat.com/show_bug.cgi?id=239585

might even be the resolution you were looking for...

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.