Bug 245306 - Democracy fails to start
Democracy fails to start
Status: CLOSED DUPLICATE of bug 244889
Product: Fedora
Classification: Fedora
Component: Democracy (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Thorsten Scherf
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 06:33 EDT by Jonathan Underwood
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-22 07:39:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Underwood 2007-06-22 06:33:33 EDT
Description of problem:
On a freshly installed F7 system, Democracy fails to start

Version-Release number of selected component (if applicable):
Democracy-0.9.5.1-10.fc7

How reproducible:
Everytime

Steps to Reproduce:
1.yum install Democracy
2.democracyplayer
3.
  
Actual results:
$ democracyplayer 
/usr/lib/python2.5/site-packages/dbus_bindings.py:1: DeprecationWarning: The
dbus_bindings module is not public API and will go away soon.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  from dbus.dbus_bindings import *
Traceback (most recent call last):
  File "/usr/bin/democracyplayer", line 89, in <module>
    onetime.OneTime()
  File "/usr/lib64/python2.5/site-packages/democracy/onetime.py", line 112, in
__init__
    dbus.service.Object.__init__(self, bus_name,
'/org/participatoryculture/dtv/OneTime')
  File "/usr/lib/python2.5/site-packages/dbus/service.py", line 424, in __init__
    self._connection._register_object_path(object_path, self._message_cb,
self._unregister_cb)
AttributeError: 'BusNameFlags' object has no attribute '_register_object_path'
Exception exceptions.NameError: "global name 'dbus_bindings' is not defined" in
<bound method BusNameFlags.__del__ of <dbus.service.BusName
org.participatoryculture.dtv.onetime on <dbus.Bus on SESSION at 0x2aaaae9c47d0>
at 0x80e590>> ignored


Expected results:
Expect democracy player to start :)
Comment 1 Gianluca Varisco 2007-06-22 07:39:44 EDT

*** This bug has been marked as a duplicate of 244889 ***

Note You need to log in before you can comment on or make changes to this bug.