Bug 244889 - Democracy player crashes on startup with exception "global name 'dbus_bindings' is not defined"
Democracy player crashes on startup with exception "global name 'dbus_binding...
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: Democracy (Show other bugs)
7
All Linux
low Severity urgent
: ---
: ---
Assigned To: Thorsten Scherf
Fedora Extras Quality Assurance
:
: 245306 246335 (view as bug list)
Depends On:
Blocks: 245305
  Show dependency treegraph
 
Reported: 2007-06-19 14:09 EDT by Allan Engelhardt
Modified: 2007-11-30 17:12 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 09:51:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allan Engelhardt 2007-06-19 14:09:30 EDT
Description of problem:

Democracy player crashes on startup with exception "global name 'dbus_bindings'
is not defined".  The application is not usable.


Version-Release number of selected component (if applicable):
Democracy-0.9.5.1-10.fc7


How reproducible: Every time.


Steps to Reproduce:

$ /usr/bin/democracyplayer
/usr/lib/python2.5/site-packages/dbus_bindings.py:1: DeprecationWarning: The
dbus_bindings module is not public API and will go away soon.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  from dbus.dbus_bindings import *
Traceback (most recent call last):
  File "/usr/bin/democracyplayer", line 89, in <module>
    onetime.OneTime()
  File "/usr/lib64/python2.5/site-packages/democracy/onetime.py", line 112, in
__init__
    dbus.service.Object.__init__(self, bus_name,
'/org/participatoryculture/dtv/OneTime')
  File "/usr/lib/python2.5/site-packages/dbus/service.py", line 424, in __init__
    self._connection._register_object_path(object_path, self._message_cb,
self._unregister_cb)
AttributeError: 'BusNameFlags' object has no attribute '_register_object_path'
Exception exceptions.NameError: "global name 'dbus_bindings' is not defined" in
<bound method BusNameFlags.__del__ of <dbus.service.BusName
org.participatoryculture.dtv.onetime on <dbus.Bus on SESSION at 0x2aaaae9c57d0>
at 0x94f650>> ignored


  
Actual results: Program crashes.


Expected results: Program runs.


Additional info: Only tested on x86_64
Comment 1 Pavel Rosenboim 2007-06-19 16:54:53 EDT
I have same problem on i686.
Comment 2 Allan Engelhardt 2007-06-19 17:02:31 EDT
Setting hardware to 'All' based on Comment 1 .
Comment 3 Allan Engelhardt 2007-06-19 17:15:14 EDT
See also upstream ticket
https://develop.participatoryculture.org/trac/democracy/ticket/7270 .
Comment 4 Thorsten Scherf 2007-06-21 05:08:20 EDT
looks like this happened after the latest dbus-python update on f7.
dbus-python-0.80.2-3.fc7 doesn't have this problem. use this as a workaround
until I have a "real" fix for the problem. 
Comment 5 Thorsten Scherf 2007-06-21 05:46:27 EDT
upstream ticket: #7748
Comment 6 Gianluca Varisco 2007-06-22 07:39:46 EDT
*** Bug 245306 has been marked as a duplicate of this bug. ***
Comment 7 Thorsten Scherf 2007-07-02 02:08:24 EDT
*** Bug 246335 has been marked as a duplicate of this bug. ***
Comment 8 Martin 2007-07-18 16:22:12 EDT
change the line 128 in "Miro-0.9.8/platform/gtk-x11/onetime.py"
        dbus.service.Object.__init__(self, bus_name,
'/org/participatoryculture/dtv/OneTime')

to
        dbus.service.Object.__init__(self, bus_name=bus_name,
object_path='/org/participatoryculture/dtv/OneTime')

and rebuild the sources, that should solve your problem.
Comment 9 Jason Farrell 2007-07-18 21:09:25 EDT
had to up the mozversion from 2.0.0.3 to 2.0.0.4 as well, but Miro 0.9.8 is
working just great here.
Comment 10 Thorsten Scherf 2007-07-21 03:09:47 EDT
will try with Miro later this weekend. looks like dbus bindings are fixed there.
Comment 11 Andre Robatino 2007-07-21 03:15:19 EDT
  Still broken for me with Democracy-0.9.5.1-11.fc7 and all other updates applied.
Comment 12 Valent Turkovic 2007-07-21 05:37:34 EDT
Yup, I installed new updates and that included:
Democracy 0.9.5.1-11.fc7
firefox 2.0.0.5-1.fc7

and I still get democracyplayer to spit out this:

$ democracyplayer 
/usr/lib/python2.5/site-packages/dbus_bindings.py:1: DeprecationWarning: The
dbus_bindings module is not public API and will go away soon.

Most uses of dbus_bindings are applications catching the exception
dbus.dbus_bindings.DBusException. You should use dbus.DBusException
instead (this is compatible with all dbus-python versions since 0.40.2).

If you need additional public API, please contact the maintainers via
<dbus@lists.freedesktop.org>.

  from dbus.dbus_bindings import *
Traceback (most recent call last):
  File "/usr/bin/democracyplayer", line 89, in <module>
    onetime.OneTime()
  File "/usr/lib/python2.5/site-packages/democracy/onetime.py", line 112, in
__init__
    dbus.service.Object.__init__(self, bus_name,
'/org/participatoryculture/dtv/OneTime')
  File "/usr/lib/python2.5/site-packages/dbus/service.py", line 424, in __init__
    self._connection._register_object_path(object_path, self._message_cb,
self._unregister_cb)
AttributeError: 'BusNameFlags' object has no attribute '_register_object_path'
Exception exceptions.NameError: "global name 'dbus_bindings' is not defined" in
<bound method BusNameFlags.__del__ of <dbus.service.BusName
org.participatoryculture.dtv.onetime on <dbus.Bus on SESSION at 0xb7b6b29c> at
0xb7b709ec>> ignored
Comment 13 Martin 2007-07-22 05:32:10 EDT
take this workaround:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=244889#c8
Comment 14 Jack Deslippe 2007-08-10 02:53:54 EDT
Is the new miro player coming to fedora?
Comment 15 Thorsten Scherf 2007-08-14 19:12:04 EDT
created a new package for miro, should be in testing repo tomorrow. 

or download it from:
http://koji.fedoraproject.org/koji/buildinfo?buildID=13761

could you guys please provide some feedback for the new package. the old dbus
problem should be fixed in this release.
Comment 16 Jonathan Steffan 2007-08-14 19:35:57 EDT
Miro is working for me.
Comment 17 Jonathan Steffan 2007-08-14 20:21:35 EDT
The package needs to have Obsoletes: Democracy ?
Comment 18 Jack Deslippe 2007-08-14 22:38:21 EDT
Hmm, so I downloaded your package and installed it and I have the same problem I
had with the miro rpms built in fedoraforum.org:

When I create a new user and run miro, it works fine for the first run. Then,
everytime afterwards I get the following error "An unknown error has occurred
while finishing starting up." and miro loads up as just a grey screen which I
have to kill from the command line. I should mention that I have another Fedora
7 machine where the same miro package seems to work just fine however... (so far
at least).

Here is the crash report from the command line:

INFO ----- CRASH REPORT (DANGER CAN HAPPEN) -----
INFO App: Miro
Publisher: Participatory Culture Foundation
Platform: gtk-x11
Python: 2.5 (r25:51908, Apr 10 2007, 10:29:13)
[GCC 4.1.2 20070403 (Red Hat 4.1.2-8)]
Py Path: ['/usr/lib/python2.5/site-packages/miro', '/usr/bin',
'/usr/lib/python25.zip', '/usr/lib/python2.5', '/usr/lib/python2.5/plat-linux2',
'/usr/lib/python2.5/lib-tk', '/usr/lib/python2.5/lib-dynload',
'/usr/lib/python2.5/site-packages', '/usr/lib/python2.5/site-packages/Numeric',
'/usr/lib/python2.5/site-packages/PIL',
'/usr/lib/python2.5/site-packages/gst-0.10',
'/usr/lib/python2.5/site-packages/gtk-2.0']
Version: 0.9.8
Serial: 20070717000
Revision: unknown
Time: Mon Aug 13 15:34:21 2007
When: while finishing starting up

Exception
---------
Traceback (most recent call last):
File "/usr/lib/python2.5/site-packages/miro/app.py", line 713, in _finishStartup
self.videoDisplay.setVolume(config.get(prefs.VOLUME_LEVEL))
File
"/usr/lib/python2.5/site-packages/miro/frontend_implementation/VideoDisplay.py",
line 147, in setVolume
volumeScale = app.controller.frame.widgetTree['volume-scale']
AttributeError: MainFrame instance has no attribute 'widgetTree'

Call stack
----------
File "/usr/lib/python2.5/threading.py", line 460, in __bootstrap
self.run()
File "/usr/lib/python2.5/threading.py", line 440, in run
self.__target(*self.__args, **self.__kwargs)
File "/usr/lib/python2.5/site-packages/miro/eventloop.py", line 260, in loop
event()
File "/usr/lib/python2.5/site-packages/miro/eventloop.py", line 117, in
processNextIdle
dc.dispatch()
File "/usr/lib/python2.5/site-packages/miro/eventloop.py", line 49, in dispatch
util.trapCall(when, self.function, *self.args, **self.kwargs)
File "/usr/lib/python2.5/site-packages/miro/app.py", line 625, in <lambda>
eventloop.addIdle(lambda :self._finishStartup(gatheredVideos), "Finishing startup")
File "/usr/lib/python2.5/site-packages/miro/app.py", line 786, in _finishStartup
util.failedExn("while finishing starting up")
File "/usr/lib/python2.5/site-packages/miro/util.py", line 132, in failedExn
failed(when, withExn = True, **kwargs)

Threads
-------
Current: Event Loop
Active:
- MainThread
- Event Loop
- ThreadPool - 2 [Daemon]
- ThreadPool - 0 [Daemon]
- ThreadPool - 1 [Daemon]

INFO ----- END OF CRASH REPORT -----
Comment 19 Andre Robatino 2007-08-15 18:56:51 EDT
  Today's Democracy-0.9.6-2.fc7 update still has this bug.
Comment 20 Allan Engelhardt 2007-08-16 02:41:08 EDT
Confirming Comment #19 that I am still seeing the original problem on Fedora 7
x86_64 with Democracy-0.9.6-2.fc7 and

dbus-1.0.2-6.fc7
dbus-glib-0.73-2.fc7
dbus-python-0.82.0-2.fc7
dbus-sharp-0.63-6.fc6
dbus-x11-1.0.2-6.fc7

Also confirming that Miro-0.9.8.1-1.fc7 from updates-testing Works For Me.
Comment 21 Thorsten Scherf 2007-08-16 03:28:56 EDT
patch for Democracy still has to be included. but anyway, users should update to
Miro. The new Miro package which will be pushed to updates repo today makes
Democracy obsolete.
Comment 22 Jack Deslippe 2007-08-16 03:37:11 EDT
Hmm, should I open a new bug report for my bug (comment 18)  I still can't miro
to work correctly.  If I delete .miro/ .gconf/apps/miro and Movies/ AND reboot
my computer miro will work again for a single time when I try again (it acts
again like miro had never been run).  After this single time, I get the "An
unknown error has occurred while finishing starting up" error again :(  

I really want to get this to work.  :(
Comment 23 Allan Engelhardt 2007-08-16 03:54:04 EDT
Regarding Comment #21 and Comment 22 : When I said that Miro "Works For Me" I
meant that Miro starts up without the DBus errors.  Like Jack I find that after
the first run of Miro it is completely f***ed.

To be clear: Miro fixes the startup issue but is otherwise completely unusable
as an application.

Thorsten: Can I recommend that you do not push Miro to updates just yet, but
leave it in updates-testing?
Comment 24 Thorsten Scherf 2007-08-16 04:23:51 EDT
hm, this is strange. I tested it on different machines and it worked without any
problens. when this happen, could you try to use the menubar, open a file or
something like that, and report if problems goes away or not...
Comment 25 Allan Engelhardt 2007-08-16 09:47:54 EDT
Re Comment 24 : I created a few bug reports specifically for the Miro component.
 Hopefully they are detailed enough to reproduce.  Let me know what I can do to
help: I really want this to work.

https://bugzilla.redhat.com/bugzilla/buglist.cgi?product=Fedora&version=f7&component=Miro&bug_status=NEW&bug_status=ASSIGNED&bug_status=NEEDINFO&bug_status=MODIFIED&short_desc_type=allwordssubstr&short_desc=&long_desc_type=allwordssubstr&long_desc=
Comment 26 Thorsten Scherf 2007-08-16 09:51:53 EDT
will close here. all further bus reports should go to the miro component.
Comment 27 Jack Deslippe 2007-08-16 14:30:18 EDT
Thorsten, regarding your post on 24, my problem (which seems to be slightly
different than allane's) does not go away when I start miro by opening a file or
using the menu bar.  I still get the crash on startup.  I will post a new bug
report.

Note You need to log in before you can comment on or make changes to this bug.