Bug 245391 - VNC Server fails with depth of 24 pixels
VNC Server fails with depth of 24 pixels
Status: CLOSED DUPLICATE of bug 242277
Product: Fedora
Classification: Fedora
Component: vnc (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 15:52 EDT by Liam Dennehy
Modified: 2013-04-30 19:36 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 11:56:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
VNC Log output (831 bytes, text/plain)
2007-06-22 15:52 EDT, Liam Dennehy
no flags Details

  None (edit)
Description Liam Dennehy 2007-06-22 15:52:33 EDT
Description of problem:
creating a new VNC desktop with a depth of 8, 15 or 24 bits per pixel fails,
only 16 works.

Version-Release number of selected component (if applicable):
Xvnc 4.1.2

How reproducible:
Every time

Steps to Reproduce:
1. Launch a desktop with (e.g.)
vncserver :1 -geometry 1280x800 -depth 8
2.
3.
  
Actual results:
Silent failure, only log file reveals problem (and not being able to attach)

Expected results:
VNC desktop should be created

Additional info:
VNC desktop works jus fine for 16bpp
Comment 1 Liam Dennehy 2007-06-22 15:52:34 EDT
Created attachment 157642 [details]
VNC Log output
Comment 2 Liam Dennehy 2007-06-22 15:58:43 EDT
Hmmm, 8 is working now... 15 and 24 still fail.
Comment 3 Adam Tkac 2007-06-28 08:16:31 EDT
What says rpm -q vnc-server? Looks like dupe of bug #242277 for me.
vnc-server-4.1.2-18.fc7 could support depths 8, 16 and 24 without any problem.
15bpp depth isn't supported now because I think this depth isn't used. If you
need it I could add 15bpp support.

Regards, Adam
Comment 4 Adam Tkac 2007-07-02 11:56:21 EDT

*** This bug has been marked as a duplicate of 242277 ***
Comment 5 Liam Dennehy 2007-07-02 16:59:46 EDT
Thanks for the attention, I will monitor the original bug.

Note You need to log in before you can comment on or make changes to this bug.