Bug 245478 - screen flickers on every source /etc/init.d/functions
screen flickers on every source /etc/init.d/functions
Status: CLOSED DUPLICATE of bug 238300
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-06-23 16:49 EDT by Adam Pribyl
Modified: 2014-03-16 23:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-27 04:05:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Adam Pribyl 2007-06-23 16:49:59 EDT
Description of problem:
On various computers I observed strange screen flickering when Fedora is
shutting down. This is not normally noticable during startup due to RHGB but it
is present too.

Version-Release number of selected component (if applicable):

How reproducible:
Always - just try to e.g. restart network.

Steps to Reproduce:
1. shutdown
2. watch the screen
Actual results:
The screen flickers with every line printed on it. This is especially noticable
on slower machines and often with ATI Radeon 9xxx cards.

Expected results:
No flickers.

Additional info:
I identified, that this is due to sourcing /etc/init.d/functions. This is
sourced with every service start/stop/restart. In this function, it sources also
/etc/profile.d/lang.sh. lang.sh starts EVERY time the /bin/unicode_start. In
unicode_start there is always /bin/setfont $DEFAULT_UNICODE_FONT.
With every setfont the screen flickers. Is that really necessary to set font
with every line printed on screen??

I think the same problem is also present in Fedora 7. I report it against FC6 as
there I tested this.
Comment 1 Bill Nottingham 2007-06-25 12:37:55 EDT
Please actually test F7 - there were changes in this area.
Comment 2 cheguaka 2008-02-25 10:48:09 EST
Same in F7 and RHEL 5.1 
Comment 3 cheguaka 2008-02-25 11:07:37 EST
Seems duplicate
Comment 4 cheguaka 2008-02-25 11:08:14 EST

Comment 5 Adam Pribyl 2008-02-27 04:05:47 EST

*** This bug has been marked as a duplicate of 238300 ***

Note You need to log in before you can comment on or make changes to this bug.