Bug 245494 - RFE: split LSB init stuff into a redhat-lsb-init subpackage
RFE: split LSB init stuff into a redhat-lsb-init subpackage
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: redhat-lsb (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Lawrence Lim
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks: 515276 603578 607537
  Show dependency treegraph
 
Reported: 2007-06-24 06:19 EDT by Ville Skyttä
Modified: 2014-03-25 20:55 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-12 08:05:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
split desktop/printing into sub-packages (18.46 KB, patch)
2008-11-30 15:13 EST, Curtis Doty
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2007-06-24 06:19:09 EDT
With https://www.redhat.com/archives/fedora-devel-list/2007-June/msg02275.html,
it looks like LSB init stuff is becoming pretty much a mandatory package for
every setup.

However, on a fairly minimal current F-7 system:

$ sudo yum install redhat-lsb
[...]
=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 redhat-lsb              i386       3.1-14.fc7       fedora             21 k
Installing for dependencies:
 at                      i386       3.1.10-11.fc7    fedora             55 k
 bc                      i386       1.06-26          fedora            107 k
 binutils                i386       2.17.50.0.12-4   fedora            2.9 M
 cairo                   i386       1.4.4-1.fc7      fedora            500 k
 cups                    i386       1:1.2.10-10.fc7  fedora            2.9 M
 ed                      i386       0.5-1            fedora             57 k
 file                    i386       4.20-1.fc7       fedora             28 k
 file-libs               i386       4.20-1.fc7       fedora            311 k
 gettext                 i386       0.16.1-8.fc7     fedora            1.5 M
 groff                   i386       1.18.1.4-2       fedora            1.9 M
 libXft                  i386       2.1.12-1.fc7     fedora             44 k
 libXi                   i386       1.0.4-1          fedora             29 k
 libXrender              i386       0.9.2-1.fc7      fedora             27 k
 libXt                   i386       1.0.4-1.fc7      fedora            175 k
 libgomp                 i386       4.1.2-12         fedora             76 k
 libthai                 i386       0.1.7-5.fc7      fedora            154 k
 m4                      i386       1.4.8-2.fc7      fedora            175 k
 man                     i386       1.6e-3.fc7       fedora            267 k
 pango                   i386       1.16.4-1.fc7     fedora            356 k
 paps                    i386       0.6.6-19.fc7     fedora             32 k
 pax                     i386       3.4-1.2.2        fedora             63 k
 time                    i386       1.7-29.fc7       fedora             24 k
 tmpwatch                i386       2.9.11-1         fedora             19 k

Transaction Summary
=============================================================================
Install     24 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

That's a lot of unwanted dependencies.  To fix this, how about splitting
functionality related to LSB init scripts to a redhat-lsb-init subpackage, and
having the main redhat-lsb package require it?
Comment 1 Jon Stanley 2008-04-23 16:30:43 EDT
Adding FutureFeature keyword to RFE's.
Comment 2 Ville Skyttä 2008-08-13 01:06:19 EDT
I suppose the original threat did not occur after all, but redhat-lsb continues to pull in even more stuff in F-8 than it did in F-7, so perhaps the split would still be a good idea.
Comment 3 Curtis Doty 2008-11-30 15:13:56 EST
Created attachment 325142 [details]
split desktop/printing into sub-packages

First brutish attempt to jettison desktop specs into sub-packages.
Comment 4 Curtis Doty 2008-12-02 19:54:12 EST
This bug should block FedoraServerTracker bug.
Comment 5 Thayne Harbaugh 2008-12-03 11:36:28 EST
Not having fine-grained LSB capabilities has blocked a customer from
deploying software.  Software that doesn't require X, but uses lsb_release
and /lib/lsb/init-functions requires redhat-lsb.  The customer attempted to
install redhat-lsb and here is a portion of the response:

Well, we have a strict policy here (as do many companies) of no X GUI on Linux servers, so that's not an option for us. Why in the world do the latest util package require me to install X-everything on my server? I guess I'll go with 1.2 for now instead of 1.2.1, and until this is resolved we won't be installing anything newer than 1.2.
Comment 6 Matt Domsch 2009-04-01 16:43:51 EDT
I have the same concern.  lsb_release needs to be in a smaller package that doesn't require all the libraries...
Comment 8 Rehan Khan 2010-12-04 17:15:22 EST
I see that the graphics and printing has been split out of the rehat-lsb package. Any news on if the lsb init stuff will be split out as well?
Comment 9 Rehan Khan 2010-12-04 17:38:55 EST
It looks like there are some missing scripts in the lsb packages. The /lib/lsb/init-functions script calls some scripts in /etc/redhat-lsb


log_success_msg () {
	/etc/redhat-lsb/lsb_log_message success "$@"
}

log_failure_msg () {
	/etc/redhat-lsb/lsb_log_message failure "$@"
}

log_warning_msg () {
	/etc/redhat-lsb/lsb_log_message warning "$@"
}


These seem to be missing.

Installing the Redhat-lsb packages to enable the dkms_autoinstaller init script to produce useful messages on failure also does not resolve the problem as it calls a function called 'log_action_end_msg' which does not seem to exist.
Comment 10 Rehan Khan 2010-12-04 18:01:05 EST
Please ignore the comment about the dkms_installer init script. It turns out that although it sources the /lib/lsb/init-functions it does not use it as I assumed/thought.

The report about the missing files is still relevant though.
Comment 11 Rehan Khan 2010-12-04 18:04:19 EST
Sorry, please ignore the last two messages. They are both wrong. I seem to be confusing myself and polluting the bug.
Comment 12 Parag Nemade 2011-10-12 08:05:45 EDT
Sub-packaging is already done in Fedora. Closing this old bug. If needed any additional fix please open a new bug.

Note You need to log in before you can comment on or make changes to this bug.