Bug 515276 - "log_action_end_msg: command not found" when running dkms_autoinstaller
Summary: "log_action_end_msg: command not found" when running dkms_autoinstaller
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dkms
Version: 11
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Mario Limonciello
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 245494
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-03 15:11 UTC by Toralf
Modified: 2010-12-04 23:23 UTC (History)
5 users (show)

Fixed In Version: 2.1.0.1-1.fc10
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-28 18:23:28 UTC


Attachments (Terms of Use)

Description Toralf 2009-08-03 15:11:00 UTC
Description of problem:
With Fedora 11 and the latest updates, I find that dkms_autoinstaller does not work at all. It says:

/etc/rc5.d/S04dkms_autoinstaller: line 143: log_action_end_msg: command not found

on startup.

Version-Release number of selected component (if applicable):
2.0.21.1-2.fc11

How reproducible:
Every time

Steps to Reproduce:
1. Configure a module for dkms build...
2. Boot the system
  
Actual results:
Error reported - see above

Expected results:
Module is built and installed

Additional info:
I'm testing with the NVIDIA module distribution from rpmforge.net - 	http://apt.sw.be/fedora/10/en/i386/RPMS.rpmforge/nvidia-x11-drv-173.08-1.beta.fc10.fc10.rf.i386.rpm (there is no fc11 version yet, but surely that makes no difference in this context?)

Comment 1 Toralf 2009-08-03 15:32:26 UTC
After some further investigation, I found that the problem was caused by missing kernel headers - which had to do with the fact that a "yum upgrade" had somehow failed to install a new kernel-devel even though an old version was there. After installing the package in question, everything work as bit better - the build still fails, but I think this may be a problem with the module itself.

It seems to me that there is still a minor bug, though - surely the startup report failure, and not exit on script error when the headers are missing.

Comment 2 Matt Domsch 2009-08-03 15:53:59 UTC
This message is due to the initscript trying to use the LSB-approved functions, when the redhat-lsb package is not installed.  Ugh.  Marking this as depends on splitting redhat-lsb up, so we don't have to install many megabytes of libraries just to get these initscript-using echo functions.

Comment 3 Matt Domsch 2009-08-22 18:02:49 UTC
DKMS 2.1.0.0 removes the need for Requires: lsb.  This is built in rawhide, so please test it there if you can.  I'll think about building it for testing in F11 also.

Comment 4 Fedora Update System 2009-08-22 18:08:12 UTC
dkms-2.1.0.0-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/dkms-2.1.0.0-1.el5

Comment 5 Fedora Update System 2009-08-22 18:08:56 UTC
dkms-2.1.0.0-1.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/dkms-2.1.0.0-1.el4

Comment 6 Fedora Update System 2009-08-22 18:15:00 UTC
dkms-2.1.0.0-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/dkms-2.1.0.0-1.fc11

Comment 7 Fedora Update System 2009-08-25 04:32:49 UTC
dkms-2.1.0.0-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dkms'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8929

Comment 8 Fedora Update System 2009-08-25 16:02:58 UTC
dkms-2.1.0.0-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dkms'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0339

Comment 9 Fedora Update System 2009-08-25 16:03:22 UTC
dkms-2.1.0.0-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dkms'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-4/FEDORA-EPEL-2009-0316

Comment 10 Fedora Update System 2009-09-10 04:33:43 UTC
dkms-2.1.0.1-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/dkms-2.1.0.1-1.el5

Comment 11 Fedora Update System 2009-09-10 04:34:11 UTC
dkms-2.1.0.1-1.el4 has been submitted as an update for Fedora EPEL 4.
http://admin.fedoraproject.org/updates/dkms-2.1.0.1-1.el4

Comment 12 Fedora Update System 2009-09-10 04:34:40 UTC
dkms-2.1.0.1-1.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/dkms-2.1.0.1-1.fc11

Comment 13 Fedora Update System 2009-09-10 04:44:55 UTC
dkms-2.1.0.1-1.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/dkms-2.1.0.1-1.fc10

Comment 14 Fedora Update System 2009-09-10 22:56:33 UTC
dkms-2.1.0.1-1.el4 has been pushed to the Fedora EPEL 4 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dkms'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-4/FEDORA-EPEL-2009-0431

Comment 15 Fedora Update System 2009-09-10 22:56:46 UTC
dkms-2.1.0.1-1.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dkms'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0436

Comment 16 Fedora Update System 2009-09-11 23:25:10 UTC
dkms-2.1.0.1-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dkms'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-9486

Comment 17 Fedora Update System 2009-09-11 23:34:05 UTC
dkms-2.1.0.1-1.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update dkms'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-9510

Comment 18 Fedora Update System 2009-09-28 18:23:23 UTC
dkms-2.1.0.1-1.el4 has been pushed to the Fedora EPEL 4 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2009-09-28 18:23:43 UTC
dkms-2.1.0.1-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2009-09-29 14:29:21 UTC
dkms-2.1.0.1-1.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2009-09-29 14:34:47 UTC
dkms-2.1.0.1-1.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Chad Feller 2009-10-29 22:39:30 UTC
problem persists:

# /etc/init.d/dkms_autoinstaller start
Running DKMS auto installation service for kernel 2.6.18-164.2.1.el5
/etc/init.d/dkms_autoinstaller: line 143: log_action_end_msg: command not found

versions:

# rpm -q dkms redhat-lsb
dkms-2.1.0.1-1.el5
redhat-lsb-3.1-12.3.EL
redhat-lsb-3.1-12.3.EL

# cat /etc/redhat-release 
Red Hat Enterprise Linux Client release 5.4 (Tikanga)

# uname -srmpovi
Linux 2.6.18-164.2.1.el5 #1 SMP Mon Sep 21 04:37:42 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux

Comment 23 Chad Feller 2009-10-29 23:20:27 UTC
Note:

this only appears:
/etc/init.d/dkms_autoinstaller: line 143: log_action_end_msg: command not found
if there was an error.  if the module(s) build successfully, that message is not displayed.

on success I get:
# /etc/init.d/dkms_autoinstaller start
Running DKMS auto installation service for kernel 2.6.18-164.2.1.el5
Done

Comment 24 Rehan Khan 2010-12-04 22:09:23 UTC
This issue is also present in F14. None of the redhat-lsb rpms are installed on a default install.

redhat-lsb
redhat-lsb-graphics
redhat-lsb-printing

The descriptions of each package don't really give much away. Has anything changed with respect to these?

Installing the above rpms also pulls in pax, gettext and gettext-libs for a total install of 6.7MB on disk (according to smart package manager). Doesn't seem too much for a desktop machine?

Comment 25 Rehan Khan 2010-12-04 22:43:39 UTC
Some further information:

Installing the Redhat LSB packages does not solve the problem :(

It looks like the logging functions in /lib/lsb/init-functions calls some scripts in /etc/redhat-lsb which are missing. I have reported this here:

https://bugzilla.redhat.com/show_bug.cgi?id=245494

in any case the dkms init script uses a function called 'log_action_end_msg' which does not seem to be supported in /lib/lsb/init-functions. It also references this as '$DEBIAN_STYLE_LOGGING'. Should this not be closer to LSB style logging?

Does any of this even matter for the future with systemd on the horizon?

Also I can't seem to re-open the ticket.

cheers

Comment 26 Rehan Khan 2010-12-04 23:23:31 UTC
Sorry, please ignore the comments about the missing functions (they actually exist) and the '$DEBIAN_STYLE_LOGGING', I misread the script.

Although the dkms_installer script sources /lib/lsb/init-functions it does not seem to use those functions. Very confusing for those not quite paying attention like myself.

The original error reported in the bug is due to the 'log_action_end_msg 1' not being wrapped in an if statement.

Making it look like this:

		if [ ! -z "$DEBIAN_STYLE_LOGGING" ]; then                        
			log_action_end_msg 1
                fi

fixes the error message. 

Would that mean that on Fedora the script fails silently (no indication to the user that the modules are not built)?


Note You need to log in before you can comment on or make changes to this bug.