Bug 245510 - thunderbird- crashes evrytime after a reboot (segfaults)
thunderbird- crashes evrytime after a reboot (segfaults)
Status: CLOSED DUPLICATE of bug 429339
Product: Fedora
Classification: Fedora
Component: thunderbird (Show other bugs)
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-06-24 14:00 EDT by Gaveen
Modified: 2008-02-28 09:37 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-28 09:37:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Gaveen 2007-06-24 14:00:17 EDT
Description of problem:
I installed directly thunderbird- using yum from Fedora
updates repo and copied my old .thunderbird (from a FC6 with Thunderbird 2.0.0.x
package from Mozilla). After the installation I executed it a few times (worked
fine) then rebooted the computer. After a reboot Thunderbird crashes when I try
to view any mail (new or old) from any local Inbox folder.

I tried to reproduce the scenario by removing Thunderbird (and .thunderbird dir)
and then installing a fresh copy. Each and everytime I tried with the following
steps, I succeeded.

Version-Release number of selected component (if applicable):
lightning addon 0.3.1

How reproducible:
After a reboot of the computer Thunderbird segfaults when tried to view a mail

Steps to Reproduce:
1. Install thunderbird-
2. Copy old .thunderbird directory to the home dir
3. Use Thunderbird a few times
4. Exit Thunderbird and reboot the computer
5. After the reboot run Thunderbird and try to read any mail

Actual results:
Thunderbird segfaults and goes away

Expected results:
Thunderbird stays and works normally

Additional info:
I did a strace, and here's the last few lines

munmap(0xb3c1b000, 86653)               = 0
munmap(0xeda000, 317920)                = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
unlink("/home/xxxxxx/.thunderbird/nv0dw436.default/lock") = 0
rt_sigaction(SIGSEGV, {SIG_DFL}, NULL, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [SEGV], NULL, 8) = 0
tgkill(5512, 5512, SIGSEGV)             = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++
Comment 1 Christopher Aillon 2007-06-25 16:14:02 EDT
I'm a little confused as to what exactly you did with your .thunderbird
Comment 2 Gaveen 2007-06-27 01:35:42 EDT
I just copied my old .thunderbird dir to my home directory, after installing

I was earlier running a Thunderbird 2.0.0.x (where x is 3, I guess) on FC6
without trouble. I wanted to keep my mails, filters, account configs and stored
passwords. So I copied the old .thunderbird dir to my home directory in F7 and
started using the newly installed Thunderbird.

As I said there was no trouble before restarting. All my old mail was
accessible, my account settings and passwords were were working. Even my
previously installed Lightning addon was available.
Comment 3 Christopher Aillon 2007-06-27 12:20:16 EDT
Does the lock file exist in your profile?  If so, can you remove it and see if
that helps?

Also, it's possible that a lightning requirement changed in FC6->FC7.  Can you
move the .thunderbird out of the way and try again with a fresh profile to see
if it starts up normally with a clean profile?
Comment 4 Gaveen 2007-06-27 13:05:07 EDT
I checked and the lock file doesn't exist. 

Then I removed .thunderbird and started with a fresh profile. It seems to work
fine. But I only tested with one reboot.

Anyway I wouldn't want to use Thunderbird without my earlier things like mails,
mail filters, account settings, and etc.
Comment 5 Christopher Aillon 2007-06-27 13:13:28 EDT
Yup, just trying to track down if it's Thunderbird or something in your profile
that it doesn't like.  My next guess has to be Lightning... 

Can you put the profile back and this time rm -rf extensions* and see if that helps?
Comment 6 Gaveen 2007-06-27 13:29:55 EDT
I think Lightning addon (remaining in the profile from my earlier Thunderbird
installation) was the culprit as you guessed. :)

As Thunderbird crashed only when I tried to view mail I was able to go and
uninstall Lightning addon. After that crashing ceased. However I have to install
Lightning later if I want the calendar.

However I switched back to using Evolution as my e mail client. In my point of
view Thunderbird is not yet up to where Evo is. I guess Thunderbird still has
things to do before it reaches the brilliance which Fx is having in browser
market. :)

It might have been the addon (which remained in my .thunderbird backup) which
caused the crashing. This means I have to uninstall to addon and later install
it (freshly for this Thunderbird installation) if I want it. 

I guess this still isn't what you exactly wanted Thunderbird to behave. So I
guess this still is a bug or s compatibility issue which users have to be aware
of, right? Hope this helps :)
Comment 7 Matěj Cepl 2008-02-28 09:37:57 EST

*** This bug has been marked as a duplicate of 429339 ***

Note You need to log in before you can comment on or make changes to this bug.